Macbook stuck in white, have upgrade dvd--can I boot from it?

Discussion in 'MacBook' started by mags299, Jan 6, 2009.

  1. mags299 macrumors newbie

    Joined:
    Jan 6, 2009
    #1
    Hello, I have been doing searches to see if I can solve my white screen problem on my macbook running tiger, but haven't found a thread that gets all my problems so I am trying to see if I am piecing things together correctly.

    So, again, Macbook will not load, get the white screen, apple logo, and twirling thing--just that "forever". I have been able to firewire to an old mac and recover all the data as if it were an external HD. Was told at a mac help store (live in France, no genius bars, helas) that if I could get all the data, then should be able to boot from the install disk.

    That is where I am today--trying to see if this will work--but I do not have an "install DVD", I seem only (as I doubt I did not keep every disk when I purchased in the States in '07) to have been given the Tiger "upgrade DVD".

    I tried loading it and restarting with the "c" key held down. Nothing happens different than before for 10 minutes of trying with the key depressed.

    That said!, does anyone know if I can use the "upgrade DVD" to boot from? And if holding the "c" key is the way when you have white screen issues.

    Thanks in advance for your advice--I can go find an install disk if I need to, but if the upgrade is as good for this, then maybe I need a new macbook?

    thanks
     
  2. dariusperkins macrumors newbie

    Joined:
    Sep 17, 2007
    #2
    I can boot from my Leopard upgrade DVD that came with an iMac on any [10.5-supported] Mac. I'm guessing the same should be true of Tiger. Did you hear the 'gong' on startup, or a disconcerting beep?
     
  3. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #3
    Is it a universal tiger DVD? If its the old PPC architecture DVD then you won't be able to boot it.

    Have you got access to another machine? Try a linux Live CD if you can download one. If this boots you know the hardware is fine.
     
  4. bsheridan macrumors 6502

    bsheridan

    Joined:
    Jan 11, 2008
    #4
    you say you were able to firewire to an old mac.
    Without the access to boot discs you could try target disk mode:
    • On your old mac, got to System Pref | Startup Disk | Target Disk mode. (hopefully your old mac is not too old that it still has this feature?)
    • Connect your old mac to your Macbook.
    • Turn on your Macbook and after the 'chime' at startup hold the option key (between ctrl and :apple: keys)
    • Select the old macs hard drive to boot from. If you can boot successfully, the problem then probably lies with the Macbooks HD.

    b.
     
  5. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #5
    OK--thanks for the replies, first.

    I hear the gong, like normal when I start.
    I do not know how to tell if it is universal or PPC??? So my other mac is a powerbook G4 with tiger--I will try to look for the linux cd--though I am not sure how I reboot the macbook thru the G4--???
    I will also try the target disk mode--it is not that old it seems--though it seems scary to me!!
    Thanks again....
    mags
     
  6. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #6
    put G4 in target mode--it restarted and came up with the firewire symbol. I then started the macbook holding down the option key--and got the white screen with a HD icon with a little arrow below pointing up to the icon.
    First time I clicked the arrow, and it went to the white screen with the apple icon and then nothing different than not loading before.
    Second I restarted the macbook with option key and clicked the HD icon. No difference.
    Any of this make sense? Am I doing it right? I held the option key when hitting the power botton....

    Off to look for a linux live CD....
     
  7. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #7
    Did the disk come with the macbook or the G4? If the live CD works you most probably have a PPC disk.

    To boot the live cd, power on the machine insert the CD and hold the coption key (between CTRL & CMD), you will then get a menu appear, scroll and select the Live CD.
     
  8. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #8
    Aaack! Just read again, will try again with the option key after the chime, like I was told...opps.
     
  9. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #9
    After the chime--same deal. Back to looking for the live cd...
     
  10. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #10
    turns out the update came with or I got after the G4--so not install for the macbook at all--will have to look again for it, though I thought I was good about keeping it all in one place....
    Meanwhile--I am afraid I am not savvy enough to get this liveCD thing. I tried to search for a downloadable live cd for tiger--and got something for computers before 2004.

    I am assuming that I find this file, a linux liveCD file that has tiger install stuff, burn that file to a cd (on a computer that works!) and then take the cd and put it in the macbook to to do the start, option, to get the menu etc...
    Yes?

    I am not good at the background stuff with computers--so you have to talk to me like I am a 4 year old--thanks!!!
    :eek:
     
  11. bsheridan macrumors 6502

    bsheridan

    Joined:
    Jan 11, 2008
    #11
    Can you confirm which HD appears on screen after you press the option key. Is it the Macbook's HD or is it the G4's HD?
     
  12. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #12
    No worries dude.

    Download this to test it:

    http://ubuntu.virginmedia.com/releases/intrepid/ubuntu-8.10-desktop-i386.iso

    once you have burned this, throw it in your macbook wait for the chime and hold down the option key. When the menu appears select the CD icon.

    Then all you need to do is select "Try Ubuntu" from the boot screen and let it load. As said before if this works hard drive issues are possible. But you are in luck as I have a 120GB MacBook drive spare so PM me with address details, no charge.
     
  13. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #14
    Way man, how did you know I am from California, dude?? :D

    I have not been able to try the next steps--the computer that can burn things went off to work today--so I hope to give it a go this evening.
    And I cannot confirm which HD--it is just the icon with the title macintosh HD--but both of them (old g4 and macbook) are called that, so I didn't see anything else to tell me which HD.

    Meanwhile thanks for the attention!

    I was also looking at the apple pages--people were saying that installing from a retail tiger doesn't seem to work--but does from a retail leopard--any one with an opinion on if that works even if the machine had only tiger on before? Though I can get a bundled leopard, I would have to purchase the retail...hmmn.

    Will report back.

    Thanks.
     
  14. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #15
    Update...:

    Burned the .iso file to a cd. Put the cd into the macbook, started, heard the chime, pressed option, held--the same Macintosh HD title and icon appeared with the same little arrow under. No other menu to choose from.

    So what does that mean????
    Did I want HD issues, because that would mean change it and it works after, but since it didn't work, I basically still don't know how to fix?

    Am getting the leopard install files sent--not for my macbook, and not retail--but no cost so I thought I would give it a try....

    Thanks for the link and help navigating this.

    m
     
  15. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #16
    Hmmmm, there is no CD icon at all? That is strange....

    There is another option to boot from CD. With the disk in the drive, when your mac chimes hold down the 'C' key, this is a direct boot from CD option with out the selection menu.

    Another issue could be with the CD, try re burning the CD at a low speed (2-4x). If this doesnt work then there could be CD drive issues.

    Let us know how you get on.
     
  16. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #17
    Hello.

    So, the "c" key got me just my now normal white screen icon and twirl.

    Some things I wonder if they are relevant:
    1-the day it went white I had a home movie DVD (ie I burned it, not a studio DVD) in the drive. Would that have caused any hiccups for starting up? (I had to find the hold-pad-down trick to get it to eject)
    2-the .iso file--it just that as burned. When you look at it on the CD it has that piece of paper with the HD icon on it above the title. Not the white, don't know how to describe it, low white 3D box that looks sort of like a fancy macwhite external drive, if you know what I mean. Is there a special way to burn the file on the CD, or dragging and dropping on to the blank cd drive and hitting burn is the right way?
    3-last thing I thought of, before the white screen forever I had a few times where I would put the top down and it would not sleep, or I would open it quickly after having put it to sleep--because I remembered something...--and it would not wake up. I think I even had force shut down once or twice because it was just black despite pressing keys... I don't know, does that give any clues to what may be up with this macbook?

    OK. Thanks.
     
  17. msjones macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #18
    have you burned the ISO as a disk image or have you just dragged and dropped the .iso on the CD?

    What application do you use for burning?
     
  18. mags299 thread starter macrumors newbie

    Joined:
    Jan 6, 2009
    #19
    Hello--to anyone still out there...

    I just got the leopard disks so have tried again....
    To answer the last question--I did only a .iso burn--did not have access to a computer to make a disk image.

    otherwise, with the leopard install disks that came with another macbook, I am able to get a new screen!
    I pressed "c", get a blue screen after a few minutes, then a starscape background with a box that asks what language to make the main one, choose english, and then the mac install menu appears at top, and a dialog box that says something like "Mac OS X.5.2 cannot be installed on this computer" and "OK" or "restart".
    If I restart then it is back to the white screen.
    So I tried many things on the menu--Disk utility--repaired the HD and it said it appears to be fine.
    There is the erase disk option--but I did not do it as I am not sure if that is the sound thing to do.
    Went to the start-up disk. tried to start-up from the HD, white screen. From the install disk, same dialog box about can't install on this computer.

    If I quit the install--it is like one o the start-up options.

    The airport appears in the top right corner--and I was able to connect with the password--but that didn't seem to change anything.

    feels like I am so close, I mean it was acting like a computer--except not.

    Any ideas? Is it because the leopard install disks are not retail?
    Does this sound like a "hard drive issue", and if so what does that mean? The operating system is ok, the software, but the harddrive part of the hardware is not working?

    And does any one know if buying the leopard retail would solve this?
    Should I erase the disk?--though maybe not if I don't have leopard that "can install"?

    Thanks for any help, insights, advice!

    Mags299
     

Share This Page