MacBook takes 10mins to start

Discussion in 'MacBook Pro' started by lokster, Sep 17, 2014.

  1. lokster macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #1
    So I have a 2010 MacBook that boots up really slow, sigh a few weeks ago it was fine, I stopped using it when I was building my desktop.

    Now it's sluggish on everything, from browsing and just trying to use disk utility,

    I don't know if it's a hard drive problem or a board problem, I'm really hoping it's the first one, because I just got this laptop second hand from a friend Month and a half ago .

    I swear two weeks ago it was perfectly fine :(
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Boot in Safe Mode, that will disable all login items, if that is OK you will have to work through each login item to see which one(s) are causing the issue...
     
  3. lokster thread starter macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #3
    whatever it takes to fix it without having to replace any hardware.

    im wondering why this is happening, two weeks ago it was perfectly fine, i didnt update or add any new programs.

    when it was on and im browsing and stuff its perfectly fine, after sometime it will slow down to a halt and i have to hard reset the laptop. and wait another 10 minutes.

    il try sorting it out later and boot safe mode
     
  4. Lachhh macrumors regular

    Joined:
    Aug 30, 2014
    Location:
    Mainland Europe
    #4
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    I'm with Lachhh... bad drive. Less common but also could be a bad drive cable.
     

Share This Page