Macbook trackpad is driving me insane

Discussion in 'MacBook' started by sunsetblow, Aug 18, 2016.

  1. sunsetblow macrumors regular

    sunsetblow

    Joined:
    Jul 6, 2013
    #1
    I thought having a super wide trackpad would be nice but literally the pads of bottom of my thumbs continually activate the pad while I'm typing so it'll click somewhere in the middle of the sentence and I'll end up typing in the middle of a previous sentence.

    Anyone else experience this and found a fix? The keyboard is almost unusable to me like this.
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    Does it make a difference with "Ignore accidental inputs (or whatever that setting is)" in the trackpad pref pane?

    Maybe one of those keyboard wrist rests would help you? That's one of those pads that are 10 or 12-inches long, and about 1-1/2 or 2 inches wide. If you can't type without touching your wrist to the trackpad, maybe an external pad like that might help...
    I can't offer much more than that - my thumbs (and associated hand parts) almost never touch the pad area, unless I am tapping there. I guess that was part of the goal of that touch-typing course that I took years ago (on that old IBM Selectric :D )
     
  3. Coco Nuts macrumors newbie

    Coco Nuts

    Joined:
    Jan 1, 2016
    #3
    You could try turning off tap to click. Saves a lot of accidental clicks.
     
  4. sunsetblow thread starter macrumors regular

    sunsetblow

    Joined:
    Jul 6, 2013
    #4
    I'm not seeing the "ignore" option that you're talking about. I'm on the Sierra public beta.

    I'd prefer to go without the wrist wrests! I got this MacBook for its ultra portability... would suck to mess that up having to carry that accessory :p

    Ah true. I love double tap to select with my finger though.. don't know if I could live without that!
    --- Post Merged, Aug 19, 2016 ---
    Ah, some googling shows that the "ignore" option has been removed and is on by default now. Makes sense.

    Others have suggested to switch click sensing to "Firm".

    Very annoying that this is something that needs to be messed around with in the first place!
     
  5. JamesGoodman macrumors member

    Joined:
    Dec 3, 2015
    #5


    I've had the computer since January and the exact same problem hsa been driving me completely nuts. It must just be the way that same people type or use the trackpad. I had to shut off tap to click -- which I much prefer and set the click pressure to firm, as others have suggested. But it is a real compromise that sholdn't be necessary.

    I have been using laptops and notebooks since the middle of the 1980s, first PC compatibles and then after I gave up on Windows 97 or 98 PowerBooks and MacBooks. I have adjusted to every single keyboard in a matter of days. Not this one. I find it the worst keyboard on any Apple computer I have ever owned or used or far inferior to the Thinkpads, Sharps, and Toshibas in years passed. I use a Bluetooth keyboard whenever I am at home, but I am early awaiting the new MacBook Pros and praying that this keyboard is not the keyboard of the future for Apple.
     
  6. kis macrumors 65816

    Joined:
    Aug 10, 2007
    Location:
    Switzerland
    #6
    I've hated the Macbook's trackpad from day one. I also own a Macbook Pro with the force touch trackpad and it's perfectly fine. Don't know why the one on the Macbook is worse. Probably had to compromise in terms of thinness again.

    Honestly: I actually prefer the touchpad on the Surface Book over than on the Macbook.
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    And, that's why there are settings. I, for one, detest tap to click. It's the first thing that I turn off when going from one laptop to another - mostly because my fingers can't get the "finesse" that's needed to avoid clicking on something accidentally every time I touch the trackpad. For me, windows laptop trackpads are the worst. Its something to do with the windows normal response to pressure. I have tried multiple times over the years, and can't get it. So, tap-to-click is off.
    I tried out the pad on a Surface Book recently. I could never use it. That touchpad felt worse than the cheap junk in netbooks a few years back. I did only use it for a short time, a couple of hours, but glad to give it up, too. Maybe it was just a faulty one. The owner didn't have much good to say about it at the time, either.
    Just my experience, and I have another friend who can't live without tap-to-click. He doesn't understand my problem either, but everybody is different.
     
  8. oldmacs macrumors 68040

    Joined:
    Sep 14, 2010
    Location:
    Australia
    #8
    Is this because the force touch MacBook trackpad is clickable everywhere?
     
  9. sunsetblow thread starter macrumors regular

    sunsetblow

    Joined:
    Jul 6, 2013
    #9
    OH. So tap to click only controls the one tap setting. I can still double tap to select a word, and triple tap to select a whole paragraph.

    This solves my problem entirely (I think)!
     
  10. sunsetblow thread starter macrumors regular

    sunsetblow

    Joined:
    Jul 6, 2013
    #10
    Update: Nope. Even with tap to click off, it still somehow activates while I'm typing.

    AGHHHHHHHHHHHHHHHH.
     
  11. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #11
    Learn to change your hand position when typing, so you hand/wrist is held above that area.

    "muscle memory" is hard to overcome for some folks... Good luck on that.
     
  12. Photios macrumors member

    Photios

    Joined:
    May 17, 2009
    #12
    Yes... i have this exact same problem. I'm trying to figure out exactly how I'm triggering it. I sure would like a solution too.
     

Share This Page