Macbook Tries to Boot into Windows - Windows NOT installed!!

Discussion in 'MacBook' started by lildudejds, Dec 15, 2008.

  1. lildudejds macrumors newbie

    Joined:
    Oct 15, 2008
    #1
    At one time I tried to install windows xp with boot camp. It wouldn't work so i gave up, deleted the disk partition I had for windows, and made sure that i checked to boot into OS X in system Prefs.

    But for some reason, Any time I restart the computer it tries to boot into windows I think. It goes to a black screen that says "no bootable device found, please insert install disk and press any key", or something like that. Nothing works, and I have to to turn it off, turn it on, hold option, and click Macintosh HD to boot to(it's the ONLY option, no windows option). It's really annoying to have to do that every single time I restart my computer. Anybody know what's going on?
     
  2. tubbymac macrumors 65816

    tubbymac

    Joined:
    Nov 6, 2008
    #2
    System Preferences > System > Startup Disk

    That will let you choose/change which partition is used by default when you boot up.

    If you didn't use bootcamp assistant to remove the windows partition, and just manually removed it yourself, that could be why you're experiencing this problem.

    Try running bootcamp assistant again and see if your windows stuff shows up and if it will let you delete it.
     
  3. PeterQC macrumors 6502a

    PeterQC

    Joined:
    Jun 30, 2008
    #3
    At boot, let press Alt/Option and you should have after 20 secs the booting choice menu.

    Edit: Nevermind.
     
  4. lildudejds thread starter macrumors newbie

    Joined:
    Oct 15, 2008
    #4
    Thanks, but like I said in my original post, I tried this already. It is set to boot into os X. In fact, that is the ONLY option, which makes me wonder why it tries to boot into windows.

    I did use bootcamp, and I already removed the partition.
     
  5. tubbymac macrumors 65816

    tubbymac

    Joined:
    Nov 6, 2008
    #5
    If you used the bootcamp assistant to remove the partition, then my guess is that during the update of the boot sequence the program couldn't change the settings. That could have been a result of a failed permission.

    To test this, use disk utility to repair your disk permissions, then use the bootcamp assistant to make another windows partititon. After it does that, use the assistant to remove the partition. It will attempt to update the boot sequence again and with proper permissions that may fix your problem.
     
  6. dnguyen macrumors regular

    Joined:
    Jun 9, 2008
    #6
    did you install windows xp that wasn't at least sp2? i did that and it effed up my osx os.
     
  7. jsdc2005 macrumors member

    Joined:
    May 13, 2009
    #7
    For what it's worth, I just encountered this exact problem, and this solved it. Thanks!
     

Share This Page