MacBook turns on, then suddenly off before chime

Discussion in 'Mac Basics and Help' started by LimeiBook86, Apr 5, 2011.

  1. LimeiBook86 macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #1
    Hello,

    My co-worker gave me her MacBook to look at today. It's a 13" White Core 2 Duo with a Combo Drive from either 2007 or 2008 I think.

    Anyway this happens if it's plugged into the AC adapter (with and without the battery) or if it's just on the battery. I press the power button, the optical drive makes it's usual noises, the hard drive attempts to spin up then suddenly - nothing, the laptop goes dead and everything goes quiet. No matter how many attempts with trying to turn it on, it just won't budge. Tried resetting the SMC, still no luck.

    Any ideas?

    Thanks!
    -Steve
     
  2. tpavur macrumors regular

    Joined:
    Sep 8, 2010
    #2
    possibly bad ram? faulty HDD? do you have ram or HDD you could switch it out with to try? any disc in the drive? if so remove it. also did you try booting off the OSx disc?
     
  3. LimeiBook86, Apr 5, 2011
    Last edited: Apr 5, 2011

    LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #3
    Thanks for the reply. I removed the RAM and hard drive. The screen will flicker very quickly, just enough to see a flash of light. With one stick of RAM in it'll do the same (still with the HD out). Odd :confused:

    I hope it's not the logic board... :eek:

    Update: When installed the hard drive is spinning up, screen is blank, LED on the MacBook is off, so the system is getting some sort of power. Hm!
     
  4. tpavur macrumors regular

    Joined:
    Sep 8, 2010
    #4
    you need to try a diffrent HDD, and diffrent ram... I have a feeling it's a faulty drive... did you boot off the disc?
     
  5. LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #5
    I'm at the office so I don't have a spare drive with me - but I'm going to see if I can find a screwdriver and open the top case up to see if anything is obviously wrong. I don't have a optical disc to boot up to - and the disc drive won't accept a disc... The disc drive is no longer making noise, maybe it shorted out or something. I didn't hear the fan turning, maybe something is disconnected. I have a spare drive and RAM at home, so I can test it with that later.

    I'll keep you all updated, thanks for your help! :)
     
  6. LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #6
    So I removed the top case, the fan will spin for a second, and then stop... I tried disconnecting the optical drive cable, no difference.

    Also removed the display data cable, display power, hard drive cable and optical disc cable, magsafe power cable (internal) - no difference. Put in the battery, fan shifts for a second, then everything stops. Got the fan to spin a bit longer, still no boot. I'll keep playing... :confused:
     
  7. tpavur macrumors regular

    Joined:
    Sep 8, 2010
    #7
    I would bet this is a HDD or ram issue, it's no use trying to trouble shoot this thing without having everything you need.
     
  8. LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #8
    Took everything out (HD, RAM, optical drive), disconnected every cable on the board. Still the fan (when connected) will just twitch. The LED won't blink (when connected) even without RAM. Sadly I think the logic board may be dead. :(
     
  9. dgbowers macrumors member

    dgbowers

    Joined:
    Apr 5, 2011
    Location:
    Alabama
    #9
    Sounds like the internal power supply to me (which is soldered on the Logic Board :( ) Bummer
     

Share This Page