Macbook unibody display problems

Discussion in 'MacBook' started by o2xygen, May 7, 2010.

  1. o2xygen macrumors regular

    Joined:
    Jan 25, 2009
    #1
    Hey guys,

    Well my unibody macbook display decided to screw up last night, it was working fine last night no problem. Connected to a external monitor. I fell asleep last night with front row left on, obviously it went to sleep and then I woke up and the screen was black.

    Now the LED lights are working, my external display is also working. The display settings recognize a screen being present (when I click detect displays and gather windows - 2 windows appear). Ive reset PRAM, SMC, reseated the RAM, control+shift+eject (which just made the screen flicker a little after turning it back on) and Im out of ideas. Its out of warranty and about about 18months old.

    Any ideas?
     
  2. chill. macrumors 6502

    Joined:
    Sep 1, 2008
    #2
    your macbook's display is working fine when not connecting to the external, but when connected to an external the external is black but the macbook's display still works - is this the case for you?

    i've had this problem before. try connecting the macbook to a different external display, and then connect back to your original external display.

    sometimes the macbook stops detecting a particular external display and needs to connect to different one to reset some settings
     
  3. o2xygen thread starter macrumors regular

    Joined:
    Jan 25, 2009
    #3
    It doesnt work whether connected to an external monitor or not. It began working again for about a day then stopped again.
     
  4. max¥¥ macrumors 6502a

    Joined:
    Aug 7, 2008
    Location:
    Over there....
    #4
    if the external display is working it and the internal is recognized but black it ma be the backlight
     
  5. gianmarc macrumors newbie

    Joined:
    May 16, 2010
    #5
    I'm having the same problem with my mini-DP to DVI adapter.

    It was working this morning hooked to my Samsung 30" LCD TV via a dvi to hdmi cable. I went out and returned, and moved it over to my Samsung 22" LCD Monitor which was working yesterday without fail. I connect to this using a DVI to DVI cable with the adapter previously mentioned, but today my MacBook 5,1 wouldn't detect the monitor. Power to the monitor is there, and it the MB screen flickers once when I plug the adapter in or out but in the display settings nothing shows! I selected detect displays but nothing still.
    I've reset the PRAM, and SMC.

    It's been working for weeks now and then all of a sudden. I've even used an older MBP with straight DVI to DVI to my monitor and it works, so I'm thinking it's the adapter. It's a knock off from eBay but how can it just stop working all of a sudden? I don't see any prong damage but who knows?!

    Any advice?
    Thanks!
     

Share This Page