Resolved MacBook USB3 Windows 7x64 Flash Drive Booting (SOLVED)

Discussion in 'Windows, Linux & Others on the Mac' started by rezwits, Jun 10, 2013.

  1. rezwits macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #1
    I finally successfully finished this DAMN project, using my Mac Pro (for VMWare) and MacBook Air 11 (2012), should work on Retinas with USB3

    HERE ARE QUICK ROUGH DRAFT INSTRUCTIONS, taking a nap B4 WWDC

    first of all I right click or shift F10, every windows app launch so…

    You need:

    a USB2 spliter cable, or USB2 hub would work.

    The main thing with this, and others may have run into this when trying to install Windows
    from a USB Flash Drive is that if you use USB3 after you get half way the drive disappears
    If you boot from a USB3 you get blue screen, but if you downgrade your USB3 to USB2
    with a USB2 splitter or USB2 Hub you can install and boot, then patch later for
    final USB3 booting, this is the main trick of this install!

    Paragon NTFS (not required but nice)
    Virtual Clone Drive (slysoft, free)
    RMPrepUSB
    NT6_Fast_Installer

    VMWare Running with Windows 7 x64
    Windows 7 x64 .iso
    WAIK 7

    BootCamp 5 drivers, with $WinPEDriver$, and AutoUnattend.xml

    USB3 Flashdrive 32GB min I prefer 64GB Mushkin (sucker is reliable and fast)

    Instructions:

    I prefer to start as RAW as possible, covering as many bases as possible.

    Insert USB3 flash in Mac, open Disk Utility
    Select Flash DRIVE not volume
    Select Partition TAB
    Choose 1 Partition
    Select Options… and select MBR
    Name your Volume
    Select Format Windows NT (compressed), if you can't pick FAT
    APPLY
    Eject Flash Drive

    Launch VMWare (I used 5) with Windows 7 x64 installed
    After VMWare is up and running
    Have access to Windows 7 iso in VMmachine
    mount WAIK iso using Virtual Clone Drive
    install WAIK

    Insert Flash and click Open with Windows when VMWare asks
    have VMWare always ask you, ie don't remember choice

    Launch RMPrepUSB
    Make sure your Flash Drive is selected
    Select No user prompts
    Select WinPEv2/etc
    Select NTFS
    Click 6 Prepare Drive
    Exit

    mount your Windows 7 x64 iso using Virtual Clone Drive
    In the NT6_Fast_Installer folder there is a file called
    INSTALLER, run that
    press enter
    press enter
    Select install.wim from Windows ISO in sources Folder at root
    Select your install flavor
    Select your USB Drive Letter
    Select your USB Drive Letter again
    Select Enter to use C: as final drive Letter
    Then I believe it's press any key to start
    After this is done in about an hour, eject the Flash Drive

    At this point you need to goto your MacBook Air 2012 and boot up Mac OS X
    create a new VMWare machine do custom machine, select WIndows 7 x64 etc
    choose without disk custom options, do not run or boot, select 2 cores and 2 GB ram
    or more if you have it, quit VMWare

    Insert your USB3 flash drive after boot without USB2 splitter
    Launch Terminal
    Type or Copy paste these lines line by line:
    cd /Applications/VMware\ Fusion.app/Contents/Library
    diskutil list
    <note: locate your USB3 flash drive's disk# and part# like disk1 1>
    sudo ./vmware-rawdiskCreator create /dev/disk1 1 "/Users/<user>/Documents/Virtual Disk" ide
    <note: put your user name in damit :p>
    goto Documents folder look in Virtual Machines folder
    right click Windows 7 file show package contents
    delete all *.vmdk files
    take the two vmdk files called Virtual Disk right next to Virtual Machines folder in Docs
    and drag to Virtual Machines folder
    get info on Virtual Machines folder and propigate permissions
    drag Virtual Disk.vmdk files to Window 7 package that is open
    close Windows 7 package

    Launch VMWare again and Boot From USB3 Flash Drive with Virtual Machine
    After about 30-40 minutes you can get in and install VMWare tools, you should
    After reboots are clean
    Shutdown and make sure USB is on Desktop
    Copy over contents of BootCamp5.x.x to root of FlashDrive
    Launch VMware again and Boot Virtual Machine

    goto start menu type cmd run as admin!!
    type cd c:\BootCamp\Drivers\Apple\
    type msiexec /i BootCamp.msi
    msi is your friend! :p
    You have to install in VMWare cause the installer rejects and has errors if you do native
    after installs are done and reboots are clean
    shutdown VMWare

    using option key or NTFS Pane select your USB3 flash drive as Boot
    your USB3 has to be plugged into USB2 splitter hub to boot properly
    after you login you will wait for all the Apple Drivers to load and load
    use tab key and apple key when trackpad goes out to reboot after they are all done

    NOTE: You do not want to install any MS updates till all done with drivers
    or they won't load

    at this point you want to make sure you reboots are clean
    you have to manually download USB3 driver cause apple wont launch
    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21129&lang=eng

    after installing USB3 driver you have to regedit
    HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet001 -> services -> iusb3hub
    HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet001 -> services -> iusb3xhc
    I changed "Start" to "0" and "Group" to "Boot Bus*Extender"

    after you reboot you will crash if you are still plugged into USB2 splitter
    so plug directly in USB3, select boot normally all the time if you blue screen

    You should be booting USB3 from your flash drive
    If you restart you can leave flash drive plugged in USB3 and boot mac
    If you want you can launch VMWare and use flash drive in VMWare Machine

    So there you have it
    Any Which Way You Want IT!

    Boot native USB3 Flash Drive
    Boot vmware USB3 Flash Drive

    Yeah it's OVER
    :(

    googled sources
    http://www.youtube.com/watch?v=uvWGV9YJxfQ
    https://sites.google.com/a/rmprepusb.com/www/tutorials/win7onusb
     
  2. rezwits, Jun 12, 2013
    Last edited: Jun 12, 2013

    rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #2
    Finished round 2

    So,

    All updates, work from Microsoft and didn't break bootcamp, for the need for a repair.

    If I remember correctly I had to change the USB part with regedit one more time after the first round of 137 out of 137 updates, so you have to check that after the first round of updates, I don't think I had to fix it after that

    You have to do all of the updates in VMWare tho, btw, because MS is basically saying "not if it's external/removable"

    you should do this in the internals of your VMware virtual machine file

    suspend.disabled = "TRUE"
    snapshot.disabled = "TRUE"

    right-click open package, open the Windows 7.vmx with bbedit and paste right before scsi section at the top

    your always going to get the paging prefs to pop up after a reboot, note..

    The last step is a DD save, and burn a gzip image of the 64GB to blu-ray

    The reason is, you can't use Winclone, cause it's MBR (on the restore), and you want an image incase of failure, because notice, I have been doing updates since I posted the first post. That was 2 days ago? Yeah 2 days of Microsoft updates via VMWare from USB3 Flash UGH!

    sample:

    sudo su
    dd if=/dev/disk1s1 | gzip > /Volumes/Scratch/win7x64Flash.img.gz

    Restore ->

    sudo su
    sudo dd if=/Volumes/Scratch/win7x64Flash.img.gz | gunzip | dd of=/dev/disk1s1

    the dd to make img will probably take under an hour via usb3 to usb3 ext
    restore ? eh,,

    oh I forgot I zeroed the drive which took 8 hours, then the DD backup today to 2 hours

    oh one note to disclaim like all others DD is DESTRUCTIVE with SU
    you have to get the "disk1s1" part right for your System and Setup
    Laters... back to Mac Pro forums
     
  3. rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #3
    boot selection

    I forgot to mention if you don't have a Mac that supports booting Windows from USB, you might be able to get away with using rEFIt or rEFInd

    Good Luck.
     
  4. ScrewedDK macrumors newbie

    Joined:
    Nov 14, 2013
    #4
    Anybody having used this with success? Just bought an Sandisk Extreme 64 gb USB 3.0 for use with my rMBP and thought of trying this, but because of it being such a looong process I wondered if anyone had tried it with success?

    Or perhaps there is another easier solution?

    I have searched the net in a couple of hours on the subject and it seems like this is the most plausible approach - but please enlighten me. :)
     
  5. rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #5
    I went back and forth

    I went back and forth for over 2 years trying to nail this down. This is the best I could do, seeing as you need to have special windows versions in most other possible ways talked about on the net...

    Good luck, but here is something tho: You don't have to necessarily update windows when you are done, which would save you a couple days of just grinding away...on those :(
     
  6. rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #6
    What I mean by 2 years

    2 years goes like this:

    One month I had a weekend, so, I googled and googled and found nothing, tried some crap, and didn't work. Gave up. (MacBook Pro 17)

    A few months go by same thing, I get a weekend and google and google, with forum posts and searching. Gave up. (MacBook Pro 17)

    It always came back at why do I need this haha. And it was just TO ACCOMPLISH THIS. I could use bootcamp tho, and I would always say GOD I hate windows, so I quit this side project.

    this went on for a while till I got my MacBook Air 11

    Then I looked up some new google reports, and still nothing. (Once again a free weekend)

    But the next time was different. Because it wasn't "Why do I need this = TO ACCOMPLISH", It was "I need this because I have my MacBook Air 11 and it only has a 128 GB flash drive!"

    Then found some of those resources and got er done! Finally.

    Want became Need...
     
  7. mcarlie, Jan 27, 2014
    Last edited: Jan 28, 2014

    mcarlie macrumors newbie

    Joined:
    Jan 27, 2014
    #7
    This didn't work on my haswell rMBP. I got error 0x00007b INACCESSIBLE_BOOT_DEVICE

    I did however find a working solution for windows 7 but it requires non-free software:

    1) Install windows 7 normally with bootcamp drivers and all that.

    2) Once in your windows 7 install, change the two registry entries mentioned by TC.

    Also change HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet001 -> services -> pcw

    Set start to 1. This might not be needed for others, but I got error BSOD 0x00007e or something like that without it.

    4) Back in OSX, open Disk Utility and partition your external drive, make sure that the partition scheme is GUID and the format of the partition is FAT32 (which is called MSDOS(FAT) or something like that in disk utility).

    5) Get winclone (the paid software) and image your bootcamp drive.

    6) Restore your Bootcamp drive to the external drive. Make sure that you replace BCD files when it asked you if you want to.

    7) Go back to your bootcamp install and download set_7_usb_boot.cmd from here http://reboot.pro/topic/14186-usb-hdd-boot-and-windows-7-sp1/ it's in one of the posts.

    8) Start CMD as administrator (won't work otherwise) and change the directory to where the cmd file is.

    Type set_7_usb_boot.cmd e:\windows

    replace 'e' with the letter assigned to your external drive.

    This file changes:

    HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet001 -> control -> BootDriverFlag to 6

    and

    HKEY_LOCAL_MACHINE -> SYSTEM -> ControlSet001 -> control -> pnp -> PollBootPartitionTimout to 30000

    It also changes them in ControlSet002 and CurrentControlSet but I haven't had any success changing them manually for some reason so just use the command file.

    Once this is done windows should boot from the external drive. It refuses to create a pagefile since it detects that it's an external drive but you can possibly fix this with filter drivers http://agnipulse.com/2012/03/filter-drivers-removable-media-fixed-disk-windows/

    If anyone gets this to work on Windows 8 then let me know.

    I've written this all from memory so if something's wrong then ask me to look it up.
     
  8. mcarlie macrumors newbie

    Joined:
    Jan 27, 2014
    #8
    Addendum:

    Set pcw to 1 instead of 4. Setting it to 4 will cause task manager to crash.

    None of the filter drivers worked for me. The disk is already detected as a local disk. I'm still trying to figure this out.

    This update: http://news.softpedia.com/news/Microsoft-Offers-Statement-on-Botched-KB2862330-Update-398229.shtml breaks the install so skip it.

    If you can't find your disk when trying to apply set_7_usb_boot.cmd then in cmd type 'diskutil' then type 'list disk' find your external drive in the list. It will probably say that it's offline, to online it type 'select disk N' replace N with the number assigned to your external drive and type 'online disk'.

    Removing the local bootcamp drive before booting from the external seems to fix a couple of errors. Namely that the local bootcamp drive is C and the external is E even though you've booted from the external, so you should probably remove it.

    Windows activation works fine and all of the updates (besides the one that I mentioned) work as well.

    The only problem left is the pagefile.sys not being created.
     
  9. rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #9
    That's good to know

    Yeah I have the page.sys error too, but get by...

    I find it so weird different machines need different codes to "get by"

    It makes sense tho, just re-affirms how odd windows can be!

    Thanks
     
  10. mcarlie macrumors newbie

    Joined:
    Jan 27, 2014
    #10
    This setup has been pretty unstable for me though. I just plugged in a keyboard and it immediately blue screened and then broke the whole setup. I read somewhere that plugging in new usb devices can reset some of the registry settings but I didn't expect it to immediately crash.

    I've tried windows 8 and it worked incredibly well without any modification on all computers excepts my mac. I'm going to try to get that to work instead since it's already built for running off of a usb drive.

    The problem is that iusbhub and iusbxhc don't exist on windows 8 since bootcamp just uses the generic usb drivers that come with windows 8 instead. Trying to let the generic ones load at boot doesn't work either.
     
  11. mcarlie macrumors newbie

    Joined:
    Jan 27, 2014
    #11

Share This Page