MAcBook Webcam Issue

Discussion in 'MacBook' started by AeroUK, Mar 2, 2012.

  1. AeroUK macrumors 6502

    Joined:
    Jan 6, 2008
    Location:
    New York
    #1
    My mother has a white macbook and sometimes when we Skype or she tries photo booth the camera does not work, she has to restart the application or reboot the computer for it to work again.

    Does anyone know what the fault could be or how to fix it?

    Thanks
     
  2. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #2
    Yes I've had this happen to me before. in my case the green led came on but the camera didn't. A software update fixed it for me, using the software update option from the apple menu. If you are getting no led, then there could be a loose connection, but this would be unlikely to happen, unless the lid of the macbook has been slammed closed repeatedly.
     
  3. AeroUK thread starter macrumors 6502

    Joined:
    Jan 6, 2008
    Location:
    New York
    #3
    Yeah it cannot be that because restarting Skype fixes the issue...
     
  4. saggel macrumors regular

    Joined:
    Mar 3, 2012
    Location:
    Coventry, UK
    #4
    I have the same problem... I really can't find what it is...
    so I just stopped using the camera... if someone has a solution for that, it'll be fantastic... the camera generally works, but after a while it starts having problems. In my case I don't even need to restart the application, just turn off the camera option in the call and turn it on again!
     
  5. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #5
    Is this not likely to be a Skype fault rather than a hardware problem ?

    Does the camera work in iChat, FaceTime and/or PhotoBooth ??
     
  6. saggel macrumors regular

    Joined:
    Mar 3, 2012
    Location:
    Coventry, UK
    #6
    hmm no problem in Gtalk...!!!!!!
     
  7. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #7
    So have Microsoft broken Skype now ???

    Now there's a surprise !!
     
  8. east85 macrumors 65816

    east85

    Joined:
    Jun 24, 2010
    #8
    Well you can't blame Skype for that one.
     
  9. saggel macrumors regular

    Joined:
    Mar 3, 2012
    Location:
    Coventry, UK
  10. saggel macrumors regular

    Joined:
    Mar 3, 2012
    Location:
    Coventry, UK
    #10
    The update fixed it for me...
    Almost an hour video call with no problem!
     
  11. AeroUK thread starter macrumors 6502

    Joined:
    Jan 6, 2008
    Location:
    New York
    #11
    The camera never goes off, it just doesn't always initialize.

    Sometimes it is simply not sending in the call and it can be enabled by turning it on in the chat window. But sometimes the camera icon is not even visible and Skype needs to be restarted.

    It happens in photo booth as well, it will say no camera connected. But this is when Skype was running so it may be Skype that is causing the problem still.
     

Share This Page