Macbook (white) doesn't charge

Discussion in 'Mac Basics and Help' started by Whooper, Sep 19, 2009.

  1. Whooper macrumors newbie

    Joined:
    Jan 22, 2008
    #1
    Hey :)

    My 2 year old White Macbook (Core2duo), started acting weird a month ago. Suddenly the LED in the charger stopped showing green/orange - but it still charged just fine.
    Then a week later, it stopped charging, and the only way to make it charge, was to push the magsafe charger, hard into the charge port in the computer.
    That worked for like 2 weeks, and now it won't even charge that way! It's completely dead..

    The computer boots just fine running on battery.

    I've taken the computer apart, changed the internal magsafe board and I'm using another charger (Which is working on other machines). But yet still no light in the charger and it doesn't charge..

    Of course my MacBook is just out of warranty :(

    It started 2 days after I've installed snow leopard. Could that have anything to do with it? Or is it just an incident?

    Any good ideas?
    Thanks in advance :)
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    No, Snow Leopard won't affect the performance of your charger.

    Warranty or no, sounds like you need to have someone take a look at it.
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
  4. Whooper thread starter macrumors newbie

    Joined:
    Jan 22, 2008
    #4
    I've tried SMC reset many times. But now there isn't enough power on the battery to turn it on.. I can't perform a PRAM reset then? can I? :confused:
     
  5. Whooper thread starter macrumors newbie

    Joined:
    Jan 22, 2008
    #5
    still no luck about this one :(
    Anyone got any comments/Suggestions? :eek:
     

Share This Page