MacBook WiFi Beachball... ;_;

Discussion in 'MacBook' started by Nick012, Aug 3, 2008.

  1. Nick012 macrumors regular

    Apr 28, 2007
    Ive started having an issue where my macbook's internet will stop working even though the airport status in the menubar shows no change. However, when I mouse over the part of the menu bar with the airport status I get the dreaded beachball and I have to turn off the machine by holding down the power button. It only happened once or twice at first but recently its been happening once or twice a day...
    Any ideas on what it could be?
  2. KoolStar macrumors demi-god


    Oct 16, 2006
    That sounds like it could be an air card issue. Does it do it with all wireless signals or just your own. If it is just your wireless network there could be an router setup issue; however, if it is all networks it most likely is an air card issue. I would then try reseting the PRAM and VVRAM (LINK). If none of these work I would make an appointment to see your local genius bar @ :apple:.
  3. alphaod macrumors Core


    Feb 9, 2008
    I get this sometimes; I can't reproduce it whenever I want, but as far as I can tell, it's from the card timing out and the computer still thinking it's connected, the Airport program goes into a loop. I restarted the SystemUI process in Activity Monitor and that usually fixes it for me.
  4. Nick012 thread starter macrumors regular

    Apr 28, 2007
    I would do that but it turns out that everything but the application thats being used when it happens locks up.. basically I have to do a hard shutdown because nothing else works. This is the worst possible time for this to happen too since my MA dissertation is due in a month... Perhaps I'll just buy a new HD and do a clean install of Leopard since I can't send it in for Apple to fix atm.
  5. bluedepth macrumors newbie

    Sep 11, 2014
    MacBook Pro Wifi Beachball possible fix

    Hello, I have a late 2013 MBP and had this exact same problem. The usual fixes, such as wiping out the network, deleting the plist for Airport, NVRAM reset and repair permissions didn't touch the issue. What did fix it was setting the channel on my wifi router to a specific channel, I chose 6 because it's right in the middle. Since then I haven't had any more Wifi beach ball issues.

Share This Page