MacBook WiFi - Help?

Caitlyn

macrumors 6502a
Original poster
Jun 30, 2005
842
0
Hi guys.
So, as you may know I just got my new MacBook yesterday. It's an amazing machine. However, I have one problem that is really getting on my nerves.

I was able to connect to my wireless network quite easily. It was a matter of typing in the name of my network and the WEP password and bam, I'm online. But every so often, in the middle of my work, it just disconnects. When I pull down the Wi-Fi menu in the menu bar, it still says it can see my network and getting back online is just a matter of re-selecting my network from the dropdown box. But why is this happening? Is there a preference I forgot to enable or something? It's really annoying. If anyone has ANY input, it is incredibly appreciated.

Thanks in advance. :)

Edit: Here is a screenshot of what it looks like. My network is "seveniweb". I all really need to do is reselect seveniweb. But why should I have to?
 

7on

macrumors 601
Nov 9, 2003
4,940
0
Dress Rosa
try changing the channel seveniweb is on. You do that in the router preferences. Could be that other AP is on the same channel throwing you off. Or you could "try" Interface Robustness. That, in theory, should make your card focus harder or something on one signal ignoring extraneous data - at the expense of some signal strength.
 

Caitlyn

macrumors 6502a
Original poster
Jun 30, 2005
842
0
I'm not sure about the channeling because it is my father's network and he has it set up perfectly so...but I tried Interference Robustness. Sounds like a good idea, but I just set it on so we'll have to see how it works. Thanks tons for the reply. :)

Any more ideas or thoughts are totally welcome!

EDIT: Okay, I have Interference Robustness selected and I still am losing connection. So, that's not working.
 

fatties

macrumors regular
May 21, 2006
179
0
have you updated to 10.4.7? before i did that my wireless dropped occasionally and cannot understand that when it wakes up it needed to go back on the internet. 10.4.7 sorted that out for me... now the wireless is perfect.
 

FullmetalZ26

macrumors regular
Jun 12, 2006
159
0
Make sure 'seveniweb' is set as a preferred connection in System Preferences -> Network -> Airport, and if it already is, try removing and re-adding it. My MacBook stopped auto-connecting to my wireless network when I bought a new AP awhile back, and re-adding it as a preferred network took care of the problem.
 

Caitlyn

macrumors 6502a
Original poster
Jun 30, 2005
842
0
I am currently running 10.4.7. I don't want to jynx it, but for the past hour, after draining my battery for the first time and now recharging it, I have had no trouble. *knocks on wood*
 

FredClausen

macrumors regular
Aug 7, 2006
170
0
KALM
Caitlyn said:
I am currently running 10.4.7. I don't want to jynx it, but for the past hour, after draining my battery for the first time and now recharging it, I have had no trouble. *knocks on wood*
Believe me, I had the same thing happen where it quit acting up, and it always did it again :rolleyes:

The only possible explanation, besides a generic its a bad OS update, is that it seems my issues crop up much more frequently when I'm using my bluetooth mouse.
 

FredClausen

macrumors regular
Aug 7, 2006
170
0
KALM
A followup to my last post. I ran my MP on and off the last 24 hrs with no wifi disconnects. The only thing I didn't use that I normally would was my BT mouse. Looks like BT is the bad egg here. Any suggestions?