MacBook will not boot, stuck on grey screen

Discussion in 'MacBook' started by nebulous, Mar 20, 2012.

  1. nebulous macrumors newbie

    Joined:
    Mar 12, 2009
    #1
    So my friend asked me if I could fix her 2008 Penryn Macbook. The LCD screen was broken and it also needed a new keyboard, but apparently booted and worked fine.

    Basically, I took the whole thing apart, following the guide to replace the LCD screen on iFixit.com (http://www.ifixit.com/Guide/Installing-MacBook-Core-2-Duo-LCD-Panel/1498/1). I replaced the screen and the LCD brackets as I realized that one of airport antenna cords was torn. I also bought a new screw set because there were many screws missing and I read that many of them were crucial for the computer to run (they were needed to complete the circuit). I also replaced the keyboard.

    I double-checked that everything was plugged in correctly (including the RAM). When I turned it on it sounds the chime and then shows the grey screen. There is no Apple Logo or spinning wheel. I also realized that the computer now requires to be plugged in at all times or it will shut down- don't believe that was an issue before). I tried every startup key combination and reset the NVRAM.

    After this I decided to try to boot with a Snow Leopard Install disk (even though this mac was probably running Leopard (10.5.x) and then after that a Tiger Install disk and neither worked. I don't have a Leopard disk, but if this is crucial I might be able to get my hands on one.

    Interestingly, the only startup keyboard shortcut that garnered any response, besides resetting the NVRAM and ejecting the install disks, was when I held the option key- the mouse would appear.

    At this point, I need all the help I can get. I'm really no expert at all and I'm terribly afraid that I will have to just sell it on eBay and buy her another computer.

    Thanks in advance for all the advice!
     
  2. reubenroyapple macrumors newbie

    Joined:
    Jul 23, 2010
    #2
    When the mouse appears, a list of bootable drives should appear here. One would then assume that the hard drive had died as it is not listed, but what is strange is, there is no flashing questionmark when you turn it on with no keys pressed. Even though you double checked, there maby some small thing somewhere that was not seated correctly.
     

Share This Page