MacBook will not boot!

Discussion in 'MacBook' started by kd5qhr, Aug 10, 2009.

  1. kd5qhr macrumors newbie

    Joined:
    Aug 9, 2009
    #1
    I have a macbook with OSX 10.5.7 and 4gb ram. Having fallen victim to the current scare tactics out on the web, I downloaded and installed PC Tools's iantivirus. All went well with install. About half way through the initial system scan, iantivirus hung up and locked my system. I had to do a hard power off with the power button. Now, my mac will not boot past the Apple logo. I don't even get the spinning wheel. I have booted to my install disk and ran disk utilities and everything checks out ok. I reset the pram and removed the battery and power supply and held the power button down for 10 or so seconds. Nothing. After several minutes, the system restarts and the cycle begins again. I cannot get into safe mode. Upon looking behind the splash screen, I see where it hangs on a driver error. The driver in question is \system\library\extensions\roxiobluraysupport.kext.\contents\macos\. I have tried removing the driver in terminal, but terminal cannot locate the file. I am by far no expert in Terminal, but i followed some directions I found on a google search.
    Anyone had this sort of problem before? It's coming down to a few options I have: Try to restore the system or do a clean install. I really hate loosing some of the data that I have collected over the last 3 or so years. I do have to say, other than a few minor glitches, the macbook has worked great up until now! I will not write it off yet!
    I guess another question would be how exactly do you delete a driver in terminal? I tried using the rm command, followed by the location. Am I doing that wrong? Also, I am accessing terminal through the boot disk. Thanks for the help in advance.:confused:
     
  2. MrM macrumors 6502

    Joined:
    Oct 13, 2008
    Location:
    California
    #2
    Try launching in Open Firmware if you have another Mac in the house (and assuming your MacBook has a firewire port).

    You could also do an archive and install instead of a clean install.

    I really doubt that Toast is to blame for this (the driver you are pointing out)

    Have you tried launching in single user mode and running -fsck ?

    PS- Antivirus software for OSX is a joke. You don't need it, ever.
     
  3. MarkCooz macrumors 6502a

    Joined:
    Jul 12, 2009
    Location:
    California
    #3
    agree with this guy...
    and plus don't believe all that ooooh my mac is having a virus.. come on.
    seen the commercials? MAC VS. PC? well they have one about viruses. so don't worry man

    and can't you just do a clean install?
    i mean unless you have important files you didn't back up then i don't know... just go with what the guy told you.
     

Share This Page