MacBook will not sleep automatically since Snow Leopard install

Discussion in 'macOS' started by celticpride678, Dec 30, 2009.

  1. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #1
    Hello. I am having a serious issue with my MacBook since upgrading to Mac OS X Snow Leopard. My MacBook (Late 2008 Aluminum, 2.4 GHz) will not go to sleep automatically anymore. If I select "Sleep" from the Apple menu it will sleep fine. However, it will not sleep according to my Energy Saver preference pane which says sleep at 1 min each (Display and Computer). Another thing to keep in mind is that my display sleeps perfectly normally. However, the computer itself will not sleep.

    Here are the things that I have tried so far:

    • Reinstall 10.6.2 combo updater
    • Remove Energy Saver preferences and entire System Configuration folder
    • Made sure that no hardware or software is interrupting sleep
    • Reset PRAM and SMC
    • Repaired Disk Permissions
    • Archive and Install
    I am running Mac OS X 10.6.2 with ALL updates and firmware installed.
    Please help me figure this out as it is a serious issue. Thanks.
     
  2. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #2
    Have you tried repairing disk permissions in Disk Utility?
     
  3. celticpride678 thread starter Guest

    celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #3
    Yes. Sorry I missed that. I also just performed an Archive and Install and that did not help.
     
  4. flinch13 macrumors regular

    Joined:
    Jul 4, 2004
    #4
    Hey, did you ever solve this problem? My iMac won't sleep its display automatically anymore... and I don't like it. I leave my computer running at night to process video and I don't like that the display wakes itself up for no reason. Didn't do this when I was running leopard...
     
  5. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #5
    I would check your system.log in Console for any conflicts in or about the time when you mbp should normally sleep. It may reveal something.

    In my case, I found that TM scheduling backups while my TM external harddrive was disconnected, was somehow conflicting with the sleep schedule. I disabled TM and all is good now.
     
  6. allan.nyholm macrumors 6502a

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Aalborg, Denmark
    #6
  7. celticpride678 thread starter Guest

    celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #7
    I am currently working with a team of Apple Bug Support technicians to try and figure this problem out. They said that a lot of people are having this issue.

    I used to have Growl installed, but it is uninstalled already.

    I will monitor my system.log and post back anything that seems out of place.
     
  8. pit29 macrumors 6502a

    pit29

    Joined:
    May 23, 2006
    Location:
    The Golden State
    #8
    Here's another bump.

    Did anything ever turn out? My MBP is sleepless as well. Permissions repaired, 10.6.2. System.log shows lots of the following two lines:

    Feb 26 13:25:35 ### ntpd[25]: Cannot find existing interface for address XX.XX.XX.XX
    Feb 26 13:25:35 ### ntpd_initres[198]: ntpd indicates no data available!

    ### is my computer name, XX.XX.XX.XX an IP address.
     
  9. celticpride678 thread starter Guest

    celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #9
    Nope, we are still trying to diagnose the issue, but it seems like it has to do with system file errors.
     
  10. hyp0 macrumors newbie

    Joined:
    May 12, 2010
    #10
    celticpride678, Problem solved or not for now?
     
  11. SDF-01 macrumors newbie

    SDF-01

    Joined:
    Sep 7, 2010
    #11
    Any Luck?

    I'm having the same issue with a 2007 MacBook running 10.6.4, but it only recently started to act up. It definitely worked fine for a long while since my Snow Leopard installation. Good to know that it's common and Apple is working on a fix though. Have there been any changes or recommendations?
     
  12. pit29 macrumors 6502a

    pit29

    Joined:
    May 23, 2006
    Location:
    The Golden State
    #12
    Not sure whether something's in the making here... I never got rid of the problem, as far as anything I could do with OS X is concerned.

    Starting using PleaseSleep (http://www.dragonone.com/products/macosx/pleasesleep/) a couple of weeks ago, works well - though, obviously, it's a workaround, not a fix.
     
  13. tomharrisonjr macrumors newbie

    Joined:
    Sep 24, 2010
    #13
    PleaseSleep is also good for diagnosing cause

    I was having the same sort of problem as others described. I installed PleaseSleep and used its log to see exactly when sleep was invoked and wake was invoked -- within a second in my case. With exact time, I was able to see the kernal.log from the console and trace to a message reporting that a keypress was occurring from the internal keyboard or touchpad. I googled that message, found someone else with the same problem, who solved it by making sure there was not a stuck key -- I used some "canned air" to blow out my keyboard and trackpad, and whatdya know: that problem didn't occur any more.

    I still need PleaseSleep because so many things interfere with sleep (Sharing, Time Machine, many other apps I usually have running).

    I had the same problem with Windows XP (now have 250+ comments on two posts from my blog about how I resolved it). Apple is better than MS, and should have the functionality of Please Sleep built in to the "Energy Saver" app as an advanced option.

    Harrumph.

    Tom
     

Share This Page