Macbook: Wireless drops out constantly for a few mins after startup

Discussion in 'macOS' started by bob.summers, Mar 7, 2011.

  1. bob.summers macrumors newbie

    Joined:
    Mar 7, 2011
    #1
    Hope this isn't a repost, have searched but this is a difficult problem to search for exactly.

    My wireless runs faultlessly most of the time, except when I first boot up the machine. For several minutes after connecting to my (or any) router, pages refuse to load until I click the airport icon and refresh the list of available networks. The page loads, but when I want to load another, I have to again click and refresh the airport, then retry the page. After ten or fifteen repeats, the wireless seems to stabilise. Throughout, I have a strong connection to the router. Not the end of the world, but not exactly convenient.

    It's not a router problem (other machines connect fine), and I've deleted all connection history, and updated the machine. It's an Intel 2,4GHz running OSX 10.5.8.

    Any pointers? Are there system logs I can check?

    Cheers

    Bob
     
  2. iBrody macrumors 6502

    Joined:
    Jun 11, 2008
    #2
    In your Applications folder, make sure System Preferences is not in a subfolder. I previously found that Airport does not connect if it has been moved to a sub folder within Applications.
     
  3. bob.summers thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #3
    Thanks, checked that & it's OK.

    Tried looking at dmesg output and everything looks OK, it just says the link is up (which it would do; the connection to the router is always fine, just that pages don't load)

    :confused:
     
  4. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #4
    Try a ping test using Terminal:
    1. ping -c4 192.168.1.1 (or whatever your router address is) - if ok then...
    2. ping -c4 8.8.4.4 (which is the ip address of Google's public dns server) - if ok then...
    3. ping -c4 www.google.com

    The ping test will tell you if you actually have a connection. Test 1 checks the connection to your router. If test 2 is ok and test 3 fails, you know that the dns server you are actually using (which is probably your isp dns server) has fallen over. You don't have to use your isp's dns servers, do a search for a reliable alternative public dns server like the Google ones.

    If all this checks out it might be that you are getting interference from some other device, eg a cordless phone, microwave oven, burglar alarm that is transmitting on the same wavelength as your wireless card/router. You should be able to change your router setup to use a slightly different frequency.
    I recently had to do that myself - I'd read this advice before but dismissed it as a 'that couldn't possibly happen to me', and spent hours fiddling about with various settings with no effect.

    One other possibilty - set up a location in Network Preferences rather than relying on the 'Auto' setting - it may help to point your wireless card to the router rather than let it search blindly for a working network.
     
  5. bob.summers thread starter macrumors newbie

    Joined:
    Mar 7, 2011
    #5
    Thanks for the info Steve.

    If I run the pings when I'm experiencing the connection problem, I get failure or packet loss to all 3 - the router, IP and www addresses.

    If I then click the airport icon to refresh networks, all 3 pings come back fine (and of course pages load OK).

    As I mentioned, this is only a problem for the first 10 minutes or so; after that its faultless.

    I tried setting a location, no difference. And I guess I can discount interference as I can repeat the problem in any location, whether the network is encrypted or open.

    It's an odd one. I can almost live with it, but when you're in a rush to get to a page and you have to constantly click/refresh the networks it's infuriating!!
     

Share This Page