Macbook wireless network problems

Discussion in 'MacBook Pro' started by bankshot, May 20, 2006.

  1. bankshot macrumors 65816


    Jan 23, 2003
    Southern California
    We brought home a beautiful new Macbook last night - 2.0 GHz, white. Everything seems great, no heat problems or strange noises when taxing the machine, etc. Except for wireless.

    I have a D-Link DWL-900AP+ wireless access point that has worked perfectly with numerous PowerBooks, an iBook, and the occasional wireless PC. However, this Macbook seems to consistently drop about 1/4 to 1/3 of packets. The effect is that the network freezes up during this period.

    What happens is I get about 12-15 seconds of good packet reception, followed by 6-7 seconds of all packets dropped. Signal strength remains constant at 100% during the dropped packets, but all network activity stops dead. This is especially irritating because I often login remotely to other machines via Terminal, and every time the network freezes up, I can't see what I'm typing until it comes back 6-7 seconds later.

    Can other people with a Macbook please try this little test? If you know the IP address of your wireless access point, or even just another computer on your network:

    1. Open /Applications/Utilities/Terminal
    2. Type this command: ping -c 100 where you replace with the IP address of your access point or some other computer on your network. In my case, my D-Link has IP address

    What is the brand and model of your wireless access point?
    When the ping finishes, what are your statistics?

    On my work PowerBook, I get the following:
    When I run the test at exactly the same time on the Macbook, I get this:
    One possible wildcard here is that the PowerBook is still on Panther, while obviously the Macbook has Tiger. This is my first time using wireless with a Tiger machine here (the Power Mac has Tiger, but is using ethernet). Also, the PowerBook and the Macbook can't ping each other, although both can ping and remotely login to my Power Mac which is also on the network. Crazy!

    I'm about ready to go back to the Apple Store and see if it does the same thing there, as well as whether the display Macbooks do it. Might be interesting.

    Anyway thanks for any feedback!
  2. bankshot thread starter macrumors 65816


    Jan 23, 2003
    Southern California
    Just to follow up in case anyone comes across this thread (not that anyone saw it the first time, apparently... :rolleyes: ), the issue went away a few hours after I posted. I had started changing advanced "performance" settings on my wireless access point one by one, to see if any of them had an effect. After changing Preamble Type from Long to Short, suddenly the problem went away. Good deal!

    Because I like to understand problems, and like to confirm that it's truly fixed and not just randomly better, I changed the setting back. The problem should have come back, verifying that Preamble Type was the offending setting. However, the problem did not come back. It's been working perfectly ever since, regardless of the Preamble Type setting. This is a little bit annoying because it means I don't know if the problem will ever reappear. All I can do is hope it doesn't...
  3. iceprincess0966 macrumors newbie

    Jul 13, 2006
    I just got my new MacBook Pro, C2D 2.16GHz 15".

    I'm noticing the exact same problem when I'm on the wireless network at my boyfriend's house. I have 0-5% packet loss at my own home, with my US Robotics 5461 router at the opposite end of my house, so I don't think it's a problem with the Airport card itself.

    I also wasn't having any problems with his router with my G4 Powerbook. But pinging either the router or any other host with my MBP gives me a very regular pattern of around 11 packets sent perfectly and 6-7 dropped (30-40% loss). His router is also a D-Link.

    I have searched the inter-tubes high and low for a solution, and I've tried changing all kinds of settings, deleting widgets, etc. If you've had a similar problem, could you please post your ideas on how you fixed it? I also use Terminal to ssh to different servers for my job, and this problem is making it impossible for me to work from his house.

    Please help me save our relationship from the inevitable blow it will suffer if I can't use my computer at his house anymore!

  4. froob macrumors newbie

    Apr 11, 2007
    I have a very similar or the same set-up as you: Macbook C2D 2Ghz / D-Link DWL-900AP+. The wireless would drop about 1/3rd of packets and have pings of about 2-3 seconds on another third.

    What fixed this issue for me was reinstalling the Apple Airport Extreme Update 2007-002. No more dropped packets, pings look normal.

    Hope this helps anyone still having issues.
  5. jonb704 macrumors newbie

    Apr 21, 2007
    Similar issue

    I have the same problem with my macbook pro 2.0Ghz. I was using an old Netgear wireless router and recently upgraded to a newer Dlink WBR-2310 wireless router. Ever since then, my macbook will not connect via wireless. I have other devices that connect fine to the router. I'm using WPA/TKIP since that is what my other devices can support. On my macbook, I select the SSID and it prompts me for my passphrase. I type it in and get 'There was an error joining the Airport network "XXX" ' (XXX being my SSID).

    I checked my logs on my router and it shows where the MAC address of the wireless card authenticates successfully.

    When I open the network utility on my macbook pro, i see a lot of Recv Errors and some Send Errors as well.

    I tried the things bankshot suggested, but still doesn't work. I tried reinstalling the Airport Extreme 2007-02 update, but no luck.

    Any ideas?
  6. TraceyS/FL macrumors 601

    Jan 11, 2007
    North Central Florida
    Had issues with our D-Link and a MBP and MP.

    Got it all jacked up totally non-working on a Saturday (after installing a firmware update), DLink couldn't help us until Monday after 8am when level 2 got to work. Replaced it that day with a Belkin N, the computers could finally connect. THEN, that had a major heat issue and died, replaced it with an Apple Extreme N...

    All is well in the world....
  7. benkenney macrumors newbie

    Aug 23, 2007
    I tracked my problem down to a dashboard widget called JiWire which is a wifi sniffer. The results from ping -c 100 didn't show any packet loss but it showed that the response time went from ~1.5ms to > 1000ms every almost every 5 packets or so..this made using programs like skype virtually unusable because the jitter was so high.

    I have a new macbook (~2 months old) and a linksys router.
  8. swemoney macrumors newbie

    Oct 12, 2007
    Thank you!! I was searching everywhere for someone with the same problem as me and was getting very scared that I was going to need to get my brand new (also about 3 months old) macbook pro serviced.. I, too, had a widget running that was sniffing for wifi hotspots and had pings jump from nice low numbers to 1 or 2 seconds every few packets.. Removing the widget cleared everything up. Thanks a lot!
  9. sal macrumors 6502

    Oct 13, 2007
    been having similar issues on my week old macbookPro. It's a wireless isue since I did the ping test on a wire connection and didn't get any dropped packets, while the wireless I got 5% packet loss.

    I have since re-installed the airport update and that seem to have solved the issue. I'll report back to this thread it the problem returns.

    i know it's not a widget issue either since I haven't installed any on this computer(it's a week old)
  10. brettweir macrumors newbie

    Nov 2, 2007
    Having wireless throughput issues with my Macbook 1.82 C2D; very strange - I also have a Dell Inspiron 1.6 CD w/ Centrino right beside my Macbook and it works fine in terms of throughput. The Macbook, horrible.

    So I did the ping thing in the beginning part of this thread, and here were my results:

    --- ping statistics ---
    100 packets transmitted, 98 packets received, 2% packet loss
    round-trip min/avg/max/stddev = 1.944/115.287/722.130/140.543 ms

    I'm not running any widget wifi sniffer or anything like that; my Macbook is pretty much stock except for Firefox and Office 2004. Any ideas what I can change/do to improve performance? Your help is appreciated.
  11. brettweir macrumors newbie

    Nov 2, 2007
    Also forgot to mention - I reinstalled the last Airport update and it didn't seem to change anything. I also tried to reinstall Airport update - 002, but it apparently wouldn't let me do it.
  12. devyhevy macrumors member

    Feb 12, 2008
    I've been getting problemas with a DLINK DI524 wireless... my macbook internet connections dies every now and then and it's starting to get really annoying. I'll try on those updates when I get home.
  13. The Flan Bandit macrumors newbie

    Jul 21, 2007
  14. aaron.lee2006 macrumors 65816


    Feb 23, 2006
    Ontario, Canada
    Did the same thing with my DLink 614+ and my problem went away. Mine was dropping about 50-75% of the packets though. But it's fixed now and I bought a Wireless N router anyway.
  15. DachWuff macrumors newbie

    Apr 18, 2008
    I had similar problems. Mainly if my system was not plugged in I could not keep the wireless live for more than 5 min. (yes i timed it) Every time I was running an SSH or TinyFuge session if I was not actively typing or pinging it would die out after 5ish min. TinyFuge was worst even if I was typing it would dye out. Same with other chat based programs. Unless I was pinging a server, or browsing web pages, downloads would even break. And this was every where, work's wireless, public wifi, home etc..

    I threw in that ack-0 thinggy, and so far no issues. But has any one else had the issue with SSH sessions dropping? And any other fixes? This feels like too much of a band aid for a broken limb.
  16. gooshi macrumors newbie

    Oct 8, 2008
    Wireless doesn't work!

    Hi there, it's been couple of months I've been struggling with wireless which doesn't work. If I try to go to settings it doesn't allow me . Everytime I go to preferrencess an information appears that my settings have been changed by another application. Rubbish! And can't ever go on with it. It's painfull having to use the wire. At first I thought it was the modem's fault as am living in a crazy country..but reading all the posts I realize it must be my Mac!. Anyone had similar problem and found solution??
  17. kahanabob macrumors newbie

    Sep 23, 2010
    I took the easy way out unsecured my d-link and wireless works fine on macbook and mac desktop........

Share This Page