MacBook with Leopard can't use Canon MP600R

Discussion in 'Mac Basics and Help' started by Joanne, Aug 30, 2008.

  1. Joanne macrumors newbie

    Joined:
    Aug 30, 2008
    Location:
    the Netherlands
    #1
    Hello,

    I've got several Apple computers in a network. I'm using a Canon multifunctional PM600R for printing. It's connected on a iMac DV with a USB-cable. I'm using a Vigor wireless router. It was alle working perfectly. With my Powerbook I could use the printer wireless.

    Recently I bought a MacBook with Leopard. Up until today I can't print wireless. When I connect the Canon printer directly (USB), it will print. But that's it. I've downloaded the most recent software from the Canon website. Unfortunately, it won't work. In printer configuration I just can't select the printer because it doesn't show up in the window of the Canon IJ network tool.

    Any solutions?
     
  2. nse macrumors newbie

    Joined:
    Oct 27, 2008
    #2
    Hi
    Have the same problem(just for a mp800R) .....
    but the problem arrived 2 seconds after upgrading to Leopard....
    Tiger(10.4) worked like a charm, and although I have had a look for newer versions on Canon's homepage(and upgraded to the latest versions).. still the problem persist.....

    I'll check later if the problem also is there when using Ethernet... but I suspect not as the Canon Network tool finds the printer... only with the Ethernet MAC address.... which obviously will not work....

    Any solutions will be greatly appeciated....

    Besides .... I also use a Draytek Vigor.... but using Tiger(10.4) there were no problems... so I assume(!) the Draytek is not the cause....
     
  3. Joanne thread starter macrumors newbie

    Joined:
    Aug 30, 2008
    Location:
    the Netherlands
    #3
    Hi nse,

    I finally solved the problem with great help from someone on one of the Apple Forums.
    This is what he advised me to do, and it worked. Hopefully it will solve your printing problem to:

    Mac OS X 10.5 Leopard uses Bonjour to locate shared printers on your local network, but it does not display printers shared by Mac OS X 10.2 through 10.3.9 which are broadcast to the network using the "cups" protocol. The steps below will allow Mac OS X 10.5 to locate shared printers which are being announced to the network using the "cups" protocol:

    1. Open Terminal (located in /Applications/Utilities).

    2. Type or paste this command, followed by Return:

    cupsctl BrowseProtocols='"cups dnssd"'

    The next time you add a printer, you should see printers shared by Mac OS X 10.2 through 10.3.9. These printers will display "Shared Printer" in the Kind column. You may see printers shared by Mac OS X 10.4 or later appearing twice (once as a "Bonjour Shared" printer and once as a "Shared Printer") after completing these steps.

    To revert back to the default behavior in Mac OS X 10.5, you can remove "BrowseProtocols dnssd cups" from the CUPS configuration file, or reset the printing system.

    Good luck!
     
  4. goblue310 macrumors newbie

    Joined:
    Jul 26, 2009
    #4
    YESSSSSS!!! FINALLY. Something that worked. I have tried all the other solutions that have worked for others, including reseting the printer system, CUPS hostname changes...what did finally work was what Joanne posted above. It did take some digging to find this information (part of the problem was me searching for issues with wireless printing specifically with the Airport Express), I wish this solution were posted more prominently.
     

Share This Page