MacBook won't boot after installing Snow Leopard...

Discussion in 'macOS' started by benguild, Aug 28, 2009.

  1. benguild macrumors 6502a

    Jul 29, 2003
    It just hangs at the spinning pinwheel.
    I shut the machine off and booted it into Verbose-mode (Command-V) and it stops at "Initializing Power Manager" or something very early on.

    I pulled the battery and unplugged the machine, am letting it cool off (not that there's a point) -- it's one of the original MacBooks that had that "shutoff" problem with the wire that'd melt and short to the heatsink... but mine never had the issue because I wasn't using it very often at the time.

    Any ideas? The drive does show up when I hold down Option.
  2. benguild thread starter macrumors 6502a

    Jul 29, 2003
    The same thing happens if I try to boot in Single-User mode... stops at "AppleIntelCPUPowerManagement: initialization complete"
  3. swb1192 macrumors 6502

    Dec 4, 2007
    Happened to mine too. I tried booting from DVD and it didn't work. Even tried booting from leopard DVD and it didn't work. I made a genius bar appt but none are available until tomorrow at 7pm. Any ideas, anyone? :(((
  4. MooneyFlyer macrumors 65816


    Nov 18, 2007
    Given that your laptop is a 2.4 Alu (relatively new) this is worrisome. OP - what machine are you running? Are there other common hardware configs (added memory from a specific vendor / etc.).

    I have an Oct'08 2.4 AluMB with 4GB Crucial... now I'm worried...
  5. benguild thread starter macrumors 6502a

    Jul 29, 2003
    I was able to reboot into the Snow Leopard Install DVD and I'm reinstalling now... I don't know if this is going to make a difference though. If it doesn't... I'm also going to hit up the Genius Bar tomorrow. Ugh!
  6. benguild thread starter macrumors 6502a

    Jul 29, 2003
    Okay, I reinstalled and it worked this time. For some reason, I think I had to do the same thing with Leopard. Whatever! (this is my traveling computer, not a primary machine)

    I did repair the disk with Disk Utility before I went back through the installer... it said it repaired the Boot GUID so I'm assuming that's what the problem was, but I reinstalled anyway.
  7. Slugg macrumors newbie


    Aug 21, 2009
    I'm having a similar problem with my 13" Macbook Pro

    When I installed Snow Leopard, it did the installer for a bit, but then the screen went black and the CD drive stopped spinning. After 10 minutes or so, I held the power button and rebooted, only to see the flashing folder with a ? in the middle. Now when I try to run the Snow Leopard DVD, it shows the normal boot procedure, but then when it should be going into the installer, the display goes blank instead.
  8. Marvin1379 macrumors 6502

    Jun 25, 2007
    New York
    I'm stuck at the spinning pinwheel too. It was in the installer and there was about 45 minutes remaining, I went to shower and when I came back, it has my background and had the spinning wheel. It's now an hour and a half.

    If I shut off the computer, will it suck getting it going?
  9. benguild thread starter macrumors 6502a

    Jul 29, 2003
    okay both of you -- those are completely different problems, lol.
    My laptop completed the install, but then wouldn't boot past the apple/spinning. You guys are having different issues :)
  10. philosinfinity macrumors newbie

    Aug 29, 2009
    Same boat here. I am working with a white MacBook. I was able to boot to the installer cd by holding down the 'c' key and powering the unit on. Otherwise, I get the initial grey apple logo with the spinning wheel below it. Once in the DVD, I am working on repairing disk permissions and the disk itself. I will let you know if this helps.
  11. gryphontech macrumors newbie

    Aug 29, 2009
    15" MBP will not boot at all after SL "upgrade"

    I ran the upgrade from SL and went to bed.

    Came to the system this morning to find it black screen and unresponsive. I can force it to shut down and power on. I get the normal chime, the grey apple, the spinning circle below it. It then sits there for several minutes. I see the screen change to the blue desktop background but only for half a sec and then the screen goes black.

    I reset PRAM - same.
    I reset NVRAM - same.
    extensions off - same.
    force boot from SL DVD - same
    force boot from Leopard DVD - same

    booting in verbose mode shows lines of text of the boot process .... until the screen goes black.....
  12. ianhomer macrumors newbie

    Aug 29, 2009
    Same thing for me

    - White macbook bought a year and a half a go
    - Snow leopard install seemed to proceed OK for most of the install then restarted and system hung with apple logo, spinning ball and spinning hard disk for an hour or so.
    - I forced restart and same hung problem and couldn't eject SL DVD
    - Restarted with option key pressed down to enter startup manager and selected to boot from hard disk - and same hung problem
    - Restarted by pressing C down and entered SL installation screen, decided to restore previous system from time machine back up ... restoring now
  13. soggywaffle17 macrumors newbie

    Aug 30, 2009
    Same problem here, keep us updated on how it gets fixed!
  14. Lordedmond macrumors regular

    Oct 24, 2008
    Tilchestune UK
    do we think that the ADC beta tester did not test on all mac's
  15. swb1192 macrumors 6502

    Dec 4, 2007
    Please see my earlier post to view the problems i was encountering. This post is a followup.

    Went to my genius bar appt last night and he was stunned because he hadn't heard of thr MacBooks hanging up at that point (right after power management). He took an external with 10.6 bootable, then reinstalled leopard again. It restarted and stayed at the grey screen for about five minutes, thn booted up with all of my data intact. But everything was extremely slow and it took minutes for everything to open and then it wouldn't even shut down. I gave it a few restarts and now it goes faster than ever. Everything seems just how it should be.
    I'm not sure what the genius did special to make it work, but I guess I'd just recommend making an appointment and having the genius fix it.
  16. journeymaid macrumors newbie

    Aug 30, 2009
    I had the same problem during my first install -- it seemed to install OK (I didn't pay much attention to it and just let it run), then it hung at the apple logo and spinning circle.

    But the 2nd install worked. This is what I did:

    Held down "C" while booting so that it booted from the SL CD. I had to hold it down for a while.

    Instead of installing from the CD, I chose to restore a Time Machine backup. That took 4+ hours, so I just let it run.

    It restored perfectly. I then ran a disk permissions check with Disk Utility and repaired permissions.

    I ran the SL installation again. This time I kept an eye on it.
    At some point it wanted to reboot and there was a message asking me if I wanted to install a software update; I had put off installing the 10.5.8 update and it wanted to install that before restarting. I chose to restart without installing the update. (Since I wasn't paying attention the first time, maybe this is what caused the problem with the first install?)

    It rebooted normally and SL is working great.
  17. benguild thread starter macrumors 6502a

    Jul 29, 2003
    I don't even think you need to go that far. I just went into Disk Utility, did "repair disk", then reinstalled. Worked fine... didn't even have to do a Time Machine restore.
  18. maduro macrumors newbie

    Jun 16, 2006
    Snow Leopard on Macbook

    When loading Snow Leopard do the following!

    1. Snow Leopard disc in machine
    2. Turn on holding down only the "C" key
    3. After you pick your language go a few screens in and go to the startup menu and use disc utility.
    4. Erase disc and make sure you pick the journal erase.
    4a. close out disc utility and continue with install screen.
    5. Continue the installation

    I hope this works for you! It sucks that you lose your data!
  19. tngilbert1s macrumors newbie

    Sep 1, 2009
    Same problems here....

    I have a pretty new unibody 17" mbp (2.66ghz w/2GB ram) - same problems.

    Installation said it went fine (although it took an hour an a half) - on the first reboot it just hung at CPUPowerManagment intilization.

    I am re-installing now but dont have high hopes - I haven't been able to work today as a result.
  20. Matthewleusher macrumors newbie

    Sep 2, 2009
    :confused: I am just getting so frustrated! - This process isn't even working. The disc is now inside the machine from where the intallation process began, and it rebooted itself, now it gets stuck on the grey apple logo screen with the endless cycle of the dreaded wheel.

    I have tried switching on and holding down "C" and it does nothing. I don't really know what to do next, but this is really really poor as my Macbook Pro came TODAY and already I cannot use it.

    Any suggestions?
  21. armerarmer macrumors newbie

    Sep 2, 2009
    LCD quits so use a bright light or flashlight to finish installation

    What happens is the LCD no longer back lights the screen. If you use a flashlight or take it under a bright light you can see the next steps you must take for installation. It is an odd problem.
  22. chiefvb macrumors newbie

    Sep 3, 2009
    Disk Utility


    how do you get into disk utility to repair disk? My mini is stuck on the wheel spinning nothing works and I don't have it backed up so I dont want to lose all my stuff by holding C and re-installing like mentioned previously
  23. LuvMacs macrumors newbie

    Sep 5, 2009
    Here's a fix

    I had a similar problem after installing Snow Leopard on my MacBook Pro - it appeared that installation was complete, but the laptop would not boot.

    Mike, from Apple Online support, after a process of trial and error worked out a fix.

    My MacBook Pro booted up again after we reset the System Management Controller and the Parameter Random Access Memory.

    Here are the steps:
    1. To reset the SMC - disconnect the power supply, remove the battery and then hold down the power button for 5 seconds.

    2. To reset the PRAM - replace the battery, connect the power supply, press the power button, holding down the Command, Option, R & P keys as the laptop starts up.

    Hope this work for you.
  24. plaw1016 macrumors newbie

    Jun 21, 2009
    Does anyone have a solution to this?

    after installing SL it only goes to the grey apple and spinning wheel and just stays like that forever. i have held down c and it says that i can restore from time machine but i dont have anything saved so i cant restore anything and it wont let me just reinstall it so im stuck. ive also tried resting the PRAM and everything else on this thread. Nothing is working. please help
  25. Philly-GUI-Dude macrumors newbie


    Sep 5, 2009
    AppleCare said my mac mini was dead! Nothing to do with SL!! :-(

    After going through the Snow Leopard installation and thinking all went well - I got some message that the installation couldn't be done - and I can't remember what the message was exactly. SO I tried again, then after several attempt, I remember my system restarting or something like that. Them it appeared that SL was going through the installation again - I got some weird message, and I remember NOT being to exit the installation, even seeing overlapping buttons on the screen. Well I don't remember what the next steps were, but I know now that my mac mini will not boot up. It starts with the chime, then apple logo, spinning wheel then my system SHUTS DOWN.

    I tried to boot up using my Leopard disc instead and same thing - system would shut down. I called Apple - we did the Command, Option, R & P keys thing, also the Command C thing - nothing - my mac mini keeps shutting down!! The Apple Care guys said that it must just be a coincidence that my system seems dead not - and nothing to do with the SL installation. He wants me to take it to see a Genius. My Mac Mini is out of warranty - so I am really upset now.

    Please - everything that I have read in this thread sounds the same, except I don't remember anyone mention that their system shuts down after initial screens. I can't even boot the discs up now :-(


Share This Page