MacBook won't boot after latest update.

Discussion in 'macOS' started by jfremani, Mar 8, 2009.

  1. jfremani macrumors regular

    Joined:
    Jan 17, 2008
    #1
    Ran the update from the Apple Update, which included iLife update and some other minor updates to the airport. Now the thing takes about 6 mnutes to boot up and once booted up, it will not respond in any meaningful way. Endless beachballs abound! I've tried zapping the PRAM, but no luck.

    Any suggestions?

    White Macbook 13", Leopard 10.5.6.
     
  2. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #2
    Also, i've tried holding down the shift key during boot with no luck (nothing happens) and also tried taking the battery out and putting it back in.

    This is pretty serious, so I hope somebody has come across this problem before and has a good suggestion.
     
  3. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #3
    So you can't do anything after it boots up? If you can, open Disk Utility and hit repair permissions. If you can't do this, I would get DiskWarrior or Drive Genius 2 to de-frag your directory and run general system maintenance.
     
  4. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #4
    Try starting in verbose mode (hold the "apple" button and the "v" button immediately after the chime and until the wheel starts spinning). With this you can see your computer boot. Use it to look for any errors that occur during startup; this will help narrow the problem down. It will probably be very obvious since, due to the 6 minute boot time, it will be a process that repeats with errors several times. As suggested, once started try using Disk Utility to repair permissions. It sounds like something got corrupted during the update, and you need to find out what it is and replace it from your hopefully existent backup, or repair it.

    Oh, and don't defrag the HDD, it can only make things worse in this particular case.
     
  5. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #5
    Thanks. it wouldn't allow me to run any programs when it booted up. I booted up from my Leopard disc and ran disk utility, but it came up with errors, as did the repair permissions function. Now, it won't boot up at all beyond the apple screen.

    I also noticed that my hard disk is no longer presented as an option in which to install leopard onto. That is quite discouraging.

    In verbose mode, it gets hung up on "AppleIntelCPUPowerManagement: initialization complete" - and goes no further.
     
  6. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #6
    When I run disk repair in disk util it reads like this:

    Incorrect flag for the hard link (id =40065)
    (It should be 0x22 instead of 0x2)


    incorrect number of thread records
    invalid volume file count.

    followed by "First Aid Failed".

    Filesystem verify or repair failed.
     
  7. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #7
    Is the hard disk not there at all, or is it listed as not available? If not available, this could be because of space constraints, and you need to access the drive by putting it into target mode, and accessing it like a hard drive through the file wire port. With this you need to pull stuff off to make room for the new OS installation. You start target mode by holding "t" down during startup.

    If this works, then follow these instructions, if not, move on to next.
    {
    It looks like this is a simple case of an install gone bad that has corrupted the filesystems in some way. Reinstall the OS, choosing to archive and install so as you replace only the System files, but keep all of your home files. This way, the install will be quick (be sure to choose "options" before installing and unclick X11, the printer drivers you don't need, and the languages you don't need). Once reinstalled you will notice a Previous System file on your HDD, but everything else will look exactly the same. Test it for a week, and if all is well, erase the Previous System folder.
    }//end "the easy way"

    If the HDD won't be recognized for OS installation
    {
    Attempt to access drive in target mode as described above to get your files off the HDD. Load OS disk in drive and boot from it. Run disk utility and choose to erase the HDD which will reformat it. Attempt to reinstall the OS. Copy over your backup.
    }

    If HDD still won't get recognized after erasing and reformatting it, or if erasing fails, then buy a new HDD, and attempt to run target mode to get your files off of the old one for the new HDD. Replacing HDD's on Macbooks is slicker than snot, and should take 5 minutes. iFixit.com has some nice directions. Let me know if this works for you. If you are able to begin a reinstallation but it fails, this could be from bad RAM. I've seen bad RAM do so many different weird things that you would never expect from bad RAM, including beep the morse code of S.O.S. on the new MBP.
     
  8. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #8
    Thanks for the help. The partition generally doesn't show up, but if it does, it does not allow an archive and install option. Rather, it states that the partition must be reformatted for installation of Leopard.

    From DiskUtility, the drive will not reformat, erase, create new partitions or any sort of thing. A "resource busy" error.

    Very frustrating. I've used computers for a long time now and never encountered a problem that a reformat couldn't solve. (short of a drive failure) - the drive is no where near full. I use about 40gb out of 200gb, the partitions are split evenly between Vista and Leopard.

    I must stress that I can boot into Vista just fine, so I'll just use Vista before going out an buying a new hard drive on a drive that works. I am too budget-oriented to be a sheepish consumer.
     
  9. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #9
    Update:

    Booted up with my old Tiger disc and the disk utility recognized the drive and partitions just fine, but could not repair it. I clicked on mount drive, then reformatted and all was fine.

    Now I can install from the Leopard just fine.

    Short story: The old DiskUtility from 10.5.4 (Tiger) appears to be more powerful in this respect.
     
  10. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #10
    Thank you for updating. That was an unusual problem.
     
  11. jfremani thread starter macrumors regular

    Joined:
    Jan 17, 2008
    #11
    It really isn't that unusual. I researched the symptoms and usually when this happens, the person buys a new hard drive because they believe that it is damaged. Mac "Geniuses" at the local Apple store also confirmed that my hard drive was dead and treated me like I'd be stupid not to walk out of there with a new hard drive.

    I also searched more in-depthly and found numerous people who, instead of buying a new drive, were able to reformat the drive by using the old disk util from Tiger.

    Anyhoot, all is running well now. Updating scares me, but I realize it is probably less common than getting into a car wreck.
     

Share This Page