Macbook won't boot after Leopard Graphics Update !

Discussion in 'MacBook' started by pqdbr, Mar 1, 2008.

  1. pqdbr macrumors newbie

    Joined:
    Sep 21, 2007
    #1
    Hi guys. Last night I installed Leopard's Graphic Update.

    I can't boot my macbook since then. Stuck at the gray screen with apple logo. Here's what I already tried to do:

    Boot with leopard DVD and run Repair Disk - it tells me the disk appears to be ok.
    If I click on repair permissions tough, it takes a long time and then hangs. Nothing happens, the progress bar even stops spinning.

    I then tried to boot with Disk Warrior 4.0 (it's the version I have). I tried reparing disk and files permissions there, and it worked ok. But I can't boot after it as well.

    Again in Disk Warrior, I tried clicking REBUILD to get my file directory back and retrieve my files, but after some seconds it states there is not enough memory. I hope this is RAM memory, because I just ordered a pair of ram chips, Im gonna upgrade it to 2gb (I only have 512mb ram, first gen intel macbook core duo)

    So ... tried SAFE MODE (shift), nothing.

    Single user mode, typing fcsk -y , reports the disk is ok, but nothing as well.

    I have a time machine backup from 11 days ago (apple makes it so easy to backup and I cant even bother plugging in my lacie firewire external hd, retarded me), and for me that´s kind of unnaceptable .. I go to university and thats 2 weeks worth of priceless annotations, I really need to get them back.

    Any ideas ? =/

    Felipe Raul
    Brazil:mad:
     
  2. FJ218700 macrumors 68000

    FJ218700

    Joined:
    Mar 8, 2007
    Location:
    Blue Dot, Red State
    #2
    find another mac, boot yours into target disk mode (hold "T" on startup) and connect it via firewire to the second mac. On the second macs desktop, your HD will appear as a connected external.

    get your data off,

    then screw around with trying to fix the boot disk.
     
  3. butang macrumors newbie

    Joined:
    Mar 1, 2008
    Location:
    CA, USA
    #3
    How about try to download standalone Leo graphics update from Apple site while you're computer is connected via target mode with host mac, then just install it on to your HD instead of host mac HD. It could be kernel stack or someting..

    PS - I should read your post more carefully..... Yeah sounds like your HD is full.
     
  4. pqdbr thread starter macrumors newbie

    Joined:
    Sep 21, 2007
    #4
    Well, my HD isn´t full, it had around 5 gb left.

    The only problem is that I´m in Brazil .. macs here are def. hard to find ... just one friend of mine has one, but he just moved ... =/
     
  5. brop52 macrumors 68000

    brop52

    Joined:
    Feb 26, 2007
    Location:
    Michigan
    #5
    Eesh. Those last poor 5 GB are probably heavily fragmented. Sounds like someone needs a larger HDD.
     
  6. butang macrumors newbie

    Joined:
    Mar 1, 2008
    Location:
    CA, USA
    #6
    5GB ain't too much. You should always try to keep free HD space at least 10% of your internal HD. No mac friends around you?? damn sorry to hear that. How about Apple store near by?
     
  7. pqdbr thread starter macrumors newbie

    Joined:
    Sep 21, 2007
    #7
    There are no mac stores in Brazil .. they only have authorized dealers, wich by the way are only in Sao Paulo and Rio de Janeiro as far as I know.

    There isn´t even an online mac store ...

    Well, I´m posting to give some good and bad news.

    The bad news is that I still can´t boot. Nothing manages to fix this **

    The good news is: my new 2x1GB kingstom arrived today. After installed, DiskWarrior managed to create a new disk directory for me. But even after doing this, repairing all my permissions under diskwarrior, and permissions and repair disk under leopard dvd, I still can´t boot.

    The good news then is that trough disk warrior I managed to copy the latest changes to my external HD. Since I have a time machine backup that´s 11 years old I think I will be fine, I´m restoring now.
     
  8. butang macrumors newbie

    Joined:
    Mar 1, 2008
    Location:
    CA, USA
  9. pqdbr thread starter macrumors newbie

    Joined:
    Sep 21, 2007
    #9
    Just finished the restore. Everything is fine now.

    It just boogles my mind that Apple can screw my macbook so badly with a "Graphics Update". I really couldn't get it fixed, my only luck was disk warrior being able to read the HD and allowing me to copy its contents to my external hd.
     
  10. amskram macrumors newbie

    Joined:
    Feb 23, 2009
    #10
    Excactly the same problem!

    I baught my macbook pro new just in the beginning of january. last night i installed the new leopard grapics update, and this morning when i tried to boot up it gave me the grey creen telling me that me computer needs to be shut down... i spent the day worrying about it at school, and now afterwords it continues not to boot up.

    i am in france on an exchange, im am her mostly for my photography, all of which is on that drive. and i worked full time all summer to earn the money for this lap-top.

    I am freekin out a little bit, i dont want to try anything and make things worse. the family i am staying with has a mac, which is formatted in french, would that make a diffeerence in target disk mode?

    i dont have my leopard install disks with me, i left them in america.

    can anyone give me some advice?

    Please.
     
  11. uicandrew macrumors 6502a

    Joined:
    Jan 19, 2006
    #11
    in terms of "target disk mode" it doesn't matter what language it is in.


    As long as you go into "System Preferences" and click on "International" and "Languages" and as long as English is there, you should be ok.

    Leopard is the same everywhere. all the languages are built-in.
     

Share This Page