Macbook won't boot into open firmware?

Discussion in 'Mac Basics and Help' started by littledove, Sep 8, 2009.

  1. littledove macrumors newbie

    Joined:
    Aug 8, 2009
    #1
    So, I'm still having trouble with the MacBook I posted about here. It kernel panics even more frequently now, a month later, about once every 30 minutes. I'm running 10.5.8 now (no Snow Leopard for me!).

    Anyway, the problem I'm posting about is that I can't boot into Open Firmware. It works fine just booting straight through to OS X (except about a third of the time I start up it kernel panics right after the Apple logo appears) but it won't boot into Open Firmware. I hold down Command-Option-O-F to no avail and it just won't go. (I'm trying to do reset-all to see if that helps any.)

    I tried booting into Open Firmware successfully on my other Mac so it's nothing I'm doing, this MacBook obviously has some serious issues. :confused:

    I'd rather not have to take this computer to the Apple Store again - every time I do they just reinstall the system/replace the hard drive and don't take me seriously when I say the problem is not with software. (Plus the warranty on this machine is up now and I'm trying to avoid paying hundreds of dollars!)

    Anyone know what the issue could be? i really need a new computer hahaha...

    Oh! I also tried booting into Open Firmware by holding down the power button continuously as suggested here... the on/off light blinked 3-4 times, the computer made a really long beep (like I was trying to do a firmware update), then started as normally. So I don't think that worked either lol.
     
  2. littledove thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #2
    Just to add, I have run the Apple Hardware Test, checked the HD multiple times with fsck in Single User Mode, and I just ran memtest in Single User Mode - the RAM came up ok.
     
  3. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #3
    This sounds either RAM or processor related to me. Have you tried using the Mac with different sticks of RAM installed? I know you've run tests on the RAM, but its still possible. Otherwise it sounds like it could be a problem with the motherboard itself. Has it ever been subject to extreme moisture or something like that? I agree with you that its definitely not software related. I've got somewhat similar problems going on with my TiBook right now.
     
  4. littledove thread starter macrumors newbie

    Joined:
    Aug 8, 2009
    #4
    No, I haven't. Maybe the computer just needs more RAM? I'm not sure why that would make the computer unable to boot into open firmware or kernel panic at startup though.

    I hope you sort your TiBook issues out :)
     
  5. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #5
  6. J the Ninja macrumors 68000

    Joined:
    Jul 14, 2008
    #6
    You can't boot into Open Firmware on an Intel Mac, there is no Open Firmware to boot into. And no, you can't boot into the EFI shell either, Apple didn't bother installing that.
     

Share This Page