MacBook won't charge...MagSafe adapter or battery?

Anthony T

macrumors 6502a
Original poster
Jul 10, 2008
983
76
When I plug the MagSafe adapter in, my MacBook doesn't charge. Sometimes if I keep unplugging it and putting it back in, it will do it. I noticed that the white rubber on the adapter seems a little worn and some of the wires are exposed on the end. I don't have another adapter to troubleshoot the issue, but do you think it's the adapter or my MBP needs a new battery?
 

/user/me

macrumors 6502
Feb 28, 2011
496
0
When I plug the MagSafe adapter in, my MacBook doesn't charge. Sometimes if I keep unplugging it and putting it back in, it will do it. I noticed that the white rubber on the adapter seems a little worn and some of the wires are exposed on the end. I don't have another adapter to troubleshoot the issue, but do you think it's the adapter or my MBP needs a new battery?
What do you mean by it doesn't charge? Is there no light on the charger, or just a green light..?
 

Anthony T

macrumors 6502a
Original poster
Jul 10, 2008
983
76
What do you mean by it doesn't charge? Is there no light on the charger, or just a green light..?
It doesn't light up at all and doesn't charge. I think it's the adapter though, because when I move the wire to a certain position, it works properly.
 

D.T.

macrumors G3
Sep 15, 2011
9,080
6,971
Vilano Beach, FL
It doesn't light up at all and doesn't charge. I think it's the adapter though, because when I move the wire to a certain position, it works properly.
Certainly sounds like the charger (specifically a short in the cord). Seems like a simple thing to test if you’ve got another Mac, a friend with a Mac, or an Apple store close by!
 

kevink2

macrumors 65816
Nov 2, 2008
1,346
119
About a month ago mine acted up. I noticed the computer was dead, and the green light didn't come on. I gambled and bought a new one off of Amazon, and it worked with that. If it hadn't fixed it, I would at least have had a spare after I had my computer fixed.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,365
703
When I plug the MagSafe adapter in, my MacBook doesn't charge. Sometimes if I keep unplugging it and putting it back in, it will do it. I noticed that the white rubber on the adapter seems a little worn and some of the wires are exposed on the end. I don't have another adapter to troubleshoot the issue, but do you think it's the adapter or my MBP needs a new battery?
See the link for troubleshooting MagSafe adapters at the bottom of the CHARGING section of the following link. This should answer most, if not all, of your battery questions:
 

Chimene

macrumors newbie
Jul 25, 2011
2
0
Charge icon has a x through it, not charging

When I plug the MagSafe adapter in, my MacBook doesn't charge. Sometimes if I keep unplugging it and putting it back in, it will do it. I noticed that the white rubber on the adapter seems a little worn and some of the wires are exposed on the end. I don't have another adapter to troubleshoot the issue, but do you think it's the adapter or my MBP needs a new battery?
I had this same problem, I did all the trouble shooting and nothing worked. Then it dawned on me to take the cover off the bottom which houses the battery and unplug the battery for a few minutes.... TADAAAAAA that fixed it. My charging icon now reads the time required to come to full charge and the x is gone.

Don't be afraid to remove the cover, just put your lap top on a towel on the table and place screws next to each hole. The battery tab which you will have to pull apart is small with pins

I'm only posting this for the latest users with the same issue.

Good luck
 

chrischris74

macrumors newbie
Nov 29, 2012
7
0
Power adapter 60W macbook pro

Hi,
I am looking for the schematic of the power adapter 60W
A transistor is off and I can not read its value.
Thank you for your help.
 

JoJo Zzang

macrumors member
Oct 14, 2011
65
0
Another thing to do - I've always had this happen from time to time. One thing that was suggested by Apple was to Safe Boot my Mac. It worked. Just one thing you might want to check before replacing a battery.