Macbook wont connect to network suddenly

Discussion in 'MacBook' started by Katilea, Aug 7, 2009.

  1. Katilea macrumors member

    Joined:
    Jul 8, 2008
    #1
    Hi

    For some reason my macbook wont automatically connect to my sky router when i switch it on.

    My older iBook had no problems straight away also connected via airport to same network and iMac in office is connected to router via ethernet. Can get pages on internet on both them.

    All of a sudden though Macbook just wont connect. I've tried running diagnostics and i keep getting connection timeout and its asking me to choose which network to connect to, i put password in and it still cant connect but iBook is connected to same network as we speak, i'm typing this on it!

    A few times the network icon on top right has been coloured in black and shows tick next to sky network when menu is showing but when try to get a webpage it still says i'm not connected. Tried switching airport on and off, rebooting macbook and rebooting router but still same.

    Any ideas whats happened to it? It was working fine 2 days ago! surely cant be router or signal if iBook is picking it up and online?

    Thanks

    Kati
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Have you tried removing your network under Network in System Preferences and then adding it again?
     
  3. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #3
    when i go into network after highlighting airport. it says its on but
    not connected to a network.

    under network name it says 'no network selected', if drop down menu my
    network is there as well as few of neighbours.

    If i select it asks for password i put it in it but then i just get
    connection timeout. dont see an option to delete it when its
    highlighted how do I do that?

    how come ibook can still find it and connect?

    Kati
     
  4. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #4
    This exact thing happens to me sometimes

    It's the router, or it always is in my case. Just unplug the router power cord, count to 3, and plug it in again; a reset may not be enough, and instead a complete power-down and up is in order. Wait for it to show it is connected and active, and try connecting again.
     
  5. BaronvdB macrumors 6502

    BaronvdB

    Joined:
    Oct 22, 2007
    #5
    try logging into your router and changing the name and password of your network and then try connecting with your macbook...i was having a similar problem with my mbp not connecting to my time capsule but it starting working after I did this.
     
  6. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #6
    wont i have problems getting on with the iMac and ibook then? I don't know how to log into my router? would i do that from the laptop and how if I cant get a signal or any internet pages?

    I checked macbook again this morning, its not listing any networks, tried setting new one up as i was unable to select my network or find where to delete it and now it wont accept the password either.

    I just dont get why its suddenly stopped working when it worked fine 2 days ago, cant update any software as I cant get online at all on it unless i bring it into office and connect to ethernet which kind of defeats the object of having a laptop!

    I have read that there seems to be an issue with connection timeout on macbook and leopard, does anyone know if there's a download fix for this?

    Need this fixing as I use it in bed cos have back problems and cant sit for long in office on desktop.
     
  7. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #7
    I tried connecting it via ethernet in office and downloading updates for OS X which mentioned the connection timeout issue, however it is still doing it.

    Just mystified as to why it worked fine until the other day, the iBook can still find the network i'm online as soon as I start that one up, but its not showing on macbook all of a sudden?

    can someone tell me how to remove the network or change name and password in router to see if they will work?
     
  8. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #8
    now it keeps changing, first it was showing as connected after another reboot although I couldnt actually load any web pages, i closed lid to come and desktop and tell you and when i opened it again it first showed airport as self assigned IP and showed as online then went back to been on but not connected to any network!

    Then a box pops up with a list of all networks in my area including mine but top of box says 'none of your preferred networks are available' but lists them all!!

    under network name where you turn airport on and off in network settings it now says no network selected and none are listed in that drop down menu, a minute ago when it was showing as connected my network was showing there.

    Anyone any ideas whats going on?

    The location says 'automatic'

    Thanks

    Kati
     
  9. Prospekt macrumors regular

    Joined:
    Jul 5, 2009
    #9
    Do you have 10.5.8? Its a problem that many of us have where you can only connect to the wireless internet if you have the power charger in. NO fix yet I don't think. :(
     
  10. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #10
    hi

    it is now cos i did update today as it said there was a fix, but when it stopped working it was 10.5.7 and it did same whether it was plugged in or on battery.

    Is that the 'fix' that it will connect when connected to mains? I'll go try it now and see if it works when plugged in.
     
  11. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #11
    Nope still nothing, same problem it either says something like self assigned IP and shows as connected but cant get any websites, says not connected when try to load a website

    or it goes off and and says airport is on but not connected to any network

    How can i get 10.5.8 off and go back to 10.5.7?
     
  12. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #12
    hello anyone there? still trying desperately to get laptop online :(

    Anyone know if Applejack would fix it?

    I tried utilities on the mac and airport utility says 'unable to find any apple wireless Devices'.

    One minute in Network its says it doesn't have an IP address then it has a 'self assigned IP address and can't connect'.

    Network Utility shows an IP address.

    It was doing this before i downloaded 10.5.8 which I downloaded as it said it had a fix for this issue, its not working though even plugged into mains.

    How do I get back to 10.5.7 and find out what went wrong? I thought it I go back and try using apple jack it might find the problem and fix it for me?

    any help appreciated

    Kati
     
  13. o2xygen macrumors regular

    Joined:
    Jan 25, 2009
    #13
    did you try reverting the settings to default? Also make sure your proxy settings are right, I had an issue where I was trying to connect to my home network but I forgot that I left a URL in the proxy settings that I use for when I connect to my universities network.
     
  14. Katilea thread starter macrumors member

    Joined:
    Jul 8, 2008
    #14
    Hi

    The button that says 'revert' in network settings is greyed out also apply is.

    I dont know what proxy settings are but I am housebound so I only use it in my own house with the wireless network that comes with the sky router.

    Its used so I can chat in bed as I can't sit for long due to back problems.

    I'm not that technical so havent changed any settings, it was just working one day then not the next.

    Someone suggested maybe a new network has been started in my area, that has same number or something and to change channel but I dont know how to do this.
     

Share This Page