MacBook won't connect to wireless connection.

Discussion in 'MacBook Pro' started by Dotty, Sep 2, 2007.

  1. Dotty macrumors member

    Mar 28, 2006
    Hay, i got a macbook. I've had it for about a week now. And all of a sudden i cannot connect to my wireless network. The network name shows up in the airport menu, but when i click the network i get an error "There was an error joining the AirPort network 'G604T_WIRELESS'."

    I'm using OS X 10.4.10, with all the latest updates. Could this be a hardware error? Or is this a common error? I've also rebooter the router many of times.

    Thanks for all replies in advanced.
  2. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
  3. creator2456 macrumors 68000


    Jul 10, 2007
  4. Cybergypsy macrumors 68040


    May 16, 2006
    Central Florida!
    My macbook use to drive me nuts, it would disconnect for no reason and take 60 seconds to connect if i was MBP does not do that.......never found out way
  5. Dotty thread starter macrumors member

    Mar 28, 2006
    Hay. Yeah i restarted the router and the macbook. I also formated and reinstalled OSX. Did nothing. Still the same error. Whats the repair procedure for macbooks? I bought it over in the states and now im back in the UK. Would that matter? I hear apple dropped the mail in support in the UK. Does tat mean i can just take it back to my local apple shop and get a replacement there and then? OR would i need to call before hand?

  6. Dotty thread starter macrumors member

    Mar 28, 2006
  7. mick4394 macrumors 6502a


    Oct 25, 2006
    Flyover country
    This isn't a hardware issues. It's a known software issue.

    The best thing to do with a Mac, is if you have a working Airport driver, never update it. Airport updates, often times, cause more problems than they fix.
  8. katy.did macrumors newbie

    Sep 22, 2007
    Okay, this might help! It worked for me. Hope it works for you too.

    First you need to check your router settings. Is the Wireless Security Mode set to WEP (Wire Equivalence Protection)? If so, this is what you can do.

    - Open Networking > Choose to connect using the AirPort
    - Choose the wireless network you want to enter
    - For the password, use the WEP Key from your router wireless settings page. Now here is the trick. When entering a WEP key on the mac, you need to add and extra '$' sign before your password. That's it. So if your password is - 9876543200, enter $9876543200.

    It worked for me. After hours and hours of trying and looking at that hateful error message. I found this info on someone's blog. I'd link to the original blog post, but unfortunately I lost the link. But the blogger had said that apparently, we need to add the $ sign to enable the mac to realize that what is being entered in a hexadecimal key (?). I believe this is what s/he had said.

    Oh, and also, while you are tweaking your wireless settings, you might also want to check whether your router has been set to allow all MAC addresses or just a selected few. If you don't want to allow access to all MAC addresses (allowing access to a selected few gives you a better level of security), make sure you enter your mac's unique MAC address to the list. I learnt about this the hard way!

    Hope this works out for you! Good luck!
  9. hime03 macrumors newbie

    Sep 7, 2007
    I also have a new macbook running OS X 10.4.10. I've looked in other forums and a lot of other people have problems getting on google and some other sites by wireless. Many have complained about google. Google, gmail, and sometimes even this site refuses to load when I'm on wireless. Someone said that everything was working fine until they updated to 10.4.10. I lose my complete connected sometimes (I'm the only one in the house that does) and sometimes google works for a few minutes when I restart my connection my airport connection. For now I'm just using an ethernet cord when I want stable internet. Waiting for a software update and hoping things will be fixed....
  10. chantalt macrumors newbie

    Dec 10, 2009
    Channel Islands
    my mac book will not connect to network

    For some reason, my mac book will not connect to my home network. When I enter the password it comes up with connection timeout.
  11. iBookG4user macrumors 604


    Jun 27, 2006
    Seattle, WA
    Have you tried resetting the router?
  12. SubZer0 macrumors member

    Feb 8, 2008
    Anchorage, AK
    You may want to consider changing what channel the airport is on. I don't own an Apple access point, but I have significant experience with wireless deployments. Often slow, unreliable connections can be the result of too many devices on the same channel. Go into the setup for the router and select a different channel. In 802.11 B and G, the best channels to use are 1, 6, or 11.

  13. jake1 macrumors newbie

    May 11, 2011
    Wireless Issue Solved by clearing "plists"

    I had a similar problem where my macbook pro suddenly stopped connecting to wireless networks that I used all the time at work and home. It would find them but the signal strength bar would just cycle through and then I would get a "connection timeout" message or "another device is using your IP address."

    Anyway, I went to the mac store and they fixed it in 10 seconds by clearing my "plists." I made him show me where this was located but I'm not exactly sure which plists you are supposed to clear (he cleared them so fast). If you go to your Macintosh HD located on your desktop or in finder under devices, got to Library-->Preferences-->System Configuration and you will find a lot of "plists" related to your airport and network preferences. Sorry I didn't get the specifics but I hope this helps.

    Warning: When I asked the apple guy what he had done, he said to be careful clearing you plists bc you can mess things up.
  14. TheKeeper.407 macrumors newbie

    Jun 12, 2011
    Similar Problem

    I had a similar problem until about 5 minutes ago. My problem was as follows:

    I've owned my macbook for about 2 years, and suddenly yesterday it wouldn't connect to ANY of the networks I've been using regularly since I bought it. I kept getting "Connection Timeout" everytime I entered the password to a network.

    I fixed it by doing the following:

    System Preferences -> Network -> Advanced -> 802.1X tab
    One the left panel of this tab is a list of user profiles, containing the usernames and passwords you use to get onto secured networks (such as university networks that require a username/password after you log in). Delete all profiles. Click okay, then Apply, and you should connect.

    This may not be the same problem as yours, but can be worth a shot anyways! Deleting those profiles won't have any harmful effects, you may just have to resubmit your username and password to any secured networks you use frequently. Good luck!
  15. Squashette44 macrumors newbie

    Aug 12, 2011
    Same Problem not loginning in...Think I have a solution!!!

    I have had the same problem with my MacBook. It is now working!!! I was able to login to my wifi before on my computer and then all of a sudden I couldn't login anymore. It would show an exclamation mark on the wifi logo. For some reason my computer changed the password on me (I didn't do it!!!)

    This is what I tried. I hope it works for you:
    1. Turn Air Port off.
    2. Open Network Preferences
    3. Uncheck remember networks this computer has joined.
    4. Press Ok and then Apply.
    5. Turn Airport back on and retype your password and click join.

    If this works then your password may be saved wrong in the Keychain Access application.

    6. Go to the spotlight and search Keychain Access.
    7. Under Passwords go to your network and double click on it.
    8. Click show password
    9. Type in your login password (what you use to login to your computer/account)
    10. Click Always Allow
    11. Change Password if incorrect.
    12. Save changes.

    If that didn't work try creating a new account and see if you can login from there.

    I hope this works,
  16. nyimpe macrumors newbie

    Aug 21, 2011
    Squashette44's solution worked

    Thanks, Christina! I deleted the password from my Keychain, reconnected and re-entered my password, and it worked fine.
  17. wall1512 macrumors newbie

    Aug 27, 2011
    same issue

    Thanks Christina!

    It worked perfectly well for me, too when i was experiencing the same problem but with a few different aspects.

    My MacBook pro was not automatically connecting to the internet when I would open it to use it, and I would have to manually reconnect every time, and it was becoming harder to reconnect, saying there was a problem with my connection.

    I followed several instructions on here, and Christina's instructions worked perfectly!
    Thanks again!
  18. Lewsh macrumors newbie

    Nov 11, 2011
    I've been having a problem too. I used to be connect to any of my wireless networks even after I installed OS X (Lion). Over the past few weeks however my MacBook just won't connect to my wireless router. Sometimes when I load it up it works fine, but other times it just won't connect. I turn the wifi on and off and I find the network, I click on it but nothing happens until I get a timeout error.

    I've tried these solutions on this forum but none have worked/not been able to try them.

    I think this is a more recent software bug so any new help would be greatly appreciated.

    Oh and I don't think I need any solutions with regards to my router, as my roommates PC works with no problems on our network. It's just my MacBook.

  19. compost4all macrumors newbie

    Dec 29, 2011
    connection timed out

    My new Mac mini suddenly gave me this message, but my hardwired old Macmini did not. And my MacBook got the same "connection timed out" message, but was able to connect to a neighbor's open WiFi. Fiddled with some of the other suggestions above, but finally figured out maybe the problem was the router. Turned everything off. Pushed the reset button on the Linksys router. Lights came on. Fired up the computers. All worked fine. Wish the human body was so easily healed.
  20. Muriloph macrumors newbie

    Mar 9, 2012

    Ok! Same problem in a worst case scenario.

    I have a macbook air, yesterday I decide to reset it to factory default. Till there no problem, I reset it using the apple assistant. Then I tried to re-install Mac OS Lion, guess what!? My macbook won't connect to any wi-fi connection...

    I don't know what to do... I'm stuck on a screen where the only thing I can do is choose a internet connection and nothing else!

    Any one has any ideia what I can do to solve this problem?
  21. 28mystry macrumors newbie

    May 16, 2013
    Cannot connect to Wifi network

    Hey guys! My Macbookpro 09 had been connecting to the network fine, my father set up a new network, his computer logs in fine, I however cannot connect to the internet. It states invalid password but we are damn sure it's right especially after entering it numerous times. I have no idea why this would happen. Any suggestions or help would be great! Thank you!:D

Share This Page