Macbook won't connect via ethernet :(

Discussion in 'Mac Basics and Help' started by babond, Jun 1, 2009.

  1. babond macrumors member

    Joined:
    Sep 5, 2007
    #1
    So as of mid-day my Macbook will not connect to the internet in our apartment via ethernet. I have tried all my roomates ethernet plug ins and it still does not work. It shows a green light next to ethernet saying it his hooked up but it won't load any pages. I've tried network diagnostics and it found nothing so I was wondering if anyone had any ideas? When I try to go to a webpage it goes to a white screen and after 5min of trying to load it bring up the "not connected to the internet" text. I guess I'll make a trip to the apple store wednesday if at all possible unless you guys come up with something. This machine is out of warranty so I'm wondering what would be the worse case scenario and how much am I looking at spending?
     
  2. p.luik macrumors regular

    Joined:
    Jan 18, 2008
    Location:
    Faribault, MN
    #2
    Did you try a cable that you know works?
     
  3. babond thread starter macrumors member

    Joined:
    Sep 5, 2007
    #3
    indeed! is it possible my apartment and/or internet provider blocked my cpu from the network? i tend to dload music and videos (but not excessive) thus using perhaps more bandwith than the average person. i'm just freaking out. could it be a hardware thing? im connected via someones wireless right now so the internet works but not through ethernet
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    Does your roommate's computer connect through the wire?
     
  5. babond thread starter macrumors member

    Joined:
    Sep 5, 2007
    #5
    yeah. ive tried using their cord..... their outlet.... and still mine appears to be connected but won't load any pages. does it sound like my IP address is blocked? how can i tell? our internet is included through the apartment so I can't exactly call my internet provider.
     
  6. Theclamshell macrumors 68030

    Joined:
    Mar 2, 2009
  7. jman240 macrumors 6502a

    Joined:
    May 26, 2009
    #7
    Is it just the web browser?

    Reset safari from the safari menu and try again.

    Does itunes or any other internet capable app connect? Try Apple Software Update?
     

Share This Page