Macbook wont detect any battery, only runs off AC

Discussion in 'MacBook Pro' started by Nightwing786, Oct 15, 2014.

  1. Nightwing786, Oct 15, 2014
    Last edited: Oct 15, 2014

    Nightwing786 macrumors newbie

    Joined:
    Oct 4, 2012
    #1
    Hi all,

    I’ve been a long time reader but I haven’t been able to fix my issue and its been nearly 18 months, so I need your advice as to what to do.

    One day I was using my laptop (Macbook Pro Unibody Mid 2009 model) and realised that my battery was losing battery but it was plugged into the AC. Eventually my battery died so I assumed my charger had short-circuited. I used a new charger, and although it turn on my fear worsened when I realised that even with a new charger that it still said no battery available. Also the sidelights, which indicate the status of my battery, will no longer flash at all and the light on my magsafe is always green. So up to this point, my charger stopped working, and what looked like my battery had stopped working. I tried everything to resettling my PRAM and SMU to removing the battery and holding down the power button then restoring the battery. Nothing. I then had no choice but to order a new battery, which cost me £70. To increase my problem, a new battery didn’t work. I don’t remember resetting any settings once I placed the new battery in. I am now selling the battery if anyone wants it when I realised it wasn’t the problem. So then I thought, maybe the magsafe connector is the problem. But like I said previously, my computer still works when plugged in to the AC so therefore it isn’t the charger or the battery as both had been replaced, and it can’t be the logic board as my computer has been working for the last 18 months. I then did an Apple hardware Test and it came back with the code for no battery detected, even with my new battery placed inside. So this must mean that the connection between my battery and my logic board is somehow damaged. Am I right? Does anyone have any insight into how I can fix this or any place in the UK, which can fix logic boards and wont just tell me to replace it? I have a perfectly working mac when it runs off AC, and although it runs on half its CPU usage because it can’t detect a battery I have since gotten round that. I need help, and I have no idea what to do. If anyone helps me get my mac up and running I will buy you a beer or cold beverage if I’m ever in your part of the world/country.

    Regards,
     
  2. Brindusik macrumors newbie

    Joined:
    Oct 17, 2014
    #2
    same problem!!same model of Macbook

    Hi , I have the same problem as you!it happened 2-3 days ago..so strange!!
    I've checked my macbook in apple store...the only problem was with the battery..but the Genius there told me that is the logic board..and need replacement. After i came back home..the laptop detected the battery started to charge again..but when i moved(i had it on my lap)...again the X signed appeared...and since then it stays like this!
    I ordere a new battery , but the sign is still there :(.
    I was looking around youtube..and to be honest i think i will start to measure all the contacts on the mother board..one should be the faulty one...it is one sensor that tells the mother board that a battery is there and it should charge...didn;t found it from youtube videos:(
    Did you found something more?
     

Share This Page