Macbook won't read external hard drive after Mavericks update

Discussion in 'MacBook Pro' started by patasata, Feb 27, 2014.

  1. patasata macrumors newbie

    Joined:
    Feb 27, 2014
    #1
    I downloaded and installed the the OS X Mavericks update and now, my macbook won't read my external hard drive anymore. It shows up in the disk utility and I clicked Verify Disk, and Repair, and it seems that nothing is wrong with it. No errors appear in the log. When I click Mount, it tells me that it can't mount it and to use the First Aid options. I've tried Ejecting and Mounting and replugging the device in, but still no luck.

    What can I do?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    What format is the external drive,
    HFS+, FAT, NTFS?

    Did you try plugging it into another port?
    Did you try rebooting the drive?
     
  3. patasata thread starter macrumors newbie

    Joined:
    Feb 27, 2014
    #3
    It's NTFS.

    I did try plugging it into other ports, same result.

    I'm not sure how to reboot the drive. It's powered by USB.
     
  4. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #4
    Unless you need the drive to be NTFS, temporarily unload the files and format the drive as Mac journaled. That should fix your problem.
     
  5. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #5
    did you have some extension to write NTFS drives? maybe it's not working with latest OS?
     

Share This Page