Macbook won't recognize 4gb of ram

Discussion in 'MacBook' started by npiacpka, Jun 3, 2008.

  1. npiacpka macrumors newbie

    Joined:
    Jun 3, 2008
    #1
    I have a macbook running the santa rosa chipset with the intel x3100 GMA GPU. I purchased 2X2gb ram chips for it last night, but when I put them in, the screen doesn't come on, and i get three beeps and 3 flashes of the LED. If i put my 1 gb back in, it boots right up.
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    That's going to be either incompatible or faulty RAM. Return it.
     
  3. Cave Man macrumors 604

    Cave Man

    #3
    Or one of the SO-DIMMs is not seated properly.
     
  4. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #4
    Put one chip in at a time to narrow it down.

    Same thing happened to me with 2 chips from OWC. Turned out one chip was faulty.

    -Kevin
     
  5. sushi Moderator emeritus

    sushi

    Joined:
    Jul 19, 2002
    Location:
    キャンプスワ&#
    #5
    If you try to put one in at a time, try each port as well.

    My PowerBook has one port go bad. The other one worked fine. Apple ended up replacing the Logic Board. Now it works fine.
     
  6. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #6
    What's happening is you are not pushing the RAM fully into the socket.

    When you push the RAM in, it goes in 1 inch and stops. You're not done.
    Get both thumbs on the RAM and push it harder, it will go in another 1/8th of an inch. If you don't have dents on your thumbs, you didn't push hard enough.

    It doesn't 'click', and you can;t see what you are doing, so you have to go by feel.
     
  7. sclough macrumors regular

    Joined:
    May 23, 2008
    Location:
    Kansas City, MO
    #7
    If you haven't already, I would definitely try to carefully re-install them. I had something similar when I upgraded my MBP from 2GB to 4GB (OWC Memory). I carefully removed the 4GB and re-installed it making sure it was seated properly, hit the button and it booted up. I've changed memory before on plenty of machines, so I'm not sure what was wrong the first time, but it never hurts to verify.
     

Share This Page