Macbook won't recognize new hard drive, even in Disk Utility

Discussion in 'MacBook' started by Drewbacca503, Apr 12, 2010.

  1. Drewbacca503 macrumors newbie

    Joined:
    Apr 12, 2010
    #1
    My macbook hard drive crashed, luckily I had just backed up everything. I went and bought a new 320 GB hard drive, I researched and I know it's compatible with my Macbook. I decided to install windows 7 on it first, but the windows 7 installer wouldn't recognize my hard drive.

    (For the record, my Matsushita superdrive will not read DVDs anymore, only CDs, so I created bootable copies of both my Mac OS X install disk and my Windows 7 install disk, and I've been using a bootable rEFIt CD to boot from my USB flash drive.)

    So I booted up the Mac OS X Snow Leopard disk and started disk utility - it recognizes the rEFIt CD, it recognizes the flash drive, but no internal hard drive. The partitioning tool in rEFIt doesn't recognize it either, but I know it's seated correctly because I can hear/feel it booting up with the computer (if i remove the battery and boot with the computer plugged in). I also know it works correctly because I installed it in my girlfriends PC and it recognized it just fine, I even installed Windows 7 on it, hoping the macbook would boot from it.

    So now I'm stuck. Any ideas would be great. :)
     
  2. Reflow macrumors 68000

    Reflow

    Joined:
    Mar 30, 2005
    Location:
    NJ/PHL
    #2
    Did you format the drive correctly using disk utility? Also what partition map scheme did you use? It has to set up as Apple Partition Map for it to work.
     
  3. FrozenDarkness macrumors 65816

    Joined:
    Mar 21, 2009
    #3
    I think the guy just said that disk utility won't even recognize it. I have this same problem, does anybody have a clue?
     
  4. CrackedButter macrumors 68040

    CrackedButter

    Joined:
    Jan 15, 2003
    Location:
    51st State of America
    #4
    I recently had this problem with my Macbook and an SSD, nobody could help me but I did put it inside an enclosure and it started to work, that was useless for me since I wanted it as a boot drive but I knew then the problem was with the SATA controller.

    I ended up sending the SSD back. It worked inside my housemates late 2008 MacBook though. :(
     
  5. AshMan macrumors regular

    Joined:
    May 1, 2010
    #5
    Check to make sure the cable is securely fastened. Also listen to see if you hear the drive spin up when powering on. The computer. You can also try resetting the pram or smc not sure on the key command to do that.

    I would think it could be a slightly unseated cable if the computer does not recognize it at all.
     
  6. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #6
    No, Apple Partition Map is for PowerPC Macs... it needs to be formatted GUID for Intels. But it should still show up in Disk Utility regardless.

    Possibly the drive is 7200RPM and your Macbook needs a firmware update to understand the faster speed of hard drive...
     
  7. drum4work macrumors newbie

    Joined:
    Sep 7, 2010
    #7
    MacBook Paper-Weight?

    I have the same problem that seems to be plaguing so many MacBook users. Hard Drive crashed, then flashing question mark on folder. No HD found.

    I have replaced HD with Seagate 2.5" 250GB @ 5400, and MB won't read it in Disc Utilities. I've read all the forums I could find, and the problems seem to either go unanswered (same with Apple, except they just want you to keep sending it back) or suggestions range from useless to comparing other computer systems. I've tried to boot from original CDs. I tried the SMS reset. I tried the PRAM shock. I just can't get the new HD to show up anywhere.

    I just want to figure out if my MB, which I loved until it's crash, is now just a $1200 paper-weight. Please help. I've got enough junk on my desk already.
     
  8. blackburn macrumors 6502a

    blackburn

    Joined:
    Feb 16, 2010
    Location:
    Where Judas lost it's boots.
    #8
    What model is your macbook? Maybe it needs a jumper in the hdd to make it work at sata 1 instead of sata 2
     
  9. porschemik macrumors newbie

    Joined:
    Sep 9, 2010
    #9
    Macbook Paperweight

    I also have the same problem ,with my MBP swapped out 2 other drives from childrens MBP with the same outcome,but was able too use it with an external drive ,from my trusty Powerbook. Im thinking the sata buss cable or the buss on the logic board is the problem .By the way it works ok with the external drive so ii use my macbook 13.3 sitting and watching the tube:
     

Share This Page