MacBook won't shut down or log off without pressing power button

Discussion in 'macOS' started by MacNewbie22, Jul 23, 2007.

  1. MacNewbie22 macrumors newbie

    Joined:
    Jul 23, 2007
    #1
    I'm having a problem with my MacBook- for the past month or so the only way I can shut it down is by pressing down the power button. When I hit shut down or log off on the apple menu nothing happens at all. The same applies for e.g. when the software updates require restart- when the computer prompt comes up to restart and i say ok, nothing happens. I bought my computer in March 07 and it's OS X 10.4 tiger (I think!)
    Can someone tell me what I need to do -is it just a pathway that's missing and how do I fix it?
     
  2. FJ218700 macrumors 68000

    FJ218700

    Joined:
    Mar 8, 2007
    Location:
    Blue Dot, Red State
    #2
    start by repairing disk permissions. If still no luck, try creating and temporarily using a new user account just to see if the problem persists,
     
  3. ultimateceej macrumors regular

    ultimateceej

    Joined:
    Jul 24, 2007
    Location:
    Texas
    #3
    I have the same problem with my macbook pro. I've tried repairing permissions with Onyx and Disk Utility and deleting login.plist and com.apple.login.plist. Tried creating a new account too, but that didn't work either. The weird thing is that it will shut down before I have logged on to either account at the login screen.

    EDIT: If I use fast user switching, I can get to the login window and shutdown or restart from there but I first have to type in my name and password.
     
  4. doug.hall macrumors regular

    Joined:
    Jul 28, 2005
    Location:
    London
    #4
    That is exactly what happens with all my SR MBs (four in total). I've not tried the fast users option so I'll do that tomorrow. This is really disappointing because I recommend apple to everyone i know but the SR macbooks are proving to be a real pain. In addition to the restart/shut down issue I've found on the four macbooks I have all of the trackpads are jerky. My old PB kicks ar5e compared with the new macbooks. To be honest I don't think it's much slower either (unless using handbrake).

    Update on 27th December - This issue appears to be fixed now. Trouble is I'm not sure how becuase I've not changed anything or applied a software update either. Hmm??? Strange but I'm not complaining:)
     
  5. Likugha macrumors newbie

    Joined:
    Mar 28, 2008
    Location:
    Lebanon OR
    #5
    Did anyone ever find a fix that was not as ghetto as switching between to accounts. Because I to have the same problem.
    -I tried using a few programs( e.g. shutdown x)
    -I tried command line but that is timely
    -Would love someone to figure a permanent fix
     
  6. ltldrummerboy macrumors 68000

    ltldrummerboy

    Joined:
    Oct 15, 2007

Share This Page