Macbook won't sleep, getting REALLY OLD

Discussion in 'MacBook' started by wheezy, Aug 30, 2008.

  1. wheezy macrumors 65816

    wheezy

    Joined:
    Apr 7, 2005
    Location:
    Alpine, UT
    #1
    I've searched. I've googled, I've figured it out only to not actually figure it out. My Macbook won't sleep. I close the lid, a few seconds later the drive makes it's sound and it's alive and kicking.

    I sleep from the apple menu and leave it open, a few seconds later the screen kicks on and it's alive again.

    It just won't sleep.

    I've read that it's attributed to a faulty bluetooth module, it gets too hot or something and even though you put it to sleep, it kicks the computer back on because it's having a problem. I've discovered that when Bluetooth becomes not available, I can use SMC Fan control to kick up the fans, cool it down and bring the bluetooth back. So, just now, I kick up the fans, bluetooth is okay and functioning fine, I put it to sleep.

    1 minute later it's awake, bluetooth is not available and the damn thing won't sleep. I'm at my wits end here. I have having to shut down just so I don't overheat the it while it stays on all night cooking away, or burn the fans out by having them crank at 5000rpm all the time.

    HOW DO I FIX THIS!!! (I'm outside AppleCare :()
     
  2. macbooker15 macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Hello! I'm over here!
    #2
  3. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #3
  4. simonjones88 macrumors newbie

    Joined:
    Oct 10, 2008
    #4
    was this issue ever resolved? (as i have come across the same problem this evening)
    both Bluetooth: Not Available and the no sleep issue...

    I really hope this isnt terminal, as i can't really afford or justify the repairs out of warranty, although it does make for a good excuse to get one of the new macbooks cue next week!!:D

    So yeah....was it sorted???

    Cheers,
    Si

    Edit: what's the chances that simply REMOVING the bluetooth chip will solve this issue??
     
  5. simonjones88 macrumors newbie

    Joined:
    Oct 10, 2008
    #5
    ok, so i just spent the last hour opening up my macbook and removing the bluetooth chip (for want of a replacement when i can find one!)

    The good news is IT WORKED!!! (so far)
    It would seem that removing the bluetooth chip has solved the problems with it's interference in sleep mode.
    My hope is that this is a permanent fix, i'll post updates next week.

    Any ideas where i can find a replacement chip (in the UK)?
    ideally not from apple, as their in house repairs are extortionate outside of warranty!!

    Cheers,
    Si
     
  6. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #7
    If you can't find one PM me - got several !!
     
  7. BrianJK macrumors newbie

    Joined:
    Oct 28, 2008
    #8
    Sleep issue

    Had similar problem with my G4 PB (1.33Hz): greatly delayed sleep when I closed the lid, and sometimes reawakening after commanded to sleep. For me what worked was turning off Bluetooth from the menu bar before sleeping, or just using a USB mouse (and no other Bluethooth device). It is not sufficient to simply uncheck the "Allow Bluetooth devices to wake this computer" in the Keyboard & Mouse control pane, as is often suggested. No need to fuss with the actual chip, I think.
     
  8. dleemon macrumors newbie

    Joined:
    Oct 30, 2008
    #9
    Getting Your MacBook To Sleep

    This problem has been plaguing me, like many others, for months. I've tried everything recommended, and no dice. BUT, I may have figured it out. I think it's related to Airport, maybe the persistent "scanning" that Airport does. So, my "work around" is this: Whenever I get the "bluetooth not available" icon up top, I know it's not going to sleep when I want it to. If I turn Airport off for a few minutes, the bluetooth icon goes back to normal and the computer will sleep. It helps to leave Airport off when putting it to sleep -- otherwise it sometimes reactivates.
    I'd love to know if this works for others --
     
  9. albanmews macrumors newbie

    Joined:
    Jul 29, 2008
    #10
    MacBook wouldn't sleep - cured itself!

    I suffered the same problem with my 1 1/2 year old MacBook Pro not staying asleep. This started after updating to Mac OS X 10.5.8 about a month ago; never had this problem before. Two weeks before the update, I had done a total erase and reinstall, so the software and vanilla settings shouldn't have been a problem.

    I checked many Forums for answers and tried all they suggested. Bluetooth is off. Reset PRAM and SMU. Turned off Mail and all other programs. Reset sleep mode. I even tried invoking the name of the ghost that seemed to be affecting my sister's electronics. Nothing worked! So I kept doing Shut Downs each night for a week to keep my MBP from getting hot with it turning itself on and keeping the internal fans blasting on high; I periodically tried to put the MBP to sleep (both with the menu selection and by shutting the cover), but it kept waking itself up after about 30-60 seconds.

    I decided to take my MBP to my local Apple Store for them to look at the problem (I have AppleCare). Magically, the day before I got home, sleep started working again! I can't recall any updates between the last non-sleep and sleep finally working again, but I guess there must have been one - either that, or the ghost finally gave up!

    Sorry I can't offer more help - I can only offer hope that your Mac will magically heal itself too!
     
  10. cellocello macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #11
    Do you have any running processes, like Connect360 to stream to an Xbox? Any type of streaming / sharing software running at all?

    Have you ever installed InsomniaX or similar software?
     
  11. gotnospice macrumors newbie

    Joined:
    Sep 19, 2009
    #12
    Figured out how to fix it...

    Shut the lid, and you'll hear the CD drive and then the screen turns on about ever 5 seconds.
    Set the energy saver to sleep after 1 min, and only the screen shuts off, the computer never sleeps
    Go to the Apple menu and go down to sleep and nothing happens

    Looked online and it seems like a lot of people are having this issue. They seem to think it's the bluetooth, but my MacBook doesn't have bluetooth, so I knew that wasn't it.

    Things I did to try to fix it:
    I don't have bluetooth so it's not that. It started after a Leopard update and continues still on Snow Leopard.
    I reset the SMU and PRAM which didn't work.
    I tried changing the hibernation modes from 3 to 0 and 1, none fixed it. I used
    sudo pmset -a hibernatemode 0
    I put it back to 3 and thought maybe it was the Airport constantly scanning.
    I shut off the airport and shut the lid. Bingo it went to sleep just like normal.
    I turned the Airport back on and now it sleeps like normal, no more issues.

    http://forums.macrumors.com/showthread.php?t=554150
    http://discussions.apple.com/thread.jspa?messageID=6900532
    http://discussions.apple.com/thread.jspa?threadID=1187506
     
  12. koopa35 macrumors 6502

    Joined:
    Aug 7, 2008
    Location:
    Los Angeles, CA
    #13
    sigh i have same issue. but now my bluetooth is available and my macbook still wont sleep. mind u i have 2 hard drive in mines. but i have had this setup for many months. and it just started yesterday.
     
  13. KielderWolf macrumors regular

    KielderWolf

    Joined:
    Aug 1, 2009
    Location:
    Northeast England
    #14
    You have a MacBook, you have BlueTooth. Even the first MacBooks came with BlueTooth 2.0 +EDR fitted as standard. It hasn't been optional since the October 2004 iBook.
     
  14. oldwindowsguy macrumors newbie

    Joined:
    Oct 10, 2009
    #15
    I might have a solution....

    I also think this is caused by an overheating Bluetooth module,
    but since I don't use any Bluetooth connections, I don't care about it.
    But it's frustration that this keeps my MacBook from going to sleep.
    So what I discovered is that Bluetooth has a option/setting that
    allows a Bluetooth device to wakeup the MacBook.
    Hmmm, if this settings tells OS X to allow a wakeup from say
    a Bluetooth mouse, maybe a faulty Bluetooth module gives an
    invalid wakeup indication, and every time the MacBook goes
    to sleep, it get's re-awoken. This matches the symptoms I
    see. Close the cover, goes quiet, then you hear the DVD drive
    grind, same as if you opened the cover. But then the MacBook
    determines that the cover is closed... back to sleep. An endless
    loop. If you click the Apple icon, and select sleep, it goes to sleep
    and the just wakes up.
    So, turn off that setting and your MacBook will go to sleep even
    with a faulty/overheated Bluetooth module. Works for me.

    You may have to power-off you machine for a while, set it in a
    cool place, and after you start it back up, Bluetooth should show
    up in System Preferences. So follow these steps.

    System Preferences.
    Bluetooth
    Advanced
    Uncheck "Allow Bluetooth Devices to wake this Computer"
    (this is Snow Leopard, may be different in early releases)
     
  15. macbooker15 macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Hello! I'm over here!
    #16
    The only problem is that that is only temporary :). Turning the computer off for a while does indeed fix the problem until the module over heats again. I have found that PRAM reset before a long shutdown can keep it from coming back for longer, but it may just be the placebo effect.
     
  16. oldwindowsguy macrumors newbie

    Joined:
    Oct 10, 2009
    #17
    Agreed. But since this looks like a faulty Bluetooth module, and I don't
    use any Bluetooth devices, replacing the module doesn't make sense for me.
    I just want my MacBook to go to sleep when I close the cover.
    Changing the Bluetooth preferences fixes this for me.
    There is that application smcFanControl "that is supposed to
    be able to speed up the fan to avoid overheating", but it doesn't
    seem to work for Snow Leopard(?)
    Edit
    It does work on Snow Leopard, playing with it now.
     
  17. oldwindowsguy macrumors newbie

    Joined:
    Oct 10, 2009
    #18
    Ok...I have a guess as to why smcFanControl isn't
    bulletproof. The increased fan speed is a good thing,
    but when your MacBook goes to sleep, the fan shuts
    down and smcFanControl goes to sleep also (of course).
    Then the battery must still give off enough heat, or
    something still generates heat in sleep mode and the
    Bluetooth module overheats.
    I just had that exact thing happen... my MacBook was
    sleeping with the lid closed, and I heard the DVD drive
    whirl, but the MacBook went back to sleep. Yeah! When I finally
    did open it up, the Bluetooth icon had that wavy line through
    it, meaning it had been lost. After the fan kicked in for a while,
    Bluetooth came back. So, I think my main complaint with sleeping is solved.
    One caveat... if you reset your PRAM, then that Bluetooth
    setting will go back to the default.(the "blued" plist is recreated,
    wherever that thing is stored)
     
  18. iraisis macrumors newbie

    Joined:
    Jun 20, 2010
    #19
    Fixed problem

    I had the same problem my 2 year old macbook. I wanted it to sleep and i'd try any of the way to tell it to and it would black the screen but the little sleep light stayed on and the hard drive sound would come after 4 seconds and it would be awake.

    I was reading through this forum and i started to try some of the things that worked for other people, like wifi, bluetooth. Didn't work. Then I thought, wait maybe it's my external hard drive, connected by USB. Didn't work. but I was close. It turned out to be an external USB hub/card reader that was preventing the computer from sleeping. My problem solved!
     
  19. johnwennerberg macrumors newbie

    Joined:
    Oct 11, 2010
    #20
    A possible solution!

    I've been battling with this problem for over a year. And today, I might, just might, have made some progress.

    I've identified the wake up reason to a usb-connector that seems to point to the bluetooth. The bluetooth has always been quirky on my soon to be 5 year old macbook. Today I tried something new. I removed these files:

    Look in /System/Library/Extensions
    And copy these to another folder:
    IOBluetoothFamily.kext
    IOBluetoothHIDDriver.kext

    and then remove them.

    This seem to have solved the problem for me. It does mean that there'll be no more bluetoothing, just so that you are aware.

    Also note that if you do a system update, these files might be reconstructed. So if it starts acting up again, remove the files again.

    Please let me know if this solved your problems. I'm still not sure wether my macbook just started sleeping by chance or by my meddling.
     

Share This Page