Macbook won't sleep

Discussion in 'MacBook' started by WKowalski, Apr 25, 2012.

  1. WKowalski macrumors newbie

    Joined:
    Sep 26, 2009
    #1
    My first-gen MacBook is running 10.6.8. For a few weeks now it's been going to sleep only sometimes, when I close the lid. I've been poking around all over the web and through a lot of forums. Here's what I've tried:

    • checking printer queue and uninstalling printer
    • there are no Bluetooth devices enabled
    • unplugging, removing battery and holding down power button for five seconds
    • resetting PRAM
    • resetting SMC
    • repairing permissions
    • setting to Sleep from Apple menu doesn't work
    • logging in as another user gives the same problem
    • booting in Safe Mode doesn't work
    • resetting Energy Saver settings to default
    • opening Terminal and running pmset -g assertions (this gave me all 0s except for EnableIdleSleep 1, but didn't give any further information)
    • installing PleaseSleep, setting Energy Saver to sleep in 1 minute--it still won't sleep.

    UPDATE1 I typed syslog |grep -i "Wake reason" into Terminal and got a whole buttload of responses. It seems there is a USB error happening that causes it to wake. Example: Wake reason=USB4 USB7 What does this mean and how do I deal with it?

    UPDATE2 I remembered that this MacBook was set up to synch with my wife's iPad2, so I disabled that feature on the iPad2 and also on the MacBook. Didn't help.

    Interestingly, it did go to sleep when I let it time out naturally according to Power Saver setting before installing PleaseSleep. So what could be happening here?
     
  2. WKowalski thread starter macrumors newbie

    Joined:
    Sep 26, 2009
    #3
    Thanks. After running PleaseSleep and reading the log I realized that this problem is probably due to LogMeIn, which to be honest I don't even remember installing. The log file of PleaseSleep indicates that it's getting messages from LogMeIn every ten seconds.

    So, I need to uninstall LogMeIn. Sounds simple, right? It's turned into a hellish process. There is an old thread on this site about how hard it is to uninstall. I can't even find an uninstaller program for LogMeIn. It's not included in the package, and using Pacifist I still can't find it. :mad:
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    The most effective method for complete app removal is manual deletion:
     
  4. WKowalski thread starter macrumors newbie

    Joined:
    Sep 26, 2009
    #5
    I have solved the problem. LogMeIn was preventing my computer from going to sleep. This should have been easy, and in fact in the end it was, but in my mind LMI is now classified as Malware and I spit upon it. I have finally succeeded in uninstalling LMI and now my computer will go to sleep. I can only conclude that LMI was what was keeping it awake.

    Here is a link to the thread about uninstalling LMI if anyone else is having a similar issue:
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    Now that you've removed LMI, you might want to check out TeamViewer, which is free for personal use and works with Windows, Mac OS X, Linux, Ubuntu, iPhone, iPad, etc. It's very secure and quite simple to set up and use (no messing around with ports), which comes in handy if providing remote support to those who aren't very computer literate. You can talk them through the setup on their end and be connected to them in less than a minute. I prefer it over LogMeIn because it includes free file transfers between computers, a feature I use frequently.
     
  6. WKowalski thread starter macrumors newbie

    Joined:
    Sep 26, 2009
    #7
    Thanks! Would you say the file transfer capability is any better than sharing files between a MacBook and an iPad2 using iTunes? Can it do that?
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    The file sharing in TeamViewer is though a Finder-type interface, where you select files of any type (not just music) to transfer from one computer to another. It's not anything like iTunes Home Sharing.
     
  8. WKowalski thread starter macrumors newbie

    Joined:
    Sep 26, 2009
    #9
    Well... guess what. The problem is persisting. It's intermittent, and I can't even seem to determine what factors cause it. Sometimes it goes to sleep when I close the lid. Sometimes it goes to sleep when Energy Saver tells it to. And sometimes it doesn't.

    Today I am going to do a clean re-install of the OS and then use Time Machine to restore my user settings and data. If this doesn't work I'm going to assume it's a hardware issue.
     

Share This Page