Macbook won't start up/ hdd not mounted...

Discussion in 'MacBook' started by lmvo23, Jun 3, 2010.

  1. lmvo23 macrumors newbie

    Joined:
    Apr 20, 2009
    #1
    I have a mid-2007 white macbook that I bought used last year. I have had absolutely no problems with it until a few days ago...

    First, safari froze (spinning beach ball). I only had 2 tabs open (cnn and facebook) and Mail. Not much going on, it has never froze like that so I let it sit for about 10 minutes. It was still spinning when I came back so I did a hard shut down (held power button). I tried to turn it back on about a minute later but it wouldn't go past the grey screen...and then the lovely folder/question mark came up. Joy oh joy.

    So I booted from the install disk and it said my hdd was not mounted. I ran disk utility and it gave me these errors:
    -Invalid node structure
    -Volume needs to be repaired
    -Error: The underlying task reported failure on exit

    then I hit "repair" and it said:
    -Invalid node structure
    -Rebuilding catalog B-tree
    -The volume could not be repaired

    Grrr. Tried a few more times and same result. I also reset the PRAM and SMC. No luck.

    Also I tried to boot up from cd again yesterday and it wouldn't boot up, it kept ejecting the disk. I also tried diskwarrior, and again, it ejected the disk. I called tech support at apple and he told me to leave it alone until they could look at it, obviously whatever the problem is, is getting worse.

    I bought a firewire cable in hopes that I could mount it in Target Disk Mode to my iMac and save some photos...the fw symbol appeared on the macbook screen but my iMac didn't detect anything attached to it.

    I'm not too worried about losing my data since I don't have much on there except full resolution photos from the last few months...but it would be nice to recover those if the hdd is toast. I think I've learned my lesson to back it up more than 4 x a year.

    Anyway, I have an appointment at an apple store tomorrow but I just wanted to see if anyone had any suggestions of what to do at this point. Thanks.
     
  2. AndyK macrumors 65816

    AndyK

    Joined:
    Jan 10, 2008
    #2
    The genius bar will more than likely sort it for you, however have you tried removing the drive & putting it back in?
     
  3. bbazzahh macrumors newbie

    Joined:
    Jun 3, 2010
    #3
    Flashing folder = HDD

    If you cant boot to the installation disc to do an Erase and Insatll - Most likely more issues with your portable
     
  4. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #4
    bbazzahh is right. Either the data on your hard drive is corrupt and you need to re-install the OS, you need to reset the HD as the boot device, or the HD is dead and needs to be replaced.

    The first thing to try would be to boot up from an OS X install disc or Restore Disc and see if Disk Utility sees the drive. If it does, try setting the HD as the Startup drive or re-install OS X. If it doesn't see the drive, it may be time to replace the HD.
     
  5. lmvo23 thread starter macrumors newbie

    Joined:
    Apr 20, 2009
    #5
    Just wanted to give everyone an update. First off, this problem is covered by a repair extension noted here:
    http://www.apple.com/support/macbook/hd/repairextension/

    I took my computer in to the genius bar, told them the problem, they had the hdd swapped out in 20 minutes, no charge to me. I was also able to keep my old drive in hopes that I can recover the data myself. To top it off, they installed a 160gb hdd- my original was 120gb!!! Not sure if that was a mistake or not...but needless to say, I'm beyond satisfied. Thanks Apple!!!
     

Share This Page