MacBookPro EFI Firmware Update 1.5.1 won't load

Discussion in 'Mac Basics and Help' started by A1bsteg, May 26, 2008.

  1. A1bsteg macrumors newbie

    Joined:
    May 25, 2008
    #1
    Each time my MacBook Pro checks for software updates, I am told that MacBook Pro EFI Firmware Update 1.5.1 is available. I click on install, the installer runs and says installation was completed but the next time I check for updates, there it is again. I've tried to install several times, but System Profiler still does not show the updated firmware version number, so it apparently hasn't installed, regardless of what the update installer tells me.

    Any ideas?
     
  2. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #2
    Just check the instructions for installation.
     
  3. SamoanDude macrumors regular

    Joined:
    May 22, 2008
    Location:
    United States Now
    #3
    Yea, power down the computer. Then hold in the power button until you hear a long tone and it will begin the update
     
  4. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #4
    You have to manually install it. Look in your /Applications/Utilities folder and you should find the file there. Launch it and follow the instructions EXACTLY.

    The next time you launch Software Update, you won't see it in the list and after you apply the update, the System Profiler will show a new firmware version number.
     
  5. A1bsteg thread starter macrumors newbie

    Joined:
    May 25, 2008
    #5
    Thank you. I never would have known where to look for the installation program or that it had to be installed manually. There was no indication at all in the Software update dialog. Once I knew where to look and what to do, it worked just fine! Thanks again.
     
  6. 123456789101112 macrumors newbie

    Joined:
    May 12, 2011
    #6
    Broken/Incomplete Update

    I had the same problem, but when I hunt down the update in my Utilities it says it is damaged or incomplete...?
     

Share This Page