macbookpro stuck at grey screen and can't see newly installed disk

Discussion in 'MacBook Pro' started by Arsene1406, May 16, 2012.

  1. Arsene1406 macrumors newbie

    Joined:
    May 16, 2012
    Location:
    Bangkok, Thailand
    #1
    Hi everyone,

    I've got a very huge issue that needs your help.
    I got a Macbook Pro (2010 version). It was working pretty fine all this time but somehow it just became a bit slow compared to when i bought it. Then last week, it just got a bit slower than usual that i decided to restart it. And when i did, it wouldn't go past the grey screen with an apple logo and the spinning wheel (it would get stuck there for hours!!!). I searched the internet for some solutions but none of them could solve my problem.

    I even had to format my disk, lost all my data that wasn't backed up yet, and still it didn't work!!! I also tried to reinstall the OS but i wouldn't work. One time the installation was successful but when the computer booted, it didn't go past the grey screen. Stuck there again for hours...

    Then i was told that my hard-disk is dead. So, i went out and got me another disk: a Western Digital 500Gb 5400rpm disk but my Mac can't see it (i.e not visible in Disk Utility). After trying again and again, i decided to change it to Hitachi 500Gb 5400rpm (because the original says HITACHI 160Gb 5400rpm) but the same problem persists. Strangely, if i put back the old hard-disk, the computer can see it!!!! :confused:

    Now again i changed to Seagate 500Gb 5400rpm and it still doesn't work!! :mad: Surprisingly, both disks work fine if i connect them to an external enclosure (except for the Hitachi disk which even Windows OS can't recognize: the worst of all!!).

    Is there a way of fixing this problem? I really don't know what to do....

    Whatever ideas or suggestions you have are so welcomed.

    I REALLY NEED HELP WITH THIS GUYS, PLEASE!
     
  2. Arsene1406 thread starter macrumors newbie

    Joined:
    May 16, 2012
    Location:
    Bangkok, Thailand
    #3
    The disk was formatted

    Yes,
    actually i did format them using another Mac computer because my one could not recognize/see them. I'm pretty sure the disks were formatted.
     

Share This Page