Resolved MacBook's SuperDrive in PowerBook G4 - works, but not recognized properly

Discussion in 'PowerPC Macs' started by j00z3k, Apr 8, 2012.

  1. j00z3k, Apr 8, 2012
    Last edited: Apr 11, 2012

    j00z3k macrumors newbie

    Apr 8, 2012
    Hello all.
    I have a PowerBook G4 15" 1.33 GHz (model A1095) with Matshita CD-RW CW-8123-C (COMBO 8123A) Combo drive, running Mac OS X Leopard 10.5.8 and MacBook C2D 13" (model A1181) with Panasonic DVD-RW UJ-857-C (SUPER 857CA) SuperDrive. MacBook is dead, but its SuperDrive is good.
    But, when I put MacBook's SuperDrive in PowerBook, connecting it with the cable from PowerBook (I don't have a connector from MacBook), it works normally, reads both CDs and DVDs, but it's still recognized by Leopard as Matshita CD-RW CW-8123, preventing me from recording DVDs.
    Is there any possibility to make it recognized properly and allow to write DVDs? Or is it just impossible, and is just my luck, that it is even reading discs?
    Thanks in advance for reply.
  2. MAC MAN JW macrumors 6502


    Jul 12, 2011
    Try to reset the PRAM Hold Command-Option-P-R at startup hold the keys to your hear 2 start up tones:)
  3. j00z3k thread starter macrumors newbie

    Apr 8, 2012
    Problem solved

    Thanks for reply.
    I guess it worked, or I must have mistaken something...
    I noticed, that now with my original Combo drive, it's recognized as Matshita CW-8123, and with my, apparently, SuperDrive, it's recognized as Matshita CW-8221 (Combo, not SuperDrive), so I guess I must have been cheated (I bought MacBook 13" on the auction), because someone changed the drive bezel I think, which is saying that it's SuperDrive... Even the serial number on a bezel doesn't match to the serial number inside the drive...
    Anyway, I think the problem is solved, and again, thank you.

Share This Page