Machine to Develop On

Discussion in 'iOS Programming' started by Dellaco, Apr 24, 2012.

  1. Dellaco macrumors newbie

    Joined:
    Apr 24, 2012
    #1
    Hello, thank you for reading this. I would like to make iPad apps, and I want as cheap of a starting cost as possible. I have heard that I need a Mac with 10.5.7 in order to develop so my questions are:

    A) What is the oldest piece of hardware that can run OS X, especially 10.5.7?

    B) Can you remote to a mac using a Windows machine, and how many connections can it handle through remote?

    Thank you for your time.
     
  2. Carob macrumors newbie

    Joined:
    Apr 19, 2012
    #2
    I'm not sure about 10.5.7. My impression is you need Snow Leopard (10.6) for the latest SDK, and you'd be better off having Lion (10.7) for best compatibility. Lion's system requirements are a Core 2 Duo with 2GB RAM.
     
  3. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #3
    Any Intel Mac ever produced (since ~2006) will run 10.5.

    I'd suggest trying to find a system that can run 10.6 and try to learn with Xcode 4. This way you can target iOS 5 and can use the most recent version.

    I'd recommend any 2007 or later Mac that can have at least 4 GB of RAM, and the more RAM the better.

    B
     
  4. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #4
    You will need a Mac with a C2D or later CPU running OS X 10.7 Lion to develop iOS apps (older CPU/OS/Xcode combos won't support any currently selling iOS device). The cheapest used/refurb Mac you can find that runs Lion will do.

    A stock Mac will allow one VNC remote session. There's add on software that will allow more. No problem remoting to a Mac from a Wintel PC or iPad.
     
  5. Comeagain? macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
    #5
    I'd go find a refurb Mac mini. It's most likely the cheapest, most reliable Mac you can get that will still have a warranty and apple care.
     
  6. cMacSW macrumors regular

    Joined:
    Mar 20, 2006
    #6
    I think if you want to develop for iOS5.1 you will need Lion (10.7)
     
  7. jnoxx macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #7
    If you want to build for iPad 3 you need OSX Lion* :)
    I know it sux, but I have the same issue with my 24" iMac, that's why i'm selling ^_-
     
  8. larswik macrumors 68000

    Joined:
    Sep 8, 2006
    #8
    I found recently that Apple likes to keep everything close from you OS, Xcode and the latest version of the ios.

    For instance, last week I was in Las Vegas with my Laptop and brought a project with my. Found out that I did not have 5.1 SDK on my laptop, So I needed the new version of Xcode to get it but xcode required that I have the latest up date of Lion to 10.7.3 from my 10.7. They like to keep everything updated to work it seems.
     

Share This Page