machine won't boot - from HD or Intsall disk

Discussion in 'MacBook Pro' started by DuendeVision, Jun 5, 2010.

  1. DuendeVision macrumors newbie

    Joined:
    Jun 5, 2010
    #1
    My mac Book won't boot from the install Disk or from the Hard drive. Booting to hard drive in SIngle user mode gets to that it's loading drivers..goes 1 1/16 rows of dots. Waits a while spurts a few more.. continues to wait and spurt for about 10 minutes and the reboots. When not in single user mode I never get the initializing symbol. When booting from Installation Disk it starts to read from the disk, I get the initializing icon and then nothing.. once in a while I can hear the DVD drive read/search and then nothing. I've reset NVRAM/PRAM doing the Command/Option P-R thing. Safe Mode of course isn't relevant. I've been looking for instruction on how to l load firmware to a downed machine but haven't been able to find anything on it yet but figured I'd RTfM'd enough to pose my dilemma to this forum.

    I was reinstalling OS yesterday due to some flaky problems. Now the flakes became a blizzard.

    (More Information)
    It's a friends and I just got it yesterday. I have no bootable backup drive. Initially it wouldn't boot.. in single user mode it got to the point of initializing the journals and crapped out. Disk Repair wouldn't touch it. I didn't have a copy of Disk Warrior to boot from so I figured nothing lost if I reinstall the OS... same results after a reinstall of the OS so I re-partitioned the drive, installed OS and it worked fine. I did a restore from a time machine back up he had made. He had a copy of disk warrior so I checked the drive and it was fine. However it seemed a bit sluggish at times... leaving the beach ball on for what at first seemed just a second. then incrementally got worse until finally it hung after a few hours of this. I checked the disk a few times and it was always fine. I'd like to think it is a firmware issue since I'm in Guatemala and service isn't an easy or cheap thing and my buddy's a Guatemalan musician. No ay mucho denero. SO that's why I was asking what I asked in my original post. It does start to read from the CD ROM when trying to boot of the Installation Disk.. and I guess it's looking at the disk drive since the boot file path is being recognized and it does appear as if it's trying to load some of the drivers.
     
  2. lilcosco08 macrumors 65816

    lilcosco08

    Joined:
    May 27, 2010
    Location:
    Dayton
    #2
    Try burning a copy.
    The other day I did the same thing with my old inspiron 1501. It wouldn't read the legit install disk, so I "got" another copy on another dvd and it worked
     
  3. DuendeVision thread starter macrumors newbie

    Joined:
    Jun 5, 2010
    #3
    I tried my own install DVD for my MacBook Pro with the same results. However I think I read some where that with the newer machines that run Snow Leopard won't boot from a boot disk (like Disk Warrior) from an earlier version. So maybe my Install DVD won't boot and new MacBook Pro. I'm only asking since I don't want to waste a DVD if I needn't. Resources are in short supply where I live in Guatemala.
     
  4. DuendeVision thread starter macrumors newbie

    Joined:
    Jun 5, 2010
    #4
    What threw me off in this whole problem was that when I tried the OS install from DVD I got the apple logo and the initializing symbol spinning and it just stayed in that state. I'd assumed that at this point the OS install would come up regardless of the status of the disk drive (after all we need to get to disk utility).

    However if I held down the alt/option key when booting to select my boot device, and waited a few moments, the Install CD appeared and became an option to boot from. Then it worked fine. It appears that when holding down the "c" key to boot from the CDrom it expected a usable disk.

    Thanks all for your help.
     

Share This Page