"Macintosh HD" cannot be modified?

Discussion in 'MacBook Pro' started by wcalderini, Sep 24, 2008.

  1. wcalderini macrumors member

    Joined:
    Dec 7, 2004
    #1
    Macbook Pro • 2.4 Intel Core 2 Duo • 4GB Ram

    Last night I upgraded the above from the original 200GB HD to a WD 320
    Scorpio. Install went fine. Repartioned drive for GUID, 1 partition, Mac OS extended, journaled.

    Restored contents from a time machine backup. Boots up fine. All runs well.
    Everything was restored.

    The problem.
    When I try to copy a file from the desktop to the hard drive I get the following message: The item "file name" could not be moved because "Macintosh HD" cannot be modified.
    While I do have the option to "authenticate" and on typing in my admin password I am able to copy the file, but to have to do this EVERY single time would be an unacceptable burden.

    What I have tried.
    Checked the "Get Info" box and made sure I had "Read/Write" permissions on everything.
    Verified and repaired disk permissions both from a separate boot device, and while in the current OS.

    My first thought was to modify the hard drive via the "get info" box and apply the "read and write" to all enclosed folders, but the last time I did that I got stuck in an eternal boot loop, had to archive and re-install and had to, after much frustration and searching, modify all of my external drives via terminal because I had suddenly been "locked out" of them.

    I'm thinking this is something simple that I'm missing.
    I have searched the forums here, but maybe I'm putting in the wrong search criteria, becuase I'm not finding much info.

    Hence the post.
    Any help will be appreciated.
    Thanks in advance.

    WRC

    (By the way I have installed a boot camp partition that I am running Vista Home Premium 64 on. but the problem was occurring prior to that install)
     
  2. itistoday macrumors newbie

    Joined:
    Sep 24, 2008
    #2
    I'm confused, you copy a file from your desktop to the drive? Are you booted from this drive?

    In other words are you doing this:

    /Users/<your name>/Desktop/file => /

    Or are you doing:

    /Users/<your name>Desktop/file => /Volumes/SomeDrive

    ?

    Either way, this sounds like a permissions/owner problem. Can you post screenshots of the location you're copying to? Here's what my boot drive looks like:

    [​IMG]
     
  3. wcalderini thread starter macrumors member

    Joined:
    Dec 7, 2004
    #3
    It was very Strange...

    The problem was this:
    After I installed my new hard drive, and restored my old system and files from a Time Machine back-up I could not do the following things:

    Any file I had saved to my desktop could not be moved onto my hard
    drive icon, or any folders within, without "authorizing" via the admin password.
    I could not create a new folder within the hard drive "folder".

    I did finally mange to "fix" it, but I'm still not sure it is supposed to be this way.
    After rebooting from the CD and running "fix disk permissions" from disk utility
    I was finally able to "correct" the problem by granting read and write privileges to "everyone".

    If I go back and just use "System" and "User" read and write privileges and turn off that option for "everyone" the same problem occurs.

    It has me kind of confused and there does not seem to be a whole lot out there on this particular problem.

    I imagine the REAL solution will lie somewhere in a Terminal App script,
    but for now I guess I'll just leave my drive open until I can find a solution.
    (I Really do not want to do an archive and install as that usally costs me a few hours in re-installing certain apps like the Adobe creative suite)

    Still any help or advice will be appreciated.

    WRC


    Okay. After messing around a bit I clicked on the "plus" button on the the bottom of the "get info" HD icon box.
    It took me to a user list where I was able to "add" myself as a user. (Even though I already had admin privs)
    What was strange, is that the "user" that I thought was already "me" was listed as my admin password.
    Still confused.
    But functional.
     

Share This Page