Macintosh HD permissions changed to "no access"

Discussion in 'macOS' started by tomu570, May 18, 2009.

  1. tomu570 macrumors newbie

    Joined:
    Jan 14, 2009
    #1
    White MacBook running Leopard gets stuck at grey start up screen with spinning wheel after the Sharing & Permissions for everyone on the "Macintosh HD" was changed to "no access".

    I booted off of system disk and ran Verify Permissions and that gave me the message " Disk Utility stopped repairing permissions on "Macintosh HD" because the following error was encountered: The underlying task reported failure on exit"

    Archive and Install failed as well.

    Tried booting off of Disk Warrior CD but MacBook kept restarting while holding down the C-key.

    Luckily I did a back-up last week using Time Machine. But I would still like to refrain from a clean install if I can help it. There were a few new files and installs that occurred after the last back-up. Albeit not a major problem.

    So now I'm trying to change Permissions for the HD using Terminal. Current settings listed below.

    total 12
    d-wx-wx-wt@ 2 root admin 1024 May 18 06:50 .Trashes
    --w--w--w- 1 root admin 4096 May 18 06:50 ._.Trashes
    drwxrwx---@ 47 root admin 1666 May 18 06:57 Macintosh HD
    lrwxr-xr-x 1 root admin May 18 06:32 Mac OS X Install DVD

    But when I use the "chmod 755 Macintosh\ HD/" command in the Volumes Directory I get

    "chmod: Macintosh HD/: No such file or directory.

    Are their 3 spaces in that command? Or am I missing something else?

    Thanks to all who reply.
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    You messed it up. However others have done it before. Search the threads and you'll find the answer.
     
  3. tomu570 thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #3
    Thanks for being so helpful. I have searched and found nothing other than what I've tried. Hence the post.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    google:
    change permission no boot site:forums.macrumors.com
     
  5. tomu570 thread starter macrumors newbie

    Joined:
    Jan 14, 2009
    #5
    chmod 1775 /Volumes/"HARD DRIVE" did the trick!

    Apparently you must use quotation marks when your volume's name has a space in it.

    Other posts have mentioned the fsck -f thing in single user mode and chmod 755 in the in the Volumes Directory through Terminal and they just didn't work in this case.
     
  6. AGuzman macrumors newbie

    Joined:
    Aug 29, 2009
    #6
    cmod 777 /volumes/"Macintosh HD" worked

    cmod 777 /volumes/"Macintosh HD" worked
     

Share This Page