MacMini 2012 Wi-Fi Issue

Discussion in 'Mac mini' started by jamespurdy2, Mar 28, 2013.

  1. jamespurdy2, Mar 28, 2013
    Last edited: Mar 28, 2013

    jamespurdy2 macrumors newbie

    Joined:
    Mar 28, 2013
    #1
    I have a MacMini 2012 running OS X 10.8.2. Since I have had it, I have been operating on a WPA Personal Wi-Fi connecting with no problems whatsoever. I happened to log on to a WEP Network today and ever since, it will not connect to the net.

    I have 6 other computers on the same network and they all work swimmingly. It shows that it is connected but Safari won't connect. I tried making a new location in the network settings like I saw on some posts and nothing!

    Please help! :eek::apple:
     
  2. hamkor04 macrumors 6502

    Joined:
    Apr 10, 2011
    #2
    Same here. Yesterday spent 56minutes with Apple Support and had to hung up. There is no solution they could provide what so ever. I have 3-4 years old PC works with no problem when 2012 mini is dropping wifi every 2-3 minute.
    Had to get 10miter ethernet cable and hook my mini to router from next room.
     
  3. jamespurdy2 thread starter macrumors newbie

    Joined:
    Mar 28, 2013
    #3
    Solution

    I broke down and paid the $20 to have Apple call me. Here is what they did:

    First, they had me make a test user account on the computer to test if it was the whole system, or just my user account. The net worked fine on the test account, so we knew it had to be some dumb setting.

    I logged back in to my regular user account, and the net still didn't work.

    This is what made it start working again (I know it sounds ridiculous but it worked):

    Go into Macintosh HD, then system. Search for a folder called "SystemConfiguration". Drag the whole folder to your desktop. That is it. After I did this, it worked.

    I know. WTF. :mad:
     
  4. BookEmDanno macrumors member

    BookEmDanno

    Joined:
    Nov 9, 2010
    Location:
    State of ~Aloha!~
    #4
    i had same issue with my late 2012 mac mini. But it's a little different than the OPs experience. my wifi connection would either drop or very, very slow. I know it wasn't my router since I also had a macbook pro at the same room that did not have any problems at all. From google search, I found out the issue existed with other's mac mini's. To resolve, I did the following:

    On this path /Library/Preferences/SystemConfiguration/

    NetworkInterfaces.plist
    com.apple.airport.preferences.plist
    preferences.plist

    I deleted the above 3 files, and re-booted. Those files are re-created after the reboot.


    FYI
     
  5. Moccasin macrumors 6502a

    Moccasin

    Joined:
    Mar 21, 2011
    Location:
    Newcastle, UK
    #5
    Sounds like the last two solutions are one and the same. Apple support simply moved the folder into the desktop rather than deleting the files in it. By moving the folder, when the computer re-booted, new versions of the files were created.
     
  6. amerdian macrumors newbie

    Joined:
    Feb 16, 2013
    Location:
    London, UK
    #6
    I have also been experiencing either excruciatingly slow or even occasionally dropping Wi-Fi on my 2012 Mac mini, especially since I connected a new magic trackpad I bought.

    I found this discussion online: https://discussions.apple.com/thread/4450655?start=0&tstart=0 which basically says there might possibly be a conflict between bluetooth and Wi-Fi on Mac minis, especially if you have bluetooth devices previously connected to the Mac, but no longer in range.

    Long story short, I decided to turn off bluetooth completely (and to keep my trackpad on the shelf until I connect my mini again via ethernet), and I did notice a significant improvement on my Wi-Fi performance (not as great as what I had seen with ethernet, but definitely useable).

    You might want to check that if you have bluetooth devices connected to your Mac.

    Hope this helps! :)
     
  7. ed-hawco macrumors newbie

    ed-hawco

    Joined:
    Aug 1, 2009
    Location:
    Montreal, QC
    #7
    Just giving this topic a brief shake to say I noticed my late 2012 MM was running at about 8 or 9 Mbps, while my Macbook Air was hitting 30 Mbps in the same room. I tried all of the things listed here and elsewhere, re: bluetooth, configuration files, safe mode, etc. Then I shifted the MM's body literally 12 inches to the right. Boom, 30 Mbps.

    I don't know what was causing the interference, and I'm surprised that such a small move could make such a difference, but there it is, right in front of me. Moral of the story: try the easy things first.
     

Share This Page