MacMini showing up as PC server in finder

Discussion in 'macOS' started by spectre51, May 2, 2010.

  1. spectre51 macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #1
    I have three Macs a MacBook, MacMini and iMac. On the iMac and MacBook if I have show bonjour computers in the shared section of the finder sidebar the MacMini shows up there as a PC Server. It is actually listed twice once as a PC Server and the other as a regular MacMini (the regular MacMini disappears if I uncheck Back to My Mac in the finder preferences)

    I can connect to the shared folders via both the regular MacMini or the PC server version. Not sure how I can remove this rogue PC Server version of the MacMini. There must be some software installed that is causing this but I can't think what it might be.

    Anyone else have this issue? I know I can just uncheck bonjour computers but thats not what I am trying to accomplish I don't want it to show up as a PC server or at least find out what is causing it.
     
  2. VPrime macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
    #2
    Do you have SMB sharing enabled on the mac mini (so it shares with windows computers)?
    If so, that is why.
     
  3. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #3
    Don't think that is it because I have SMB sharing enabled on the MacBook and iMac and both those systems are not showing a PC Server version in the finder.
     
  4. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
    #4
    The second poster is correct. SMB (samba) shares show up as PC shares. AFP / netatalk shares can show up looking like mac / airport icons.
     
  5. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #5
    Never had that be the case. Always had smb sharing enabled because I have a PC on the network. Again my iMac and MacBook do not show up that way on any of the other systems just the MacMini

    [​IMG]
     
  6. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #6
    Just for ***** and giggles I disabled the smb sharing from all my machines. The MacMini is still showing up this way in the finder.
     
  7. spectre51 thread starter macrumors 6502

    spectre51

    Joined:
    Feb 25, 2008
    #7
    Rebooting didn't fix the issue but relaunching the finder manually did. No more Mac showing as a PC server.
     

Share This Page