macOS 10.12 Sierra Unsupported Macs Thread

Discussion in 'macOS Sierra (10.12)' started by FilthyMuppetInnuendo, Oct 25, 2016.

  1. FilthyMuppetInnuendo macrumors newbie

    Joined:
    Oct 25, 2016
    #1
    Hi, everyone. Is there a feature to search within only a specific thread? 140 pages are a pain to read through. I’m running into an error during installation on my 2009 Mac Pro, but I can’t export the log (the installer just hard freezes everything before I can do so) and I can’t seem to reset the installer to try again (it would probably work if I wiped the stick and rebuilt it, but I want to avoid that if I can). I just want to search this thread for anyone else having the same or similar error before potentially repeating something common.

    Funny thing is, I managed to get Sierra installed and working perfectly on this thing before, but for only one boot session. After which it wigged out and I had to revert things.

    Thanks for any help!
     
  2. FilthyMuppetInnuendo thread starter macrumors newbie

    Joined:
    Oct 25, 2016
    #2
    Wait, did I do something wrong? I didn’t mean to make a new thread. It says the post was moved.
     
  3. whitedb macrumors newbie

    Joined:
    Jan 2, 2017
    #3
    Any suggestions for getting WiFi to work on a Mac Pro Early 2008?

    I have just used dosdude1's great patcher to install Sierra on my MacPro 3,1. Everything went smoothly except for no wifi and the following "learnings":

    - I downloaded the latest 10.12.2 installer on a supported mac and it worked fine with the tool
    - I needed to disable SIP (I was moving from Yosemite but had previously tried El Captan on a a spare disc
    that had enabled it)
    - Whilst I was able to do the install with the Sierra Test disc in an external USB caddy, it would not boot from it.
    - I had to install the Sierra disc in one of the internal drive bays when it worked fine and I can boot.

    Whilst I have connectivity via ethernet the Wifi card is not seen. This is not a problem except Siri needs it for location services.

    I know there are problems with some airport cards but from dosdude1's instructions I thought it would work. The details of my card are as follows:

    Card Type: AirPort Extreme (0x14E4, 0x88)
    Firmware Version: Broadcom BCM43xx 1.0
    (5.10.131.36.16)

    The card type is not on his list of NOT supported so I was hoping it would work. Am I just out of luck or is there something I can do? Does anybody know of a UK source for the latest WiFi/Bluetooth card that will support continuity and removes the compatibility problems.

    Thanks for you help.
     
  4. sonofsnak macrumors newbie

    sonofsnak

    Joined:
    Apr 27, 2016
    #4
    Possibly a stupid question, but can I expect any issues going to Sierra from my upgraded Early 2009 Mac Pro (6 core & 5,1)?
    about.jpg
     
  5. sonofsnak macrumors newbie

    sonofsnak

    Joined:
    Apr 27, 2016
    #5
    Sorry, moved this to Mac Pro. It's pretty specific.
     
  6. idoccurt macrumors regular

    Joined:
    Aug 25, 2006
    #6
    Just upgraded to 10.12.4. Apparently a huge mistake...cannot even login,,I get to login screen and cannot do anything further from there. Keyboard doesn't type or anything. Cannot get to disk utility to fix. Suggestions?
     
  7. johnsawyercjs macrumors member

    johnsawyercjs

    Joined:
    Feb 27, 2007
    #7
    Sounds like you had SIP (System Integrity Protection) turned on, and at reboot it rebuilt a USB-related kext to make it into a standard Apple version, replacing the version that MacOS Sierra Patcher installs (I think that's the deal--someone correct me if I'm wrong). The fix is to restart your Mac from your MacOS Sierra Patcher installer USB drive, open the MacOS Sierra Patcher utility from the window that will appear, and select its option to reinstall the Sierra Patcher patches. After the patches are reinstalled, an option will appear in the patcher window to also rebuild kexts--you need to select this too. This process can take a while, but just be patient and let the Mac restart itself after it's done.
    --- Post Merged, Mar 29, 2017 ---
    This discussion is now at https://forums.macrumors.com/threads/macos-10-12-sierra-unsupported-macs-thread.1977128/
     
  8. sonofsnak macrumors newbie

    sonofsnak

    Joined:
    Apr 27, 2016
    #8
    A wireless keyboard not enabled can do this. I always keep an old wired mouse and keyboard for emergencies so that I can get in and troubleshoot better.
     
  9. zodbert macrumors newbie

    Joined:
    Mar 30, 2017
    #9
    I have exactly the same problem. (MBP 5.3)
    --- Post Merged, Mar 30, 2017 ---
    Will try this, thanks.
     
  10. idoccurt macrumors regular

    Joined:
    Aug 25, 2006
    #10
    Ok, for some reason i may be doing/creating an installer wrong for my USB drive.. Can you help me out...I tried just dragging sierra patch onto it...doesnt work
     
  11. Dominic2 macrumors newbie

    Joined:
    May 11, 2017
    Location:
    S Oregon
    #11
    Hi, Sorry if asked before but this discussion goes on forever and i can't see to search. I did the sucessful install on an early 2008 iMac.
    The wireless, as noted, does't work but ethernet option fine. I have an audio issue which is that i have only one volume, flat out full on. So, yes in some, for example video playback i can reduce the volume using their sliders, but the system volume is always maxed out. When i use sound mute or up or down keys, i get the graphics and all suggesting the sound is being increased or lowered or muted, but that doen't really happen, the sound stays full tilt on. Anybody had the same issue and resolved it?
     

Share This Page