Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

macOS 11 Big Sur Safari YouTube 4K HDR VP9 support

iMacDragon

macrumors 68000
Oct 18, 2008
1,940
375
UK
Hmm, even with the supposedly vp9 compatible chrome 86 I'm still not getting HW acceleration there..
 
Comment

iMacDragon

macrumors 68000
Oct 18, 2008
1,940
375
UK
Yep, I already did that and it was turned on.. so quite puzzled.
Or more accurately it was on 'default' and I enabled it to no difference.

Edit: ok, just tried again.. and today it finally seems to actually be working for me too. ( on both default & enabled )
 
Last edited:
  • Like
Reactions: CMMChris
Comment

eicca

macrumors 6502a
Oct 23, 2014
625
486
Any love for Safari 14 on Mojave? I can play 4k 60fps videos in Chrome absolutely flawless, but Safari can't even handle 1080p60 videos without tons of freezing and stuttering.

I enabled the WebRTC vp9 codec in the developer menu but still can't even see an option for 4k on Safari 14. 1080p60 still stutters.
 
Comment

startergo

macrumors 68030
Sep 20, 2018
2,710
1,148
Any love for Safari 14 on Mojave? I can play 4k 60fps videos in Chrome absolutely flawless, but Safari can't even handle 1080p60 videos without tons of freezing and stuttering.

I enabled the WebRTC vp9 codec in the developer menu but still can't even see an option for 4k on Safari 14. 1080p60 still stutters.
There is no VP9 decoding in Safari in any other version than Big Sur.
 
Comment

Superhai

macrumors 6502a
Apr 21, 2010
622
426
I enabled the WebRTC vp9 codec in the developer menu but still can't even see an option for 4k on Safari 14. 1080p60 still stutters.
The WebRTC option is not for normal playback, it is used for WebRTC applications. Typically like streaming out of tour computer.
 
Comment

Earl Urley

macrumors 6502a
Nov 10, 2014
513
218
Welp, under beta 10 on a Late 2013 13-inch rMBP with Iris GPU, all the 8K videos I was able to play before during that brief time it was enabled now give me 'An error has occured. Please try again later..'

If I disable the VP9 decoder, then they'll play at 1080P, 60 FPS as before.

Oh well..
 
Comment

WaruiKoohii

macrumors 6502
Oct 4, 2015
423
445
Boston
2018 15" MBP. Safari won't play Youtube it throws an error, but 4k VP9 HW acceleration is working in Chrome with the VideoToolBox flag set. HW acceleration not working in Edge but playback is fine otherwise (just with higher CPU usage).
 
Comment

ArPe

macrumors 6502a
May 31, 2020
507
935
No problem here, video acceleration is much better than beta 9 across YouTube, Apple TV and Amazon Prime in 4K/UHD/HDR formats.

User interface is faster than before while playing those videos.

Just have some Bluetooth mouse interference when the videos are playing.

I’ll do a broader stress test on the weekend to see if I can break something, but so far beta 10 is pretty close to what I would call GM quality.

I can only imagine how slick it will be optimized for Apple Silicon.
 
Comment

LFC2020

macrumors 65816
Apr 4, 2020
1,429
1,725
latest public beta cant watch YouTube in safari, keep getting playback error. 🥺

Cleared safari history, still won't load videos.
 
Comment

Superhai

macrumors 6502a
Apr 21, 2010
622
426
For me beta10 works the same as the last, nothing changed. Not for the worse or the better.
 
  • Sad
Reactions: LFC2020
Comment

iMacDragon

macrumors 68000
Oct 18, 2008
1,940
375
UK
Yep, seems to generally be working ok here.. only arguable issue is on chrome youtube still tries to output HDR at true level without tone mapping down, so anything very bright just goes white ,where safari tonemaps perhaps too far the other way to keep everything clear.
 
Comment

RednBlue

macrumors regular
Dec 17, 2013
160
63
Reading UK
Since last Big Sur update I can’t watch Amazon Prime videos/movies on either Safari app although they play perfectly on Chrome browser. Any suggestions?
 
Comment

TL24

macrumors 65816
Oct 20, 2011
1,205
776
Since last Big Sur update I can’t watch Amazon Prime videos/movies on either Safari app although they play perfectly on Chrome browser. Any suggestions?

Been having the same issue, I've had to revert to using Chrome for Amazon Prime.
 
Comment

ArPe

macrumors 6502a
May 31, 2020
507
935
Since last Big Sur update I can’t watch Amazon Prime videos/movies on either Safari app although they play perfectly on Chrome browser. Any suggestions?

If it isn’t a beta 10 problem you might have something in cookie or browser cache that needs flushing. Reset the browser history, delete everything in your home library/cache folder, reboot. Then check.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.