Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
Since updating to macOS 13.1 link files, that I have dragged i.e. from Firefox onto the Desktop, open when double-clicked with Safari only. It is not possible anymore to change the default application for such files to Firefox.

Firefox is since it exists my default browser. Years ago I changed once the default application for link files to Firefox, and from then on, throughout many OS versions, these files always opened in Firefox - until yesterday after updating to macOS 13.1.

Apple, in their infinite wisdom, have changed the default application for such files to Safari only and disabled the option to change this. See attached screenshot. The "Open with" option is greyed out and cannot be changed. (The default application for other file types can still be changed, just like in previous decades).

Is there another possibility to change the default application for link files to Firefox, i.e. with Terminal?
 

Attachments

  • Link File Info.jpg
    Link File Info.jpg
    157.4 KB · Views: 546
Last edited:
  • Like
Reactions: Deedeekay

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
M
system settings>desktop & dock>scroll down to 'default web browser'...
As I wrote in my original post, Firefox IS my default browser. This setting has nothing to do with no longer being able to change the default application for this particular "webloc" file type.
 

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
try changing the default to safari, quit settings (maybe reboot). then re-select firefox, save a link, see if that changes anything...
 

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
try changing the default to safari, quit settings (maybe reboot). then re-select firefox, save a link, see if that changes anything...
I did that already. Doesn't help.

Link files were opening as they should in Firefox in 13.0, but don't anymore in 13.1.
 

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
I did that already. Doesn't help.

Link files were opening as they should in Firefox in 13.0, but don't anymore in 13.1.
i never work that way (links on the desktop), and don't use firefox... but i just dragged a chrome link onto the desktop, and i can right-click on it, and choose chrome to open it. try that.
 

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
i never work that way (links on the desktop), and don't use firefox... but i just dragged a chrome link onto the desktop, and i can right-click on it, and choose chrome to open it. try that.
I know this is possible, but it is quite different from simply double-clicking on a file.

You do not address my point and question: Apple has eliminated in macOS 13.1 the ability to change the default application for webloc files in the "Get Info" window (while this is possible for other file types - as it always has been). This option is now grayed out in the "Get Info" window, which is just idiotic. I am looking for someone who knows how to change the default application for webloc files in other ways (e.g. in the terminal).
 
Last edited:
  • Like
Reactions: timelessbeing

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
I know this is possible, but it is quite different from simply double-clicking on a file.

You do not address my point and question: Apple has eliminated in macOS 13.1 the ability to change the default application for webloc files in the "Get Info" window (while this is possible for other file types - as it always has been). This is just idiotic. I am looking for someone who knows how to change the default application for webloc files in other ways (e.g. in the terminal).
right, but am pointing out a very-simple workaround. right-click>select is no more complicated than double-clicking.

but i agree, there's no logical reason the option to change the default app for a link (and then being able to click change-all)) should be greyed out. a bug? report it...
 

tozzo

macrumors newbie
Mar 31, 2020
8
6
I have experienced this as well. It is very annoying and most likely a bug. I tried to search for ways to correct via terminal but could not find anything easy. At every turn my system is telling me my default browser is what I want, but all .webloc files launch Safari.

I reported as a bug using the well written description in this post.
 
  • Like
Reactions: BR485

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
I have experienced this as well. It is very annoying and most likely a bug. I tried to search for ways to correct via terminal but could not find anything easy. At every turn my system is telling me my default browser is what I want, but all .webloc files launch Safari.

I reported as a bug using the well written description in this post.
sounds like a bug. for now, right-click is a workable alternative, at least...
 

tozzo

macrumors newbie
Mar 31, 2020
8
6
I did more digging and it seems we were never able to change the default app for .webloc files, as it is tied to default browser. But I set my default browser as Firefox, and the system reports that, but still associates .webloc files with Safari. This is new for 13.1 and definitely a bug. I reported it properly, as it is not about changing the default app, but the system ignoring the default browser setting.
 

dethier1958

macrumors newbie
Dec 14, 2022
4
9
I have also experienced this bug after updating to 13.1 ... Yes, you can right click and open with, but this is not as convenient as just double clicking the webloc file. I did submit a bug report to Apple using their feedback reporter.

There is also a thread on Reddit at https://www.reddit.com/r/MacOS/comments/zm3wbh on this problem, but no answer as of yet ...
 
Last edited:
  • Like
Reactions: eltoslightfoot

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
I also reported this bug to Apple.

It would be interesting to see what happened when double-clicking webloc files without Safari being installed. Unfortunately Apple - again in their infinite wisdom - has made it impossible to delete Safari (and other extremely vital applications like i.e. News).
 

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
I also reported this bug to Apple.

It would be interesting to see what happened when double-clicking webloc files without Safari being installed. Unfortunately Apple - again in their infinite wisdom - has made it impossible to delete Safari (and other extremely vital applications like i.e. News).
exactly, so it's irrelevant.

people should report this to apple, and they should fix it. in the meantime, you have a workaround (right-click).

it's apple's OS, if they want us to have safari (or chess 🤔), that's how it goes (safari, btw, is 15megs; tiny).
 

desertman

macrumors 6502a
Original poster
Jul 14, 2008
697
37
Arizona, USA
exactly, so it's irrelevant.

people should report this to apple, and they should fix it. in the meantime, you have a workaround (right-click).

it's apple's OS, if they want us to have safari (or chess 🤔), that's how it goes (safari, btw, is 15megs; tiny).
It's not up to you to decide what is relevant or irrelevant to me.

Not everyone is an Apple Fanboy. Some Mac owners still believe they should be able to do whatever they want with their computer. And yes, that includes tinkering with it until it stops working.
 
Last edited:
  • Like
Reactions: BR485 and eldho

fisherking

macrumors G4
Jul 16, 2010
11,177
5,515
ny somewhere
It's not up to you to decide what is relevant or irrelevant to me.

Not everyone is an Apple Fanboy. Some Mac owners still believe they should be able to do whatever they want with their computer. And yes, that includes tinkering with it until it stops working.
not a fanboy, just a fan... with some reservations.

my point was, it's irrelevant whether this would work if safari were uninstalled, since that's not do-able (altho there are workarounds...). i did not say your point-of-view was irrelevant.

but this: "Some Mac owners still believe they should be able to do whatever they want with their computer."

i get that, but also that there's no way apple can make everyone happy. and it's their OS, we just license it...
 
Last edited:

dethier1958

macrumors newbie
Dec 14, 2022
4
9
I have not yet heard of any workaround to open webloc files in the default browser. I did throw together a web page that will convert a webloc file to an html file that will redirect to the url from the webloc file. The original webloc file will not be modified.

The converter is at https://www.gradekeeper.com/webloc/

You can convert multiple webloc files at a time. The resulting html files will be downloaded to your computer. Double clicking on an html file will open it in your default browser.

I am still hoping this is a bug and that Apple will fix it eventually. But if Apple really intends to open webloc files by default in Safari instead of the default browser, an html file that redirects to the url might be an option until other web browsers can come up with an alternative to webloc.
 

eldho

macrumors regular
Aug 16, 2011
175
97
I have also found this extremely annoying and assumed that it was sheer arrogance on Apple's part in pushing their own browser. I prefer Firefox and have it as my default browser but that behaviour was negating my choice. I have found however that I am able to change the 'opens with' to Firefox - it is not greyed out for me on my M1 mini. It is still annoying to see Safari listed as being the default when it is not so on my computer.

Thank you for this topic which has solved the problem for me, though is was still annoying to have to change each webloc to what it had been originally. I hope I don't have to do this again every time there is another updating of the OS.

And now I am really annoyed. I went back to test the change and it has ignored it so that I cannot simply click to use the browser I prefer. It seems I have to choose opens with every b.... time, or use the work around mentioned above, or drag the url into my browser window as I had been.
 

lyleberman

macrumors regular
Jul 8, 2007
113
84
Annapolis, MD
I'm having the same issues for .URL and .WEBLOC files as of Ventura 13.1.
Using Firefox v108 but tried it with the previous build as well.
 

dbrewood

macrumors 6502a
Jun 8, 2018
676
223
Manchester, UK
If you are a Keyboard Maestro user there is a macro that I requested which was used to save a webloc file on the desktop at the activation of a button. The dev who created it for me has kindly updated it so it saves a HTML file on the desktop instead. Works well for me. You can find the thread and macro here.
 
  • Like
Reactions: dethier1958
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.