macOS could not be installed on your computer

Discussion in 'macOS High Sierra (10.13)' started by deadstk, Dec 19, 2017.

  1. deadstk macrumors newbie

    deadstk

    Joined:
    Dec 19, 2017
    Location:
    San Francisco Bay Area
    #1
    I have a 15" MacBook Pro (late 2011) with a freshly formatted 500 GB (Mac OS Extended journal - GUID partition map) hard drive that I'm attempting to install High Sierra on that keeps running into an error at the end what seemingly looks/feels like a full install process.

    I downloaded High Sierra 10.13.2 from the App store then used Console to make a bootable installer for macOS on a 32Mb USB thumb drive. It appears to be working fine because it goes through the entire install process until the very end when an error message "macOS could not be installed on your computer" occurs.

    FULL MSG:
    "macOS could not be installed on your computer. An error occurred installing Mac OS. To use Apple diagnostics to check your Mac hardware, shutdown, press the power button, and immediately hold the "D" key Intel diagnostics begins" (see attached image).

    THINGS I'VE TRIED:
    - Ran the extended hardware test with Apple hardware test tool and "no trouble was found (see attached image).
    - Switching to a completely different freshly formatted hard drive—same error.
    - Internet recovery mode (grinds away for about an hour and the screen goes white (for hours) with no message).
    - Start in safe mode (does not work as there is no OS on the desk).
    - Reformatting 2 different hard drive multiple times (Mac OS Extended journal - GUID partition map).
    - Reset NVRAM, PRAM, and SMC (multiple times).

    MAC SPECS:
    MacBook Pro 15.4" - Late 2011
    Quad-Core Intel i7
    CPU Speed 2.20 GHz
    Display 1440x900
    Graphic: Intel HD Graphics 3000
    AMD Radeon HD 6750M
    8 GB Ram

    Anyone have any ideas? Appreciate the help.

    IMG_3195.jpg

    IMG_3196.jpg
     
  2. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    Almost certainly graphics failure. Do you have an Apple Store nearby so they can run some tests?

    The only other thing that would cause issues similar to what you described is faulty RAM, though that normally manifests by indefinitely installing the OS rather than outright failing at the end. So I’m convinced it’s GPU, especially as you’ve tried different HDDs and the 2011s are notorious for graphics failure.
     
  3. deadstk thread starter macrumors newbie

    deadstk

    Joined:
    Dec 19, 2017
    Location:
    San Francisco Bay Area
    #3
    If it is a GPU failure then I'm assuming that's a complete logic board replacement. (?)
     
  4. keysofanxiety macrumors G3

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Yeah but I wouldn't pay for the repair as the LBs are refurbs and will shortly exhibit exactly the same issues. The graphics are inherently faulty on that model.
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    OP:
    You are aware of "RadeonGate" insofar as it effects 2011 15"/17" MacBook Pros, is that correct? (mentioned above by keysofanxiety)

    If you come to the conclusion that a failed GPU (RadeonGate) is preventing the install, I think it limits you to these options:
    1. DON'T attempt to install High Sierra. Instead, run the OS you have running now, and just "be happy with it".
    2. Pay to get the logic board replaced. Apple won't do this anymore. Probably not worth the cost at this point, because the replacement boards have the same likelihood of failure as do the originals. This is the worst of these three options.
    3. Start shopping for a replacement.

    If the MBPro is still running "well enough" otherwise, I would suggest:
    1. If you don't have an SSD in it, install one. Replacing the platter-based HDD with an SSD will make a far FAR greater improvement in performance than ANY OS upgrade. Anyone can do this install with the right tools.
    then...
    2. Stick with whatever version of the OS works, until the machine gives up the ghost.
     
  6. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #6
    One of the best first posts (in a thread) I've ever seen! Covers all the bases.
     
  7. uzer42 macrumors newbie

    Joined:
    Apr 22, 2015
    #7
    um so much wrong with this thread. if the machine booted into and operating system before and still boots into any operating system that would lead me to think its not a video card issue. Even though this year machine is known for a bad video chip.

    i would try formating the drive in the defualt afps file format then running the installer again.
    should that not work try running the installer from internet recovery( have to be plugged into ethernet port)
     

Share This Page

6 December 19, 2017