MacOS Mojave - my Mac should be compatible?

paulc130

macrumors newbie
Original poster
Oct 2, 2018
4
0
The information page from the app store states that I need to have OSx 10.8 or later. I am currently using High Sierra and my version is 10.13.6 I would imagine my version is later than the minimum requirement but when I try to download Mojave it says my system is incompatible. Any ideas???
 

chscag

macrumors 68040
Feb 17, 2008
3,699
1,270
Fort Worth, Texas
Which Mac do you have? Model and year? It's not the version of macOS you currently are using that determines whether or not you can install Mojave, it's the model and year of your Mac that is the determining factor.
 
  • Like
Reactions: HenryDJP

paulc130

macrumors newbie
Original poster
Oct 2, 2018
4
0
Which Mac do you have? Model and year? It's not the version of macOS you currently are using that determines whether or not you can install Mojave, it's the model and year of your Mac that is the determining factor.
iMac (21.5-inch, Mid 2010) - I'm guessing by the date it's not going to be compatible. I assumed that when it asked for minimum version requirements that's exactly what it meant.
 

DeltaMac

macrumors G4
Jul 30, 2003
10,254
2,693
Delaware
https://support.apple.com/en-us/HT201475
There are some exceptions, but generally, you need a Mac introduced in mid to late 2012 to be compatible with 10.14 Mojave. An iMac needs to be a Late 2012 for Mojave.

If you want to play around with Mojave anyway, then it is possible with a patcher app like "DOSDude"
http://dosdude1.com/mojave/
According to that page, when running from Mojave, the graphics is almost unusable on that iMac model.
 

paulc130

macrumors newbie
Original poster
Oct 2, 2018
4
0
https://support.apple.com/en-us/HT201475
There are some exceptions, but generally, you need a Mac introduced in mid to late 2012 to be compatible with 10.14 Mojave. An iMac needs to be a Late 2012 for Mojave.

If you want to play around with Mojave anyway, then it is possible with a patcher app like "DOSDude"
http://dosdude1.com/mojave/
According to that page, when running from Mojave, the graphics is almost unusable on that iMac model.
Thanks for your help, I really appreciate it. I guess I should upgrade but I like my Mac with the integrated disc player/reader. I don't think the recent Macs have them anymore.
 

chscag

macrumors 68040
Feb 17, 2008
3,699
1,270
Fort Worth, Texas
Thanks for your help, I really appreciate it. I guess I should upgrade but I like my Mac with the integrated disc player/reader. I don't think the recent Macs have them anymore.
That's your choice of course, however, my last two iMacs did not have an optical drive. I have two external optical drives that I use and find them to be adequate for those times when they are needed. Apple internal optical drives are troublesome in that they break very easily which makes me happy that they are no longer included.
 

bbnck

macrumors 6502a
Mar 19, 2009
567
311
High Sierra should continue to receive security updates for the next few years so you don't need to buy a new iMac right away. Unfortunately Apple does not announce when they discontinue security updates for older macOS releases but the community has generally found it to be around three years after their initial release. Since macOS High Sierra was released a year ago, it'll likely continue to receive security updates until the summer of 2020. Not guaranteed though.

As a guideline, OS X El Capitan (version 10.11) was initially released in September 2015 and last received a security update in July 2018 and is probably the last security update it will receive. Likewise, OS X Yosemite (version 10.10) was initially released in October 2014 and last received a security update in Jul 2017. As you can see, there is a pattern of just under three years before Apple quietly stops support for older releases.

As chscag mentioned, you can always buy an external disc player that plugs into an iMac via an available USB port if when you upgrade to a newer iMac, you still need to use disc media once in a while. It's just obviously an extra expense to consider when you think about upgrading.
 
Last edited:

paulc130

macrumors newbie
Original poster
Oct 2, 2018
4
0
High Sierra should continue to receive security updates for the next few years so you don't need to buy a new iMac right away. Unfortunately Apple does not announce when they discontinue security updates for older macOS releases but the community has generally found it to be around three years after their initial release. Since macOS High Sierra was released a year ago, it'll likely continue to receive security updates until the summer of 2020. Not guaranteed though.

As a guideline, OS X El Capitan (version 10.11) was initially released in September 2015 and last received a security update in July 2018 and is probably the security update it will receive. Likewise, OS X Yosemite (version 10.10) was initially released in October 2014 and last received a security update in Jul 2017. As you can see, there is a pattern of just under three years before Apple quietly stops support for older releases.

As chscag mentioned, you can always buy an external disc player that plugs into an iMac via an available USB port if when you upgrade to a newer iMac, you still need to use disc media once in a while. It's just obviously an extra expense to consider when you think about upgrading.
[doublepost=1539023535][/doublepost]Thankyou, I did not know about this. Very helpful! The optical drive issue is something that has put me off getting a new Mac as I like the built in one. I may have to bite the bullet in the future.
 

chscag

macrumors 68040
Feb 17, 2008
3,699
1,270
Fort Worth, Texas
Optical drives nowadays are a non issue since external units are inexpensive and work well. When was the last time you needed a floppy disk drive? LOL. :rolleyes:
 

Starman535

macrumors member
Apr 12, 2018
34
4
iMac (21.5-inch, Mid 2010) - I'm guessing by the date it's not going to be compatible. I assumed that when it asked for minimum version requirements that's exactly what it meant.
Don't sweat it. This OS from Hell bricked my 2015 2.5 GHz I5 (16 gb RAM) by deleting all account passwords.
 

Starman535

macrumors member
Apr 12, 2018
34
4
The information page from the app store states that I need to have OSx 10.8 or later. I am currently using High Sierra and my version is 10.13.6 I would imagine my version is later than the minimum requirement but when I try to download Mojave it says my system is incompatible. Any ideas???
Probably depends more on the amount of available RAM. When I bought my MacBook Pro in 2015, I immediately upgraded it to 16 Gb from the stock 4 gb to improve performance. Unfortunately, upgrading to Mojave erased my login passwords, so no account worked and I had a brick. Re-installed High Sierra from backup to regain functionality.
 

chscag

macrumors 68040
Feb 17, 2008
3,699
1,270
Fort Worth, Texas
Probably depends more on the amount of available RAM. When I bought my MacBook Pro in 2015, I immediately upgraded it to 16 Gb from the stock 4 gb to improve performance. Unfortunately, upgrading to Mojave erased my login passwords, so no account worked and I had a brick. Re-installed High Sierra from backup to regain functionality.
Nope. Refer to post #2. His machine is too old to install Mojave. His 2010 model does not support "Metal" and that's one of the requirements set by Apple. Available memory has nothing to do with it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.