macOs needs to repair your Library to run application

Discussion in 'macOS Sierra (10.12)' started by AdoTedo, Sep 22, 2016.

  1. AdoTedo, Sep 22, 2016
    Last edited: Sep 22, 2016

    AdoTedo macrumors newbie

    AdoTedo

    Joined:
    Sep 22, 2016
    #1
    just update from OsX 10.11 to macOs Sierra. After rebooting I keep getting this message: "macOs needs to repair your Library to run application. Type your password to allow this."
    I google around a bit, but of course there is nothing about the last Apple Os.
    I already did a disk utility repair, which actually should also fix permission issue, but no luck.
    Many applications stuck like App Store, my Office 365, preference and so on
    I'm running out of idea, the only chance left is to reinstall everything but it's really my last option.
    Any idea?

    thanks
     
  2. KALLT macrumors 601

    Joined:
    Sep 23, 2008
  3. Halleluhjah macrumors newbie

    Joined:
    Feb 21, 2017
    #3
    What I did was to go into System Preferences and Users and Groups. Then in Login Options go to Edit the Network Account Server. Click on Open Directory Utility. Click on Active Directory. Click on the little arrow on the left side of this window to unhide. Make sure the following are checked: 'Create mobile Account at login'. 'Force local home directory on startup disk', 'Use UNC from the Active Drectory to derive network home location, Network protocol to be used: smb',' Default user shell: /bin/bash'. Uncheck 'Require confirmation before creating a mobile account.'

    Hope this helps!
     
  4. stooovie macrumors 6502a

    Joined:
    Nov 21, 2010
    #4
    Wouldn't that create some kind of roaming user account? I'd go the simpler route of just creating a new user account the normal way. That should fix OP's issue.
     
  5. cswifx Suspended

    cswifx

    Joined:
    Dec 15, 2016
    #5
    I'll suggest making a new user account too. If the problem persists it's better to start from scratch, in particular if you've ever modified any system files on a previous version of macOS.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    This is not the correct process to resolve this with a computer that is not on a corporate network.
     
  7. cpenna macrumors newbie

    Joined:
    Mar 8, 2017
    #7
    I had this scenario this morning but it was after using the migration tool.
    most of the Library files had the 'owner' and 'group' as numbers (i.e no longer linked to the actual user account logged in)
    Open terminal. do ls -al in the home directory and see what you can see. You may find something like this (i've only pasted some for the purposes of illustration
    C02NL05EF8J2:~ cpenna$ ls -al
    total 240
    drwxr-xr-x 31 cpenna LTU\Domain Users 1054 Mar 8 11:58 .
    drwxr-xr-x 9 root admin 306 Nov 21 11:50 ..
    -r-------- 1 cpenna LTU\Domain Users 7 Sep 22 09:19 .CFUserTextEncoding
    -rw-r--r--@ 1 cpenna LTU\Domain Users 22532 Mar 8 11:30 .DS_Store
    drwxrwxr-x 2 root LTU\Domain Users 68 Aug 27 2015 .InstallAnywhere
    drwx------ 2 cpenna LTU\Domain Users 68 Mar 8 11:33 .Trash
    drwx------@ 66 37682 37682 2244 Sep 27 09:04 Library
    drwx------+ 9 cpenna LTU\Domain Users 306 Jan 27 2016 Movies


    To fix this, do the following (replace username & groupname to match your system)
    sudu chown -R username ~/Library
    sudo chgrp -R groupname ~/Library


    Hope this helps
     
  8. Mork macrumors 6502

    Joined:
    Jan 9, 2009
    #8
    I keep having this issue. But after I reboot with the "MacOS needs to repair your library" message, I get a two text box login (Sierra Mac Server OS, latest, June 22, 2017) and nothing I enter works. I have to restore the entire machine from backup!

    Also, when I got the dialog about needing to repair the library (before I rebooted and couldn't get back in), it puts my user name in the name field, but the password doesn't work, either. Also tried the SU account, but nope.

    What in the heck is going on?

    The machine seems to get this weird corruption every few days!!!

    HELP!
     
  9. cpenna macrumors newbie

    Joined:
    Mar 8, 2017
    #9
    I'm assuming when you say password doesn't work, it's after logging in and a window pops up asking for password? If so, that's probably a keychain password. Can you run terminal? If so, you should be able to repair permissions from there and gain some control back.
     
  10. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #10
    Are you trying to sign in to the server with an Open Directory or Active Directory account? If so, don't do that; make a local administrator account on the server and sign in with that.
     
  11. Create1314, Sep 11, 2017
    Last edited: Sep 11, 2017

    Create1314 macrumors newbie

    Joined:
    Sep 11, 2017
    #11
    Brand new IMac. Did the migration. Everything worked - eventually. Now have the "macOS needs to repair you Library to run applications." Populates with the UN but my password won't work and it won't "Cancel". Everything else working fine. This is a stand alone computer - not on a network server. Is there a simple answer? Mac Sierra 10.12.6

    Ran "First Aid" tab after opening Disk Utilities at Applications>Utilities>Disk Utilities - was able to cancel the error message.
    --- Post Merged, Sep 11, 2017 ---
    Same problem on brand new IMac that is stand alone. Everything migrated and works fine then the same error message. I was able to cancel the message by running First Aid. Open Disk Utilities at Applications>Utilities>Disk Utilities and click on First Aid tab. Run First Aid.
     

Share This Page