Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

InformationLandmine

macrumors newbie
Original poster
Jul 18, 2017
6
1
I've had this problem for years, and I had hoped it would be solved by now. I just got a new 27" iMac (running Catalina). The only reason I even want to have wifi enabled is to unlock the iMac with my watch. However, with wifi enabled, MacOS seems to prefer it over the wired connection for random things, dramatically reducing the speed of things. Two examples are copying files to/from my NAS, and Airplay screen mirroring to Apple TV.

If I start copying a file from my NAS and I see that it's going slow, I can turn off wifi and the copy stalls, so it doesn't even gracefully handle hand-off between the connections either. Same with Airplay... shut off wifi and the Airplay stops. I got the 10gbe option specifically to have a super fast connection to my NAS, and it's super frustrating that MacOS randomly decides to use wifi instead when making a connection. It is not consistent... sometimes it will use the wired connection.

I first noticed this problem with my 2017 MBP, so I would shut off wifi every time I docked it. I had kind of hoped that the issue was related to using a dock since the wired connection wasn't always there. I really like the convenience of unlocking with my watch, but now I've had to turn of wifi and live without this feature.

Does anybody have any suggestions for dealing with this?
 

Taz Mangus

macrumors 604
Mar 10, 2011
6,785
2,569
Open System Preferences→Network, click on the gear symbol at the bottom (next to + -), click on Set Service Order.... Drag the wired connection above WiFi.

Screen Shot 2020-09-05 at 10.23.38 AM.png
 

InformationLandmine

macrumors newbie
Original poster
Jul 18, 2017
6
1
Open System Preferences→Network, click on the gear symbol at the bottom (next to + -), click on Set Service Order.... Drag the wired connection above WiFi.

Sorry, I should have mentioned that the wired ethernet connection is already the highest priority. Same with my 2017 MBP.
 

KALLT

macrumors 603
Sep 23, 2008
5,229
3,285
Do you have to be connected to a Wi-Fi network at all?

It was my understanding that the devices communicate directly over the Wi-Fi antenna, not indirectly via the router.
 

InformationLandmine

macrumors newbie
Original poster
Jul 18, 2017
6
1
Do you have to be connected to a Wi-Fi network at all?

It was my understanding that the devices communicate directly over the Wi-Fi antenna, not indirectly via the router.

Thank you! That solved the unlocking issue.

It's still frustrating the the service order doesn't seem to always apply. I think Apple has a lurking bug there...
 

Taz Mangus

macrumors 604
Mar 10, 2011
6,785
2,569
Thank you! That solved the unlocking issue.

It's still frustrating the the service order doesn't seem to always apply. I think Apple has a lurking bug there...

I have read where it appears that people all the way back in OS X 10.9 were also experiencing issues with the network prioritization of WiFi over Ethernet.
 

InformationLandmine

macrumors newbie
Original poster
Jul 18, 2017
6
1
Well, unfortunately it's still annoying because every time I wake the computer up from sleep there is a dialog saying "None of your preferred networks are available" and is prompting me to join a wifi network. Does anybody know how to disable this dialog?

Edit: I unchecked "Ask to join new networks" in network preferences. I'll see if that stops it.
 
Last edited:

manhas

macrumors newbie
Sep 30, 2021
6
0
Anyone with updated insights how this can be fixed? Or if there's an easy way to determine when macOS have started to use the WiFi instead of the ethernet?

I've had this issue for years, across multiple macOS versions and with different devices. The priority order is correct, and if I toggle the WiFi on/off macOS will correctly prioritize ethernet and this persist after rebooting or waking from sleep. But occasionally, without any real pattern, macOS will start to use the WiFi instead of ethernet and this happens frequently enough to create a problem for me.

I usually discover it when I experience slow connections on the local network or if I'm unable to ping (any) remote host. If I turn off the WiFi, everything will immediately start to work again at full speed and all the hosts I couldn't reach are accessible. So I assume that macOS was using the WiFi instead of the ethernet and that the WiFi was for whatever reason slow or down.

I use airdrop frequently and I need WiFi turned on to use it, if it wasn't for airdrop I would just turn off WiFi and forget about this.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.