macOS Sierra Beta 2 Black Screen

Discussion in 'macOS Sierra (10.12)' started by kyler, Jul 7, 2016.

  1. kyler macrumors newbie

    Joined:
    Feb 14, 2016
    #1
    Tried updating to macOS Sierra Beta 2, Mac restarted and reached login screen, upon logging in just goes to black screen,not sure if turned off or just hanging somewhere, any ideas?

    Tried Disk Utility First Aid, still no luck - think I should restore from backup?

    iMac 5k Retina 27-inch
     
  2. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
  3. kyler thread starter macrumors newbie

    Joined:
    Feb 14, 2016
    #3
    Hey there,

    I haven't tried, I ended up restoring from a backup I had on beta 1. Will try and update again once restored, thanks for the reply.
     
  4. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #4
    No problem. Could be completely unrelated, but some weird kernel extension issues were causing some of us on B2 to not wake from sleep. The issue didn't occur in Safe Mode, so we were able to isolate down to some kexts (in my case from Duet Display, but it seems that any non-Apple kext can cause this to happen).

    Figured Safe Boot might be worth a try in your case as well, but proceed at your own risk! I know updating/restoring can be super time consuming.
     
  5. hugocésar macrumors newbie

    Joined:
    May 13, 2016
    #5
    I'm having the same issue. I uninstalled Duet Display and Paragon NFTS but I'm still having the issue. I don't think I can keep being on Sierra for now cause of this.
     
  6. lars06, Jul 8, 2016
    Last edited: Jul 9, 2016

    lars06 macrumors newbie

    lars06

    Joined:
    Jul 8, 2016
    #6
    I have uninstalled both Duet Display and f.lux, and still no luck. Has anybody had luck with another method? I can't revert back to El Capitan so I need to fix this!

    EDIT: Fixed! I uninstalled Duet Display properly and it worked. For those struggling, CleanMyMac or AppDelete aren't good enough for this one. Go into Duet Display settings and press uninstall. You will need to restart your computer because it deletes the display driver.
     
  7. crawltochina macrumors member

    Joined:
    Apr 27, 2015
    #7
    I have the problem that I deleted DuetDisplay with AppCleaner and I cannot reinstall it for the proper uninstall. If I reinstall it the symbol starts flickering in the system tray but I cannot access the menu for uninstalling. Does anyone have an idea how to reinstall duet display or get rid of the kernel extension?
     
  8. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #8
    Check /Library/Extensions/DuetDisplay.kext and trash it.

    If you're having trouble locating it in Finder you can try this terminal command

    sudo kextunload /System/Library/Extensions/DuetDisplay.kext
     
  9. crawltochina macrumors member

    Joined:
    Apr 27, 2015
  10. betito72 macrumors newbie

    betito72

    Joined:
    Jul 10, 2016
    #10
    Thanks finally after 4 days I can solve the problem
     
  11. f_riess macrumors newbie

    f_riess

    Joined:
    Jul 11, 2016
    Location:
    Singapur
    #11
    What can I do if even a force-restart doesn't bring my display back. Background light works etc. But screen is still black, starting chime also there. But a black screen. Resetted SMC and NRAM etc. Nothing works. Can't access.....
     
  12. blasto2236 macrumors 6502a

    Joined:
    Nov 4, 2012
    #12
    Does the screen work in Safe Boot? If so, it's likely a kernel extension causing your issue as well. If not, it may just be your display. That happened to me on the first iMac I ever owned, right out of the box. Took them a bit of digging to figure it out, they first replaced the logic board. But that didn't fix the problem and they narrowed it down to the display itself.

    So, if you don't see any picture in Safe Boot, it could be a display issue that's unrelated to the beta.
     
  13. f_riess macrumors newbie

    f_riess

    Joined:
    Jul 11, 2016
    Location:
    Singapur
    #13
    Yes, it is probably a display issue. Get over the Diagnostic Tool the issue code: VFD002, something with the display.
    And they changed my display last week through the Apple Store. Good Job....:mad:
     
  14. shayneo macrumors newbie

    shayneo

    Joined:
    Jul 15, 2016
    #14
    having the EXACT same problem. I try the terminal command but get this message:

    Can't open CFBundle for /System/Library/Extensions/DuetDisplay.kext.

    Can't create /System/Library/Extensions/DuetDisplay.kext.
     
  15. Avarix macrumors newbie

    Avarix

    Joined:
    Mar 27, 2007
    Location:
    Norristown, PA
    #15
    sudo kextunload -b com.karios.driver.DuetDisplay to unload the kext and then remove both /Library/Extensions/DuetDisplay.kext and DuetDisplay.app in the Applications folder. After a reboot you should be good to go.
     
  16. LucMetSkirreMac macrumors newbie

    LucMetSkirreMac

    Joined:
    Jul 22, 2016
    #16
    I was having the same thing, I don't know what I did but it solved the problem :)

    I restarted my mac, and try to login , after that, the loading bar beneath my Password-Insertion-Thing froze, so I restarted my mac again , with as result that my Loading Bar froze for a few secs, the screen went black and after a few seconds I was at my Desktop :)\

    I am sory for my english .
     
  17. rondo117 macrumors newbie

    rondo117

    Joined:
    Jul 25, 2016
    #17
    How can you turn on terminal without logging in password?
    I tried command S but it gave me Kxt com.karios.driver.DuetDisplay not found for unload request.

    Please help me. I forgot to back up the data.
    Thanks
     
  18. apfelfreak32 macrumors member

    apfelfreak32

    Joined:
    Dec 5, 2010
    #18
    Did they fix this? Btw. after uninstaller Duet the problem wasn't solved for me. There mus be something else... Scared to upgrade because of this black screen issue it would mean hour of reinstalling the backup...
     
  19. ad931 macrumors regular

    ad931

    Joined:
    Sep 1, 2013
    Location:
    Athens, Greece
    #19
    i have exactly the same issue as of this morning. i know my Mac mini is "working" because its "warm" to touch
    --- Post Merged, Nov 9, 2016 ---
    i should add that i have the start up chime, i don't have the apple logo, have reset the SMC & NVRAM as per Apple support document, no result. Have also tried using "Shift" , Command S, no result. I am stuck on a black screen...

    Is there anything else i can do????
     
  20. pipsqueaker macrumors newbie

    Joined:
    Nov 26, 2016
    #20
    Hi all,

    I'm having a similar issue with a black screen but i login to a user account. Can anyone help?

    A friend of mine has a new MacBook Pro 2016 with touch bar, and setup by migrating his user account from his old MacBook Pro via migration assistant. He also has another account on the MacBook which he setup before doing the migration. Both user accounts were working fine until he installed the 10.12.1 update and now when he logs into the user account that was migrated he gets a black screen with the cursor. The other user account works fine.

    I'm trying to help him and have tried to power the machine off and fire back up and holding shift to boot into safe mode but safe mode doesn't happen, it just boots back to the login screen. Recovery mode also doesn't happen, just boot back to black screen.

    Am I missing something here? Does the new MacBook Pro have a different method for booting into safe or recovery mode? Also is this the best approach to troubleshooting the issue? Where to go after safe mode?

    Is it best to boot into recovery and then re-install the OS and will this keep the user accounts intact? Or does the SMC need resetting?

    Thanks in advance
     
  21. Jimmyjamh macrumors member

    Joined:
    Aug 4, 2013
    #21

    I’m in the same boat as you now but with the High Sierra beta.
     

Share This Page